x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Shift + F1 should regain mouse control

In Play Mode Shift + F1 should regain mouse control. That doesn't work on my Mac. Where can I overwrite this setting to a different key combination?

Product Version: UE 4.12
Tags:
more ▼

asked Jun 08 '16 at 03:50 PM in Bug Reports

avatar image

rotwang
251 13 22 41

avatar image Steve Hardister ♦♦ STAFF Jun 09 '16 at 07:27 PM

Hi rotwang,

I was unable to reproduce this in UE4.12. following these steps:

  • Playing in Selected Viewport

  • In Yosemite

  • Macbook Pro (Retina, 15inch, Late 2013)

  • Selected Shift + F3

  • Result: Regains Mouse Control

Please check these steps and let me know what, if anything, you are doing differently.

Thanks,

Steve H.

avatar image rotwang Jun 09 '16 at 08:56 PM

Hi Steve,

when I click play, a message in the topleft corner says "Shift+F1 for Mouse Cursor" and then fades out. I tried Shift+F1 as well as Shift+F3, but only get the standard apple functions.

IMac OSX El Capitan.

Are those keys user-assignable? Can't find settings for this.

Thanks, Frank

avatar image Steve Hardister ♦♦ STAFF Jun 09 '16 at 09:28 PM

Hi Frank,

I've tested this on another Machine now, running El Capitan with a mouse plugged in and unplugged using the finger pad without results. Make sure you do not have Shift + F1 assigned as a hotkey in Editor Preferences>General>Keyboard Shortcuts.

-Steve H.

avatar image acxsasx Jul 24 '16 at 01:44 AM

In Play Mode, my shift+F1 has stopped working. It now sets the viewmode to Wireframe. I tried a different keyboard, same thing. Mouse X/Y stopped working. 4.12.5. Been using Unreal since March, first time this has happened.

Deleted .vs, Binaries, Intermediate, Saved directories. Still does not work.

I verified shift keys work in other programs. Tried deleting and readding the nodes.

Mouse works fine in Editor

Windows 10. C++ project.

I went back to a previous checkin in my source code to move forward.

aaaaannnnnndddd....found the problem.... Short answer: I unchecked the "Start with Tick Enabled" on my BluePrint that is based on my C++ Player Controller class (which inherits from APlayerController). Once I rechecked it, my mouse, shift+F1 works normally.

avatar image TigerFish89 Apr 11 '18 at 04:31 AM

Do you want show your mouse cursor in play game mode? In my case, Shift + F1 + fn work on Mac book pro.

avatar image GouthamMannuru Oct 27 '18 at 02:52 AM

I had same problem and if these above answers don't work do this , Zero the player transformations and it will work . this worked for me

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

HI Steve, then its just my computer, I have no hotkeys assigned, using the default preferences. I need to change the assignment to regain mouse control. Can't find settings for this.

Thanks, Frank

more ▼

answered Jun 11 '16 at 11:43 PM

avatar image

rotwang
251 13 22 41

avatar image Steve Hardister ♦♦ STAFF Jun 13 '16 at 02:36 PM

I have entered a request to have this tested on an iMac. A couple of more questions to help isolate the issue:

  1. Did this occur in previous versions of the Engine?

  2. Are you using an atypical or special mouse (ie. Magic Mouse)?

avatar image rotwang Jun 13 '16 at 03:42 PM

I tested this with the Basic demo on 4.10. Behaves the same. Im using std apple keyboard and a std non-apple mouse.

To be clear, the expected behaviour should be:

  1. Clicking Play ->change to hidden-cursor mode, mouse move controls the camera.

  2. "Shift+F1 for Mouse Cursor" should gain control back to the editors GUI, my desktop and other applications.

I recommend, that any mouse click outside the game window or at least outside the application window (when not playing fullscreen ), regains control.

avatar image Steve Hardister ♦♦ STAFF Jul 07 '16 at 02:18 PM

Your last question apparently didn't post so I'm quoting it here: "Because it's still not working for me, I'd like to ask again: Where can I overwrite the "regain mouse" setting? I want to associate it with a different key combination. Thank you."

If possible, you would set this under Editor Settings>Hot Keys, however, this is not a function you can assign a Hot Key to, as it is default behavior that is not intended to be modified.

I've run a test where I assigned Shift + F1 to replace F2 as the Hot Key combo to rename an asset. While successful, this did not interfere with the ability to press Shift + F1 to regain control of the mouse while in Play mode.

At this point, I'd suggest testing both your Shift key and F1 key to make sure that they are functional. Beyond that, we cannot fix an issue that we cannot reproduce in house and, at this point, I have tested this on multiple machines. Moreover, to my knowledge this is the only report of this behavior.

Lastly, the "non-apple" mouse may be the issue. Try unplugging the mouse, restarting your Mac, and retest this using the finger pad in lieu of a physical mouse to see if you can get the intended behavior.

avatar image rotwang Jul 07 '16 at 03:49 PM

OK so far, I appreciate your suggestions, thank you for your time (a different mouse did not change the behaviour, I might try a different keyboard)

avatar image FrederickD Mar 04 '17 at 08:37 PM

I have the same issue on a laptop. I need to hold the fn key to use function keys, but then shift F1 sets wireframe rendering.

Is this a command that can be set to a different hotkey ?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

This worked for me:

alt text

Then I clicked on the highlighted ‘Keyboard’ up there, and it brought me here:

alt text

Then I ticked on the last choice:

alt text

Hope this helps!

more ▼

answered Jul 08 '18 at 03:49 PM

avatar image

sanitary
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I had same problem and if these above answers don't work do this , Zero the player transformations and it will work . this worked for me

more ▼

answered Oct 27 '18 at 02:52 AM

avatar image

GouthamMannuru
6 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I had same problem and if these above answers don't work do this , Zero the player transformations and it will work . this worked for me

more ▼

answered Oct 27 '18 at 02:52 AM

avatar image

GouthamMannuru
6 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question