x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

BP Interface Function "Return Node" Bugged

So I have a BP interface with a function that has return pins and on all of the actor BPs it's used in they show up fine except for one.

Basically I don't know how to get the return node back with the pins for an interface function. I can only get a return node with no pins. alt text

UPDATE: So this turns out to be nothing more than a bug. I re-created the whole thing and now have no problems.

Product Version: UE 4.10
Tags:
problem.png (161.5 kB)
more ▼

asked Jun 09 '16 at 02:15 PM in Blueprint Scripting

avatar image

Thee MuffinMan
68 3 4 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

On the Details tab inside the function under the "Outputs" subsection hit New

more ▼

answered Jun 09 '16 at 02:27 PM

avatar image

Dodgin
351 7 5 32

avatar image Thee MuffinMan Jun 09 '16 at 02:35 PM

I can do that inside the BP interface function but it won't bring back the return node inside my actors interface function.

avatar image Dodgin Jun 09 '16 at 03:24 PM

Did you compile after? It wont show up until compile is done.

alt text

interface.jpg (92.8 kB)
avatar image Thee MuffinMan Jun 09 '16 at 03:28 PM

Yup. compiled, saved, closed and restarted.

avatar image Dodgin Jun 09 '16 at 03:26 PM

And the interfaced actor: alt text

ifaceactor.jpg (109.3 kB)
avatar image Dodgin Jun 09 '16 at 03:28 PM

Referencing from level: alt text

fromlevel.jpg (87.0 kB)
avatar image Dodgin Jun 09 '16 at 03:31 PM

If all else fails unset the interface, compile, save, reset the interface to the class, compile save - could be a bug

avatar image Thee MuffinMan Jun 09 '16 at 03:36 PM

That's actually a really good idea! but now things have gotten even weirder... I unset the interface and compiled and saved everything and now it wont add the interface at all. again only to this BP actor

avatar image Dodgin Jun 09 '16 at 03:40 PM

What do you mean by "wont add the interface" specifically? the interface is not available in the "Add Interface" auto-complete search bar?

avatar image Thee MuffinMan Jun 09 '16 at 03:42 PM

No it's there in the drop box, it just won't add.

I click add, I hover my mouse over the interface, I click, scroll box closes, "No Interfaces".

avatar image Thee MuffinMan Jun 09 '16 at 03:44 PM

alt text

p2.png (218.8 kB)
avatar image Dodgin Jun 10 '16 at 01:55 PM

My last suggestion would be to make a new BP, add the interface, and copy all vars/functions to the new one :(. Sometimes junk like this happens in BPs, and you should tag this as a bug report.

avatar image Thee MuffinMan Jun 11 '16 at 03:28 AM

Yea i've tried a few other tricks but it looks like it's just bugged. owell, thanks for the help.

avatar image Skifree Nov 02 '16 at 03:26 AM

I have this issue as well and it's incredibly annoying. At the frequency that it shows up, this should be triaged quickly.

I've tried recreating the function, refreshing nodes, restarting, etc...
I notice that when deleting and re-adding the return node, the outputs are removed unlike the inputs.

avatar image DKnox Jul 13 '17 at 12:10 AM

Why is this marked as resolved?? it still doesn't work. it works if all you are doing is sending an event but an interface with return data doesn't. I've been trying to get this working for a few hours now and I thought I was doing it wrong so I searched and found this. everything you have mentioned I've just experienced. even the Interface being displayed on the list but wont add. I also found one more thing. if I try to return one variable it doesn't show but if I add a second suddenly both pins show on the calling node. as soon as I add any kind of return variables it no longer shows the event nodes

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question