x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Dirty Shadows

Hi everyone,

i have a quite strange problem. I'm creating an interior/exterior scene and I have some shadow problems. I found many ways to fix them and in the beginning it worked very fine. So first here are my lighting settings:

Scene has: Directional Light (stationary) Sky Light (stationary)

World Settings:

Static Lighting Level Scale : 0.2 Indirect Light Bouces: 30 Indirect Lighting Quality 10 Indirect Light Smoothness 0.75

With this settings i'm able to have a very good look in my "light-lab level" where I can test the settings (no dirt, very smooth, even in very dark areas). Now I moved to my main scene with the same settings, same meshs and light map resolutions! (512 or sometimes 1024). And it get this:

alt text

Whats going on there? Is it possible that a bigger and larger scene needs a different light setting? Do you have an idea?

Greets Chris :-)

Product Version: UE 4.11
Tags:
more ▼

asked Jun 10 '16 at 04:41 PM in Rendering

avatar image

HWDESIGN
17 5 7 10

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

this page contains all information you need about lighting troubles link text

more ▼

answered Jun 10 '16 at 07:06 PM

avatar image

saeedc
2.4k 73 43 108

avatar image HWDESIGN Jun 10 '16 at 10:06 PM

Well i checked this site befor. And as you can see i'm using Even better Lightningsettings as in this article. So thats the reason why i can't understand where these problems come from...

avatar image saeedc Jun 10 '16 at 10:57 PM

you need to change these things

Indirect Lighting Quality

Indirect Lighting Smoothness

Num Indirect Lighting Bounces

All in world setting

avatar image saeedc Jun 10 '16 at 11:01 PM

change the light map resolution of that wall with bad shadows

avatar image saeedc Jun 10 '16 at 11:05 PM

open wall mesh and under static mesh settings you will see light map resolution of that wall

avatar image saeedc Jun 10 '16 at 11:13 PM

use a lightmassimportance volume

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Well okay .. here are two pictures. As i said: both levels have the SAME Settings in World and the same lights in level. The geometry for this room is also the same with the same Light Map Resolution. But as you can see there is a huge difference.... Its not only this one wall. Many Objects have this Problem in my main scene. Once again here are my settings:

  • Static Lighting Level Scale : 0.2 Indirect Light Bouces: 30 Indirect Lighting Quality 10 Indirect Light Smoothness 0.75

Light Test Scene : Everything is fine: alt text

Main Scene: Dirty Shadows: alt text

Greets Chris

more ▼

answered Jun 10 '16 at 11:18 PM

avatar image

HWDESIGN
17 5 7 10

avatar image saeedc Jun 10 '16 at 11:36 PM

it is really cool .

every little object in your scene have their own lightmap settings take a look at them one by one. something maybe broken.

it is as if you have used different materials for those chairs :D

avatar image HWDESIGN Jun 11 '16 at 05:53 AM

Well i had a closer look at my objects and i didn't override the Lightmap Resolution in the Level Editor. The Chair (in both Scenes) has a Resolution of 1024.... And yes of course I'm using an importance volume...

And the material is nearly the same. only roughness is set to 0.9 in the Main Scene. But also walls like in the first picture with the same material having this problem :-(..... Or is there a internal Crash for this Level, so Lightbuilding in this quality isn't possible?

avatar image saeedc Jun 11 '16 at 07:48 AM

I already experienced this lighting problem but lighting trouble shooting guide solved my problem.

the only other thing that I can say is use a higher quality build. it is set to preview by default

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I'm using the high Quality Setting. I will reset all my lights and will Build the Level on monday. I saw That i have 570 unbuild objects, if ichange the Lightning. Are ~ 600 objects too much ?

more ▼

answered Jun 11 '16 at 01:50 PM

avatar image

HWDESIGN
17 5 7 10

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question