x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Launch to Mobile crashes on Open Level

Hello, I am currently testing level progression on Android (Asus Google Nexus 7 2013) and any time I use an Open Level call (such as a kill volume to respawn the player or to progress to the next level) the game crashes on my touch device. It doesn't even matter if the Open Level is told to open the same level currently being played. What would cause this crash and how can I resolve it? Where can I find any dumps to submit for help?

Thanks

Product Version: Not Selected
Tags:
more ▼

asked May 14 '14 at 06:27 AM in Bug Reports

avatar image

kingkeoua
221 25 25 201

avatar image kingkeoua May 15 '14 at 06:19 AM

pinging for response

avatar image kingkeoua May 16 '14 at 06:28 AM

and another bump

avatar image brianheagney Jun 07 '14 at 12:20 AM

Well, just so you know, I'm also curious about opening new levels on a mobile device. When I use the "mobile preview", I can switch from level to level, but when I actually put it on my tablet, it keeps opening up Level 1. It doesn't crash, but it doesn't work either.

avatar image kingkeoua Jun 07 '14 at 03:19 AM

Yes, this is exactly what I'm seeing. I have posed this question to both Packaging and Deployment and to Bug Reports with zero responses. Is there an Unreal support moderator who can respond please?

avatar image brianheagney Jun 08 '14 at 05:56 PM

I can't do it now, but when I get back to work tomorrow I'm going to download Swing Ninja and see how they do it. I just downloaded it here at home, and successfully deployed it to my kindle fire hdx. It uses three levels and relies on the open level function.

So, I'm going to study the Swing Ninja blueprints and see if I can find a solution. Good luck to you, too.

avatar image brianheagney Jun 09 '14 at 04:51 PM

Ugh. I spent the morning working in the Swing Ninja project. I created a new map (with the sky and ground), called it "Heagney" and saved it inti the Swing Ninja project folder (with the other maps).

Then, I merely went into the Level Blueprint for the P_Starting map, changed the "Open Level" to "Heagney" (instead of "P_City2").

Again, this all works in the emulator, and when I pressed the button to go to Level 2, the map successfully switches to my new "Heagney" level.

However, when I package it up and sent it to my mobile, when I click on the button for Level 2, the intro map resets - it never goes to my "Heagney" map.

I'm thinking that there must be some setting that has to be configured on the maps for the next levels...but I have no idea what that would be. I've gone through the world settings for the Swing Ninja P_City1 and P_City2 and can't figure out what I'm doing wrong.

So, I'm going to try to build my entire app in one level. Seems silly, but I can't figure out how to load the next freaking level!

avatar image kingkeoua Jun 09 '14 at 04:53 PM

Yeah i haven't tried fully packaging but that would still be pretty bad if you had to package every time you wanted to test some level progression.

avatar image Tim Hobson ♦♦ STAFF Jul 01 '14 at 09:11 PM

Hi Ahopps01,

Are you still having the crash with the latest version of the engine (4.2.1)?

What version of the engine are you working off of if it's not the latest?

Can you provide the crash log for us to take a look at? You can find it by following the information below.

If you are experiencing a crash, then please provide us with the .LOG and .DMP files from your [project]\Saved\Logs folder. Additionally, you can please send us the CrashReportClient.log file located in C:\Program Files\Unreal Engine\4.0\Engine\Programs\CrashReportClient\Saved\Logs.

On a Mac, the logs are located in: /Users/UserName/Library/Logs/Unreal Engine/(project name)Editor/ The Library Folder is hidden by default. The easiest way to get to it is by having finder the active application and while holding Option Click Go in the Mac Menu Bar. This will expose Library.

Thank you!

Tim

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi,

Since we've not heard back from you in a while I'm going to mark this as resolved for our tracking purposes. If you are still experiencing the issue you can post the above requested information and I will take a look.

Thank you!

Tim

more ▼

answered Jul 07 '14 at 03:45 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 888 103 879

avatar image kingkeoua Jul 07 '14 at 04:10 PM

Thanks Tim, we have not yet updated our project to 4.2 (traveling during World Cup) but will do so this week and get back to you. Hopefully it resolves itself, otherwise I will reply with the crash logs.

Thanks again

avatar image hq231 Sep 20 '14 at 05:35 PM

If anyone has figured out a solution to this problem I would be very interested in reading about it because I am having this exact issue. So if anyone has please post about it

avatar image ByronBBB Oct 08 '14 at 12:53 AM

I am having this issue also on iOS. Open Level works fine in Mobile Preview, but when I Launch on my device, it starts the level load, but only shows the original level.

I'm using 4.4.3.

Hoping there is an answer out here somewhere.

avatar image ByronBBB Oct 08 '14 at 01:08 AM

I found an answer to my version of the problem on another thread...see answer below.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I was having this issue and found an answer on another thread that fixed it for me. The trick was to add this to the DefaultEditor.ini file in the Config folder of your project:

[AlwaysCookMaps] +Map=/Game/Maps/MyMapName

more ▼

answered Oct 08 '14 at 01:08 AM

avatar image

ByronBBB
27 3 5 12

avatar image germ1389 Oct 21 '14 at 10:35 AM

Where exactly do you place that? inside UE4 or outside in a source file? I'm having this issue with 4.5.0 and everything works on the PIE, but the Launch and Package apk. doesn't work.

avatar image [Epic] Gribbs ♦♦ STAFF Oct 21 '14 at 03:12 PM

Howdy Germ1389,

If you open up your project folder in Windows Explorer, In the config file of the Project, You should see a DefaultEngine.ini file. (Located by following this route: C:\Users\First.Last\Documents\Unreal Projects(Name of Project)\Config)

When you open up that text file, Add this to the bottom of the file:

  [AlwaysCookMaps]
     +Map=/Game/Maps/MyMapName

Let me know if this helps you with your issue.

Thanks and have a great day!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question