x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Shaders compile on play after compiling in editor

Hello potential problem solver, After my shaders are seemingly done compiling and I click the play button, about 200 shaders have to compile, forcing me to quit the play session. After waiting for them to compile I can repeat the process endlessly and there will always be compiling after I click play, even if it has finished compiling before the play session.

I am using a number of material functions for dynamic, weather dependant effects such as snow and humidity effects on opaque materials and did not have this behaviour before I implemented those functions into just one or two of my materials, however, this compiling on play did not occur immediately after, but only a few days on for no apparent reason for no changes were made to those functions, so I suppose this paragraph was a waste of your time, apologies.

As it stands now I am unable to test play any of my levels with proper compiled shaders, because even if they are done compiling, as soon as I hit play they will start compiling again, this is the core of my problem.

I would like to know potential reasons for such undesired behaviour having found nothing similar on the web. Adding a potential problem fix is desirable. If you have a similar problem leave a note please.

P.S. I am now going to force clean recompilation of everything by deleting some folders with old cache, if you see no subsequent post to this thread by me, the problem remains and I'm still eager to find a solution from your end.

On top of the above I would like to remind to whoever may have the power to do something about it that foliage overdraw is still causing very, very noticeable lag and since this issue is rather old and specific to unreal engine, I assume its about time to do something about it, especially if you would like UE to be at least close to adequate in that regard compared to other popular, mass accessible engines. Currently me and I assume many others have a face-slap choice: ugly grass or no grass, this is in 4.12 with the rather new two-sided shader model, overdraw lag persists ladies and gents.

Product Version: UE 4.12
Tags:
more ▼

asked Jun 10 '16 at 09:29 PM in Using UE4

avatar image

Polivantage
66 1 6 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Issue was a combination of my functions in one of the materials, the shaders no longer compile on play.

more ▼

answered Jun 12 '16 at 01:58 AM

avatar image

Polivantage
66 1 6 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question