x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Speeding up Intellisense on VS2015

Is there any way to speed up Intellisense on VS2015? The machine I'm working on has SSD and 32 GB RAM, there must be some configuration that can utilize these features to speed up the Intellisense.

Product Version: UE 4.12
Tags:
more ▼

asked Jun 11 '16 at 06:27 AM in C++ Programming

avatar image

UnTraDe
21 2 4 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

You can use precompiled headers, it wont make it instant but should take ~1 second tops.

To do this:

1) Open your .sln

2) Project -> ProjectName Properties

3) Select either All Configurations or the ones you want to use

4) Configuration Properties -> NMake -> Additional Options

5) Enter: /Yu and press OK or Apply.

6) Wait until the 'working' symbol goes away, the intellisense should be much faster now.

alt text

more ▼

answered Jun 11 '16 at 07:27 AM

avatar image

Vaei
596 28 24 52

avatar image UnTraDe Jun 11 '16 at 07:29 AM

Thanks for the replay! Should I do this on my project or the UE4 project under the same solution?

avatar image Vaei Jun 11 '16 at 07:45 AM

I've been putting it under my own project. Not sure what difference putting it in the UE4 project would make if any.

avatar image UnTraDe Jun 11 '16 at 11:22 AM

Isn't the longer times caused by processing the large amounts of headers in the UE4 project?

avatar image Vaei Jun 11 '16 at 11:25 AM

Yeah. You can put them in either, I was more saying I'll not aware of any drawbacks from putting them in your own.

avatar image jayice Jun 11 '16 at 11:25 AM

I tried using this option as well /Yu and the issue of, when I change one of my own header (.H) files, intellisense (intellistupid), is still going through all header files of the engine, which I have never changed.

avatar image Vaei Jun 12 '16 at 08:44 AM

I haven't had any issue myself, but you can try adding it to the properties for UE4 instead of your own project. Both have worked fine for me, it might solve it for you.

avatar image arcturgray Mar 19 '17 at 09:30 AM

hi. don't know if this is still relevant, but I had the same issue and have found solution (not perfect though). Instead of /Yu you should write /YcYourProjectName.h /YuYourProjectName.h

Note that there is no space between /Yc and name, same for /Yu.

But after that you should use Unreal Editor to compile, because when using Build bttn in VS, there are errors.

p.s. sorry for english.

avatar image darkgaze Feb 16 '18 at 04:51 PM

How do you make it ignore the debug symbols? / sources of the engine?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

This is a old post, but I thought I would comment my solution anyways. I found out that Microsoft Security Essentials (Windows Defender) slows down Intellisense and make it generally unusable or at least painfully slow. To solve the problem you can add an Exception processes to Security Essentials, which makes MSE not to monitor behaviour of those processes.

To add exception process, go to:

Microsoft Security Essentials -> Excluded processes -> Browse -> Find the devenv.exe or WDExpress.exe from your computer -> Press Add button -> Press Save Changes

I also added some other Visual C++ processes such as vcpkgsrv.exe and cl.exe as exceptions. After reboot intellisense ran so smooth I think I've had this problem all the time but it wasn't so severe I didn't really need to fix anything.

Hope this helps someone who is struggling with painfully slow Intellisense.

(Note: Computer in question had SSD, 3.5GHz dual core CPU and 8GB of RAM.)

more ▼

answered Dec 12 '16 at 01:41 AM

avatar image

veheluuk
41 3 8

avatar image Lhorkan Mar 09 '17 at 08:02 AM

Oh man, this just made my day. It makes all the difference in the world, whereas adding /Yu did not seem to do much at all. Thanks for this!

avatar image veheluuk Mar 17 '17 at 06:24 AM

You're welcome. I still can't believe it was something that unrelated that made Intellisense completely unusable. Spread the word mate!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question