x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaged Build crashing when activating particle system with instanced parameters

Hi, after upgrading to 4.12.2 our packaged build crashes. This happens when activating/enabling a particle system via trigger that uses instanced parameters. I made a blueprint to create a particle volume, initial location and spawn rate gets set by instanced parameters in the construction script of the blueprint. When either activating the particle system by a trigger or enabling the particle emitter, packaged builds crash at this line:

Assertion failed: IsInGameThread() [File:D:\Build\++UE4+Release-4.12+Compile\Sync\Engine\Source\Runtime\Engine\Private\Particles\ParticleComponents.cpp] [Line: 6385]Crash in runnable thread TaskGraphThreadNP 1

I reproduced this error in a clean FirstPersonExample project.

Any help would be appreciated. Thanks

Product Version: UE 4.12
Tags:
more ▼

asked Jun 12 '16 at 05:07 PM in Bug Reports

avatar image

m4d3
26 2 6

avatar image m4d3 Jun 12 '16 at 05:14 PM

here is a screenshot of the blueprint: alt text

instancedcrash.jpg (298.8 kB)
avatar image Sean L ♦♦ STAFF Jun 13 '16 at 02:42 PM

Hello,

  • Could you please provide the logs from your project's Saved->Logs folder after the crash occurs?

  • Could you please cause the crash again and provide your Machine ID from the Crash Reporter window (if you're getting one) and ensure to hit Send & Close on the report?

  • Have you been able to reproduce this in a clean project?

avatar image m4d3 Jun 14 '16 at 05:00 PM

Hi,

ill try to provide as much information as possible. Yes, this has been reproduced in a clean FirstpersonExample BP project, but only crashes in a packaged build, not in PIE mode.

MachineId:ED395DDD4937062C9AC155B8058CD188

Log File is in attachment link text

I can provide the zipped project if needed.

avatar image Sean L ♦♦ STAFF Jun 15 '16 at 08:48 PM

I've attempted to reproduce this issue on our end, but haven't seen a crash occurring.

Could you please create a test project that reproduces this crash, delete the Saved and Intermediate folders from the project directory, zip up the project, and provide a link to Dropbox or attach it to a comment on Answerhub? Here is a link to my forum profile in case you want to PM it to me: https://forums.unrealengine.com/member.php?160394-Sean-Flint

avatar image awilliams1701 Aug 04 '16 at 03:14 AM

I'm affected by this bug too. I was looking forward to putting out a new pre-alpha build last weekend. I've spent the whole week trying to fix it. I finally found the logs for the build and had that exact error. I use a blueprint that creates a particle system that grows or shrinks depending on the size of the box in the blueprint. I've temporarily replaced this particle system with one of a fixed size and the crash is gone. Or that one anyway. Now it crashes on exit. I can live with that. LMAO

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey m4d3,

I've been able to reproduce the crash in your project, and have entered a bug report, UE-32147. Thank you for your report.

Have a great day

more ▼

answered Jun 17 '16 at 03:42 PM

avatar image

Sean L ♦♦ STAFF
43.5k 485 152 443

avatar image eyesiah Aug 04 '16 at 09:56 AM

Hello Sean, I'm also experiencing this issue in 4.12. I've searched for UE-32147 in the issue tracker but can't find anything (https://issues.unrealengine.com). Can you provide any updates or perhaps check if that's the correct issue number?

Thanks, Isaac

avatar image Sean L ♦♦ STAFF Aug 04 '16 at 12:35 PM
avatar image eyesiah Aug 05 '16 at 09:28 AM

Awesome, thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question