x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Google VR Quick Start - Installation batch file failure

I'm working my way through the Google VR Quick Start guide and have a problem when it comes to executing the batch file that's created, which is supposed to deploy the project to my device. (See part 4, down the page).

The command line window is displayed showing the progress of the install, but disappears and there doesn't seem to be any location that I'm aware of that keeps a log of it. I have however taken a couple of screen shots of the few attempts that I did hoping they will make sense to someone.

A couple that stood out were "Failures here indicate a problem with the device (connection or storage permissions) and are fatal.", and "Failures here indicate storage problems (missing SD card or bad permissions) and are fatal."

I don't really know how to go about fixing whatever the issue/s might be.

alt text

alt text

Product Version: UE 4.12
Tags:
vr_error.png (70.7 kB)
vr_error_3.png (82.2 kB)
more ▼

asked Jun 14 '16 at 02:44 AM in Packaging & Deployment

avatar image

Ermahgerd_Lulz
87 10 13 14

avatar image lordsacar Jun 15 '16 at 11:56 PM

I my case I have a Google Nexus 5, but this smartphone don't have a SD card slot , but it has a nice Storage Space, and I dont understand why when you try to package needs a SD card :/

And that wasn't the unique problem, I was trying for two days, generate the Android Build Files, Install and Uninstall androidworks with no success. and just get erros during the packing proccess.

when i notices of this line int the output:

LogPlayLevel: ERROR: SWT folder 'lib\x86_64' does not exist.

the solution was add a path on system advanced propierties in " Environment Variables" more information https://docs.unrealengine.com/latest/INT/Platforms/Android/Reference/index.html#androidtextureformats, this link is a little old just Enviroment variables was Usefull to read, but one variable was missing. Variable name: ANDROID_SWT and specify the directory value: C:\NVPACK\android-sdk-windows\tools\lib\x86_64 this is my for example, and yes! I did a ATC package Finally!

alt text

But this Unjust life give me a critical punch when that SD error appears when its imposible put a SD card o my cell phone, a nice cell phone that works nice with cardboard apps for me. any help to let test my first tries to make a Google VR app?

And sorry for my english alt text

enviroment.png (103.6 kB)
sd error.png (89.1 kB)
avatar image Sean L ♦♦ STAFF Jun 17 '16 at 06:39 PM

Hello,

If the batch file completes its process successfully, it will automatically close.

What you'll need to do is run monitor on your device, and then grab the device's logs so that we can take a look at them and see what might be failing. We have not been able to reproduce this issue.

avatar image Ermahgerd_Lulz Jun 18 '16 at 03:36 AM

Hi Sean, Here's a log file that I created after another attempt. Hopefully it's got the necessary info there. link text

log.txt (524.7 kB)
avatar image Sean L ♦♦ STAFF Jun 21 '16 at 01:47 PM

Thank you for the logs.

So, does the window close automatically without providing any sort of error message for you? Typically, the window closing indicates a successful run of the file, which would mean that the project should appear on your device when you unplug it. Could you run this process again and see if the file appears anywhere on the device after the window closes?

avatar image Ermahgerd_Lulz Jun 23 '16 at 02:36 AM

I've tried it again, a few times, and still nothing seems to show up on my device.
The only thing I can find when i do a search in Windows Explorer is an obb file called "main.1.com.YourCompany.VR_Test_1" sitting on the phones internal storage at "Xperia Z1 Compact > Internal Storage > obb > com.YourCompany.VR_Test_1", but it's dated over a week ago (on the 14th of June). I'll attach another log file if that helps any. link text

logfile.txt (461.0 kB)
avatar image Ermahgerd_Lulz Jun 24 '16 at 03:40 AM

I gave it another go, this time from the command line like you suggested and still nothing appears on my phone, even though at the end it says installation successful. I do see a bunch of failures happening though, so maybe it has something to do with them. The version of Android on my phone is 4.4.4. I seem to be unable to upgrade from that version, so I guess it is just as far as my model will allow. Here's what was printed out, but if you say the Android version must be 5.0 minimum, then I'm thinking I'll need to get a new phone before I can try VR. I've been thinking of getting a Nexus 6 which runs version 6.0, and I'm hoping it will run version N when it comes out. Maybe then I'll have better luck.

Command prompt data

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Try running the batch file from a command prompt instead of double-clicking it. If you double-click it, it will disappear automatically upon completion, whether there have been errors or not. After you do this, please provide the error messages (if any) that you see.

Also, this can occur if the minimum SDK (21 for Google VR Quick Start) is higher than the version on the phone (which requires a 5.0 Lollipop minimum).

more ▼

answered Jun 23 '16 at 07:18 PM

avatar image

Sean L ♦♦ STAFF
43.7k 485 152 440

avatar image Sean L ♦♦ STAFF Jun 24 '16 at 12:55 PM

I'll mark the topic as resolved for now, as it seems you'll need to upgrade your device. Let me know if you run into any issues after doing so, and we'll be glad to look into it.

avatar image Ermahgerd_Lulz Jun 25 '16 at 04:08 AM

Thanks. I should have it by the end of the week and will be able to test it then.

avatar image Ermahgerd_Lulz Jun 29 '16 at 02:56 AM

My Nexus 6 arrived and I'm still having problems, only this time the command window doesn't close so I need to Ctrl-C stop the process. Here is a screenshot and the log file (it wouldn't upload, but here's a link to my Google drive). I have made several attempts, both executing the .bat file from windows explorer as well as from the command prompt, and I get the same results. alt text

https://drive.google.com/open?id=0BwGEFT4znaOwbTFrSFhva2lseW8

vr_nexus.png (108.4 kB)
avatar image Sean L ♦♦ STAFF Jun 29 '16 at 05:05 PM
  • Are you able to Launch onto your Android device using a clean, blank project? If you haven't tried to do this, please do so and provide the Output Log if it fails.

  • In your logs, I see these errors: 06-29 12:47:11.302: I/PackageManager(2152): Package doesn't exist in get block uninstall com.YourCompany.VR_Test_1 06-29 12:47:11.311: W/PackageManager(2152): Package named 'com.YourCompany.VR_Test_1' doesn't exist. It may be worth spending some time googling these errors to see if a solution exists.

  • We've also tested this on our end, and we were able to get it to work as expected following the guide you provided, so it seems to be some sort of issue with the device, which is why I'd like to see if you are able to launch a normal project onto your device.

avatar image Ermahgerd_Lulz Jun 29 '16 at 06:56 PM

I made a new project following the Google VR Quick Start as before, only this time omitted the part where you create a material and apply it to the floor, then save the new level (all other projects I just followed the guide precisely to test, I have never gone beyond what way stated in the guide content-wise). This time it seems to work. The application runs as expected (everything is black, but you can see it is a VR app). Now the only thing is to go beyond this. What would be causing problems with the other projects? Here is the log of the successful build in case it helps. link text

log.txt (11.2 kB)
avatar image Sean L ♦♦ STAFF Jun 30 '16 at 01:28 PM

Does this occur every time you add the material to the floor? If you create another new project, perform those steps, and then try to put it on the device are you able to do so?

avatar image Ermahgerd_Lulz Jul 01 '16 at 09:10 PM

The same thing happens every time. What I ended up doing was reinstalling Visual Studio and including everything for android. This seemed to work when creating a new project using blueprints, however now I get a massive error when attempting to create a project in C++!
I've gone ahead and posted it as a separate question as it is unrelated to the original problem I was having and this one is essentially solved if one is working with a blueprints project.
Thanks for your help.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question