x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Editor freezes when opening assets

Hello everyone,

after updating to 4.12, the editor freezes after trying to open UMG assets. The last line in the output-window of VS2015 always is "'UE4Editor.exe' (Win32): Loaded 'C:\Universion\Engine\UnrealEngine-4.12\Engine\Binaries\Win64\UE4Editor-SequencerWidgets.dll'. Symbols loaded."

Maybe it has something to do with it?

Product Version: UE 4.12
Tags:
more ▼

asked Jun 14 '16 at 09:36 PM in Bug Reports

avatar image

MykonCodes
96 8 16 26

avatar image MykonCodes Jun 14 '16 at 09:44 PM

Sorry, I have to correct myself. Almost all assets cause this issue. Also for my project partner. Cascade opens, and then it freezes. UMG freezes while opening. Mesh-Viewer freezes after opening..

After further testing, it almost freezes doing anything that requires a new window, but not always at the same spot. One time, a blueprint openend, the next time it froze opening the exact same one.

avatar image Steve Hardister ♦♦ STAFF Jun 15 '16 at 08:41 PM

Hi OmaManfred,

I need to ask a few questions in order to offer support:

  1. Did you keep a copy of your original project in a previous version of UE4?

  2. When you downloaded UE4.12 did you include 'Editor symbols for debugging?'

  3. Please post a copy of your dxdiag.

Please respond with the requested information above and we will continue to investigate.

Thanks,

Steve H.

avatar image MykonCodes Jun 15 '16 at 09:24 PM
  1. No, but I changed the Unreal Version back to 4.11 and there everything works fine again.

  2. It's a source build, I just pulled the "release"-branch.

  3. http://pastebin.com/EcGnkJc8

But as I mentioned, my teampartner has the same issues (with the same project), and we have different PC-Setups. The issue didnt occur on a new project for neither of us.

avatar image Kyoril Jun 15 '16 at 09:46 PM

I experienced a similar issue with 4.12. However, it occurred when trying to load a (big) level. Unfortunately, downgrading to 4.11.2 isn't an option for me.

Posted as several issue here, as I don't know if it really is the same. I will try to open some UMG / other assets manually though and see if I get a freeze by doing that, too.

https://answers.unrealengine.com/questions/436667/editor-and-game-freeze-on-level-load.html

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey OmaManfred,

The freeze you are experiencing is likely the same issue reported in the following two links, the latter including a pull request.

EPIC, PLEASE READ: Fixed editor freeze

4.12 infinite loop in engine source + fix

Please review these and let me know if the issue described is not applicable to your situation. If it is, a fix is on it's way.

Steve H.

more ▼

answered Jun 16 '16 at 03:00 PM

avatar image Xonos Jun 16 '16 at 10:16 PM

Hello. I am the team member working with OmaManfred. I just added in the their change and we're still having the same freeze up when opening assets. I've been manually pausing and looking at the Call Stack and the following seems to repeat as it continuously consumes more memory until it runs out and crashes. I cannot confirm that it's an infinite loops however, it does repeat indefinitely.

 PhysX3PROFILE_x64.dll!physx::ChangeList::computeList() Line 1401    C++
      PhysX3PROFILE_x64.dll!physx::PxsAABBManager::computeAABBUpdateLists(unsigned int * changedActorWords, const unsigned int changedActorWordCount, const physx::PxsComputeAABBParams & params) Line 1413    C++
      PhysX3PROFILE_x64.dll!physx::PxsAABBManager::updateAABBsAndBP(const unsigned int numCpuTasks, const unsigned int numSpusAABB, const unsigned int numSpusBP, physx::PxBaseTask * continuation, unsigned int * changedActorWords, const unsigned int changedActorWordCount, const bool secondBroadPhase, int * numFastMovingShapes) Line 1024    C++
      PhysX3PROFILE_x64.dll!physx::PxsContext::updateBroadPhase(physx::PxBaseTask * continuation, bool secondBroadphase) Line 600    C++
      PhysX3PROFILE_x64.dll!physx::Sc::Scene::ccdBroadPhase(physx::PxBaseTask * continuation) Line 1587    C++
      PhysX3PROFILE_x64.dll!physx::Cm::Task::run() Line 48    C++
 >    UE4Editor-Engine.dll!TGraphTask<FPhysXTask<0> >::ExecuteTask(TArray<FBaseGraphTask *,FDefaultAllocator> & NewTasks, ENamedThreads::Type CurrentThread) Line 1000    C++
      UE4Editor-Core.dll!FTaskThreadAnyThread::ProcessTasks() Line 1255    C++
      UE4Editor-Core.dll!FTaskThreadAnyThread::ProcessTasksUntilQuit(int QueueIndex) Line 1149    C++
      UE4Editor-Core.dll!FTaskThreadBase::Run() Line 621    C++
      UE4Editor-Core.dll!FRunnableThreadWin::Run() Line 74    C++
      UE4Editor-Core.dll!FRunnableThreadWin::GuardedRun() Line 23    C++


avatar image Steve Hardister ♦♦ STAFF Jun 17 '16 at 01:34 PM

Hey Xonos,

Are you getting a Crash Reporter window? If so, please copy and past the contents in a doc and send, including your Machine ID. Also remember to hit "submit" in the Crash Reporter window so we can cross-reference your data in our data base.

Thanks,

Steve

avatar image Xonos Jun 18 '16 at 11:55 PM

No. It never "crashes". Just freezes until it runs out of memory but I haven't waited that long because I force close it. Otherwise, entire system locks up.

avatar image Steve Hardister ♦♦ STAFF Jun 21 '16 at 02:03 PM

In the UE4.12 version, try:

  1. Delete the Config, Intermediate, and Saved folders (You will need to re-enter your Project Settings)

  2. Run a Map Check on the main map and each sub-level. (Correct all applicable errors, ignoring things like "No Source Control.)

  3. Click on the "Content" folder in the Content Browser and select Fix Up Redirectors in Folder"

  4. Save all.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question