x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Blueprinted Components lose transform in child actor BP

Hello,

I've encountered a bug whereby the transform of a component is lost in the following circumstances:

  1. Create a new Empty Blueprint project using 4.12.2

  2. Create a new Blueprint asset. Select Scene Component as the blueprint class. Name this blueprint "BPComp"

  3. Create a new Blueprint asset. Select Actor as the blueprint class. Name this blueprint "BPBaseActor"

  4. Edit the BPBaseActor blueprint. Add a new component of type "BPComp" to the class.

  5. Set the new component's Location to be "0, 128, 0"

  6. In the content browser, select the blueprint "BPBaseActor" and right-click. Select "Create Child Blueprint Class". The new blueprint will be named "BPBaseActor_Child"

  7. Edit the "BPBaseActor_Child" blueprint. Note that "BPComp (inherited)" appears in the Components list.

  8. Click on the "BPComp (inherited)" component. Note that the Location of the component is "0, 0, 0"

  9. Edit the Location of the component to be "0, 128, 0".

  10. Click "compile". Note that the Location of the component is once again "0, 0, 0"

Expected result: In steps 8 and 10, the Location of the component should be "0, 128, 0".

Thanks, Isaac inbetweengames

Product Version: UE 4.12
Tags:
more ▼

asked Jun 15 '16 at 10:13 AM in Bug Reports

avatar image

eyesiah
123 8 15 26

avatar image Sean L ♦♦ STAFF Jun 15 '16 at 05:52 PM

Hello,

I have attempted to reproduce this issue, but have not been able to do so following the steps you provided. In my BPBaseActor_Child blueprint, the Inherited BPComp was correctly placed at 0,128,0.

Did you perform this repro in a clean project? Were there any small steps that may have been left out?

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I've upgraded to 4.12.3 and the issue no longer occurs. I'm guessing it was related to this, which was marked fixed with 4.12.3:

Fixed! UE-31743 Components derived from scene component reset vector location upon closing and re-opening editor

more ▼

answered Jun 17 '16 at 09:58 AM

avatar image

eyesiah
123 8 15 26

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question