x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

'Unable to bind delegate' errors on packaging

I get two permanent 'Ensure condition failed' errors on project package:

1.MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: Ensure condition failed: this->IsBound() [File:g:\program files\epic games\4.12\engine\source\runtime\core\public\delegates\DelegateSignatureImpl_Variadics.inl] [Line: 1042] MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: Unable to bind delegate to 'ButtonNext_OnEndOverlap' (function might not be marked as a UFUNCTION)

Note: It's not just ButtonNext_OnEndOverlap, there are error messages for all Hit and Overlap delegates.

2.MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: Ensure condition failed: NewTransform.IsValid() [File:D:\Build\++UE4+Release-4.12+Compile\Sync\Engine\Source\Runtime\Engine\Private\Components\SceneComponent.cpp] [Line: 415]

It started few days ago after update to 4.12, but first packages finished successfully. Then i tried to make a shipping package instead development - it was successfull too. But all later builds without noticable source changes failed. The problem can be related to this (https://answers.unrealengine.com/questions/427611/unable-to-bind-delegate-1.html), but i don't use preprocessor macros. I also migrated all my content to entirely new 4.12 project (for another reasons), but still can't package it. All builds in C++ in non-editor Development and Shipping configs are successful, and the project works without errors in editor and via Project Launcher.

Product Version: UE 4.12
Tags:
more ▼

asked Jun 15 '16 at 11:32 AM in Bug Reports

avatar image

YuriNK
81 7 11 12

avatar image Vaei Jun 15 '16 at 11:35 AM

Just checking but.. you do have them marked as UFUNCTIONS?

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

UPD. I solved it. The problem was about lack of 'class' keywords near parameters in function definitions. Looks like Visual Studio doesn't copy them from declaration on automatic definition creation via popup menu.

more ▼

answered Jun 16 '16 at 03:37 PM

avatar image

YuriNK
81 7 11 12

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question