x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaging - Game target not found

link text

Hi, I am following this YouTube tutorial
https://www.youtube.com/watch?v=cgY1D9GwEYk&list=PLZlv_N0_O1gb5sdygbSiEU7hb0eomNLdq∈dex=7
I think this is where the packaging fails, I am able to package other projects without problem Program.Main: ERROR: AutomationTool terminated with exception: MainFrameActions: Packaging (Windows (64-bit)): Program.Main: ERROR: Exception in AutomationUtils.Automation: Game target not found. Game target is required with -cook or -cookonthefly

If someone knows how to fix it, I'd appreciate the help :)

Product Version: UE 4.9
Tags:
unreal log.txt (17.7 kB)
more ▼

asked Jun 15 '16 at 03:12 PM in Packaging & Deployment

avatar image

ccrumpet
1 1 2 3

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Hi ccrumpet,

I've run through this tutorial myself and also have a version I was helping another user with and both package without any issues. My first thought is to make sure you have the code pages set up exactly as demonstrated in the earlier parts of the tutorial.

Secondly, make sure your project settings are set like these:

Project Settings

Please check these two areas of concern and let me know if they setting them the same way resolves the issue.

Finally, the following documentation explains Target File Naming and Location and may shed some light on where it's going wrong in your project:

Unreal Build System Target Files

-Steve H.

more ▼

answered Jun 17 '16 at 08:02 PM

avatar image ccrumpet Jun 18 '16 at 11:46 AM

Hi Steve I had to create my base character using blueprint instead of C++, could that be causing the issue? I still get the same error with your solution :(

avatar image Steve Hardister ♦♦ STAFF Jun 20 '16 at 02:19 PM

Are you using any code at all in this project -or is it all blueprints at this point? Also, are you using the Launcher version of the engine or did you build it from source?

avatar image ccrumpet Jun 20 '16 at 03:27 PM

It's all blueprint. I started off with the C++ code but deleted it. I am using the launcher version of the engine. Is there a way I could send you the game to have a look at? Thanks for the help.

avatar image Steve Hardister ♦♦ STAFF Jun 20 '16 at 04:48 PM

You can send me a link to your game from Dropbox, Google Drive, etc in a private message on our Forums

avatar image Steve Hardister ♦♦ STAFF Jun 22 '16 at 06:48 PM

I found the answer to your specific issue here:

Missing Game Binary, cant pack a game on Win64 shipping mode

I had to add a C++ Character class and recompile to get your packaged project to work (C++ None did not work.) Before this, I regenerated VS files by right-clicking on the uproject, but I'm not sure if that was necessary.

This is a workaround. Typically all Blueprint projects are expected to package without having to do this.

avatar image ccrumpet Jun 22 '16 at 07:22 PM

Thanks so much Steve! That might be because I started it with the base character as a C++ class but then changed it to blueprint haha.

(comments are locked)
10|2000 characters needed characters left

Project Configuration / Platforms / android / project sdk override / Leave the SDK field and NDK blank.

more ▼

answered May 04 '18 at 09:05 PM

avatar image

maxgtp
11 1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question