x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

ShaderPlatformQualitySettings don't seem to work for SF_METAL

Hi,

I'm trying to turn on fully rough shaders for quality level 0 for some metal devices. Here's my ini settings in DefaultEngine.ini:

 [ForwardShadingQuality_SF_METAL ShaderPlatformQualitySettings]
 QualityOverrides[0]=(bEnableOverride=True,bForceFullyRough=True,bForceNonMetal=False,bForceDisableLMDirectionality=False,bForceLQReflections=False)
 QualityOverrides[1]=(bEnableOverride=True,bForceFullyRough=False,bForceNonMetal=False,bForceDisableLMDirectionality=False,bForceLQReflections=False)
 QualityOverrides[2]=(bEnableOverride=False,bForceFullyRough=False,bForceNonMetal=False,bForceDisableLMDirectionality=False,bForceLQReflections=False)
 

The materials do get compiled as fully rough, but it's applying the fully rough materials even when DetailMode is set to 1 and 2 on device. It's as if it's not creating non-fully rough versions of the materials.

Regards,

Ryan.

Product Version: UE 4.11
Tags:
more ▼

asked Jun 16 '16 at 06:53 AM in Bug Reports

avatar image

LuaChunk
95 8 10 33

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi, unfortunately the quality overrides currently only work on "feature level ES2" which the OpenGL ES renderer uses, but our Metal renderer uses "feature level ES31".

We hope to have this fixed for 4.13. The ticket for this is UEMOB-155.

  • Jack

more ▼

answered Jun 16 '16 at 09:21 AM

avatar image

JackP_oldaccount
1.3k 37 11 48

avatar image LuaChunk Jun 17 '16 at 06:17 AM

Would you be able to point me in the right direction for fixing this myself. I've been looking over the code for this system and I can't figure out why it doesn't already work. I can't find the code that restricts this to feature level ES2. The code that reads the settings from the config seems to handle other shader platforms when it builds the object name with "ForwardShadingQuality_" + PlatformName.

avatar image JackP_oldaccount Jun 17 '16 at 06:43 AM

You're correct, the shader code does to support the QL overrides for any shader platform (though only the mobile shaders look for the overrides), but we only expose the settings UI for the ES2 iOS and Android and we haven't tested it for other shader platforms.

If you disable metal in your project and use ForwardShadingQuality_GLSL_ES2_IOS, do fully rough and non-fully rough work as expected for each of the quality levels?

avatar image LuaChunk Jun 22 '16 at 01:23 AM

Unfortunately our materials don't seem to run on OpenGL. I'm getting some kind of float buffer assert because it's too big. Probably too many parameters? If we launch before 4.13 we'll just not support some of the lower end Metal devices until we can upgrade.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question