x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Run on dedicated server cause problems with socket location

Hello.

When im testing multiplayer projectile spawn from weapon muzzle, it works on normal run where one of players act as server, but if i check "run on dedicated server" to true, it cause problems with socket location, it spawning projectiles from one location...

IMAGE: http://i.imgur.com/PaVLIiw.jpg

VIDEO for sure: https://www.youtube.com/watch?v=fr_eEi06-Ho

Is there some way how to fix this? I found that some people had this problem too but they did not found any solution too

Product Version: UE 4.11
Tags:
more ▼

asked Jun 16 '16 at 06:51 PM in Bug Reports

avatar image

Name368
118 4 15 19

avatar image Adam Davis STAFF Jun 16 '16 at 08:49 PM

Hi Name368,

Can you show me a screenshot of your blueprint for the firing mechanism? Additionally, try running a print string on the relative socket location, is it different on PIE when Run Dedicated Server is on/off?

avatar image Name368 Jun 16 '16 at 10:58 PM

Hello,

I tried print string on relative location and it returned 0 0 0 for both cases (im spawning and attaching gun at begin play), also tried world location, and both cases returns same numbers so it looks like socket location is not changed with dedicated server option

here is my fire function, its in character bp: http://i.imgur.com/z3JXq2n.jpg

avatar image Adam Davis STAFF Jun 17 '16 at 01:42 PM

Try using a "User timer by event" and set the event input to the timer function you are currently using. I ran into a similar issue last week and this seemed to be the cause.

avatar image Name368 Jun 17 '16 at 02:55 PM

Hello, I tried but i still have same problem... This looks like a very deep bug... If you want i can send you my whole project and you can test it out, let me know... Thanks

avatar image Name368 Jun 17 '16 at 03:08 PM

I did one more test: 1 player and run on dedicated server: Socket location in print string is changed (got X values between 1750 - 1800 - 1750 so its mean that socket is moving on curve as expected but projectiles are spawned from one same point... Strange is that i can rotate horizontally that spawn, but not vertically like in video...

avatar image Name368 Jun 17 '16 at 05:06 PM

So i did more tests and i found that it is not only socket location problem... In weapon blueprint, i created st.mesh component and attached it to gun at muzzle location

http://i.imgur.com/JaWQBkY.jpg

Now im spawning projectiles from this point but with same problem as from socket...

avatar image Adam Davis STAFF Jun 20 '16 at 06:09 PM

Try creating a rotation variable input on your custom event. Pass the rotation and location information through this. It may be that the socket information isn't being updated to the clients properly because the data is local, not server data.

avatar image Name368 Jun 20 '16 at 10:12 PM

perfect! so i SOLVED this! Thank you a lot Adam, so for future googling for other people: First i calculated spawn transform on client (in bp without any replication) and then i passed it to server to spawn projectile and it works.

Btw only last question, is this "bug"(dedicated server option) or it was my mistake by bad BP setup?

avatar image One Mode Only Jan 10 '19 at 09:50 PM

Thanks a TON for this! I've searched a ton, and unfortunately this very prominent bug seems to be totally neglected.

avatar image rhogggi Sep 01 '16 at 06:47 AM

Thanks for this. I spent half a day trying to work around this issue and your answer solved it for me in 2 mins.

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

(UE4.15.2) Just to help anyone having trouble with this in the future. Best than asking the client to send the position is to actually use the position of the socket on the Server to prevent cheating. The thing is, Dedicated servers don't render the meshes, so skeletal meshes do not update their sockets or bones while not being rendered by default on the server part.

But there is this magic flag that allows you to set the skeletal meshes to actually refresh bones on update even when they are not rendered, just click on your Skeletal mesh component and scroll down to:

Skeletal Mesh Settings

And these are the options, the first one is the one that allows you to do calculations without rendering..

alt text

Cheers.

skeletal.png (20.2 kB)
more ▼

answered May 10 '17 at 02:42 PM

avatar image

Luiz Sotero
115 1 7 7

avatar image Flash7 Aug 31 '17 at 07:39 PM

Awesome! This one worked perfectly!

avatar image chiefGui Apr 17 '18 at 04:57 PM

Worked like a charm! Thank you!

avatar image RichardLam Jun 19 '18 at 03:40 AM

This worked for me too!

avatar image mellowsoft Aug 09 '18 at 03:28 AM

Thank you so much. I thought I was going insane here but this worked, and makes sense once I think about it...

avatar image EnYgrekMercato Dec 31 '18 at 07:30 PM

Luiz, I love you, this worked for me too, but now we have to scroll down to (ue4.21.1) alt text :

tempsnip.png (30.8 kB)
avatar image JTXPbrah Jan 24 '19 at 03:28 AM

Unfortunately this didn't work for me. Dedicated server is still not getting the correct socket location. 4.21.1. Might be a return of this nasty bug!

(comments are locked)
10|2000 characters needed characters left

Unfortunately I don't have a good answer for that. Depending on the setup it could have been as simple as a missing value or the server needing specific information to be passed through. I am happy to hear that it is working and will mark this as answered for tracking purposes.

more ▼

answered Jun 21 '16 at 03:15 PM

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question