x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Fade Animation

Hi, so I have a main menu widget which when the play button is clicked I want my next widget to fade in but I'm encountering some problems. I'v tried using animations and the graph but neither have worked so I must be doing them wrong. This is what I have so far -

alt text

alt text

alt text

Product Version: UE 4.10
Tags:
more ▼

asked Jun 16 '16 at 08:23 PM in Blueprint Scripting

avatar image

K_Clayt
15 2 4 6

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I'm not sure if this will fix it (don't know exactly the issue you are having as you didn't explain the results of your code above) but I'm thinking you may not want to put the 'Play Animation' inside the 'Tick' event. Tick is happening ~60 times a second meaning it's running the 'Play Animation' node that many times, which could cause the animation to continually reset itself to frame 1 on every tick.

If this widget's only purpose is to have this fade effect with an intro message, before it's destroyed/removed, then I would suggest putting the Play Animation in the 'Event Construct' node or put it inside a Custom Event and call the custom event after you 'Create Widget'.

Hope this helps!

more ▼

answered Jun 17 '16 at 01:12 AM

avatar image

jtsmith
1.4k 70 28 89

avatar image K_Clayt Jun 17 '16 at 02:02 AM

Ok thank you, changing the "event tick" to "event construct" fixed it.

avatar image jtsmith Jun 17 '16 at 03:04 AM

Awesome, glad it helped! If you would be so kind as to accept the answer by clicking the check mark next to Answer (answer and comments will turn green when successful) it would be greatly appreciated! Remember though, commenting on any question after an answer has been accepted, will deselect the answer as correct! Thanks!

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question