x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Apex Clothing - Crash when adding clothing to mesh after importing the apx file.

UE4 crashes to desktop without any error messages everytime when adding the cloth to the material, after importing the apex file in the skeletal mesh editor window. I'm currently using:

UE4.11.2

3ds Max 2016

PhysX: 3D Studio Max DCC plug-in for PhysX 3-3-3 3.3 2016/02/22

I've also tried:

PhysX: 3D Studio Max DCC plug-in for PhysX 3-3-4 3.4 2016/02/22

But switched to 3.3 because a google search returned UE4.11 supports 3.3.There is no crash report but the saved logs in the project folder have a little bit of info at the bottom starting from line #185:

Here's the logs: http://pastebin.com/rJZF02gy

Here are the files: https://drive.google.com/open?id=0Bx9EXUB0t6qtbXY0YUtKQ1BZNUk

zip contains Cloak001.apx Cloak001.ctp (generated on export of the file) and Cloak001.fbx

Others have asked similar questions and seem to have the same problem. Others say the've fixed the issue but have not said how they accomplished it.

Thanks for your help!

Product Version: UE 4.11
Tags:
more ▼

asked Jun 17 '16 at 12:27 AM in Bug Reports

avatar image

Grant Margison
86 7 15 21

avatar image Grant Margison Jun 17 '16 at 08:25 AM

I've tried this on old versions of max and maya, following tutorials for both. Trying every combination of export options for both, exporting to .apb and .apx. UE 4.11.2 crashes in the same place everytime, I never get any crash reports even though I have all the editor symbols installed. The end of the logs are the same no matter what I use, max/maya or version of the plugin.

It seems to me that UE 4.11.2 is the problem.

I'd upgrade to 4.12 but my project fails to compile to the new version, which is another question on its own :(

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Grant,

Thank you for the test assets. This made it easy to reproduce the crash. I've submitted UE-32163 for this to be investigated.

The crash was occurring in any version of the engine that I test with 4.11.2, 4.12.3, and our internal build of 4.13. There have been similar issues in the past that have been resolved, and it is likely that it could be resolved by fixing something with the asset specifically however I do not have a workaround for you.

Thank you!

Tim

more ▼

answered Jun 17 '16 at 05:41 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 887 101 878

avatar image Grant Margison Jun 17 '16 at 11:30 PM

Thank you Tim, hopefully the bug will get squashed soon.

Here's another little bit of info, one of the critical errors that causes the crash, this is what the engine code looks like that throws the error: ...........\4.11\Engine\Source\Runtime\Engine\Private\GPUSkinVertexFactory.cpp [Line 73] translated to line 24 of this snippet.

 /*-----------------------------------------------------------------------------
  FSharedPoolPolicyData
  -----------------------------------------------------------------------------*/
 uint32 FSharedPoolPolicyData::GetPoolBucketIndex(uint32 Size)
 {
     unsigned long Lower = 0;
     unsigned long Upper = NumPoolBucketSizes;
     unsigned long Middle;
     
     do
     {
         Middle = ( Upper + Lower ) >> 1;
         if( Size <= BucketSizes[Middle-1] )
         {
             Upper = Middle;
         }
         else
         {
             Lower = Middle;
         }
     }
     while( Upper - Lower > 1 );
     
     check( Size <= BucketSizes[Lower] );
     check( (Lower == 0 ) || ( Size > BucketSizes[Lower-1] ) );
     
     return Lower;
 }
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question