x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Problem with HTC vive and 4.12, build are blurry but fine in editor and 4.11 ?

Hello,

i ve a problem with a build for HTC vive with unreal 4.12. When i play my project in the vr preview of the editor it's perfect but when i made a build the result is quite blurry, and another strange thing is that the "mirror screen" of the vive on my monitor is blocked in the upper left corner of the monitor.

My project has been made with 4.12 so i can not use 4.11.

But i have recreated the same problem only with the starter content. I've made a very simple project with 4.11 and everything is fine the result of the build is perfect in the vive, and the "mirror screen" is in the middle of my monitor and in a scalable windows as usual.

But when i do the exact same project with 4.12 the result is perfect in the editor but blurry in the build and the "mirror screen" is blocked in the upper left corner of the monitor. (i'm in epic quality, my light are build in production, every thing is set up to the max, i have no error message during the build, and i try with 4.12.3 same issue ... and i haven't have any problem of this kind before on my precedent project with Vive and unreal 4.10 or 4.11 with the same set up)

Do i miss something ? is there a change in the default parameter in the rendering of unreal 4.12 ? or in the set up of a vr pawn for Vive ? Anyone with the same problem ? Any help would be very great.

Thanks a lot.

Product Version: UE 4.12
Tags:
more ▼

asked Jun 17 '16 at 11:23 AM in VR

avatar image

Vinzant
11 1 2 4

avatar image Vinzant Jun 20 '16 at 02:24 PM

ok you can see there if you have the same problem of blurry resolution : https://answers.unrealengine.com/questions/434362/vr-shipping-build-is-blurry-and-slow.html

thanks to Malharhak...

avatar image weberl Jun 22 '16 at 11:36 PM

I have the exact same problem. How did you solve this? or Did you solve this at all?

avatar image Vinzant Jun 27 '16 at 02:33 PM

Hi weberl, it's better with the command console r.ScreenPercentage as explain in the link, for me a good value is 180 without having problem with my fps, you can try higher but the framerate dropdown a lot... but it's still not as good as in the editor, and if i want the same quality as in the editor i can't have a fps as good as in the editor. So for now it's a not a totally good solution but they are no answer on the subject from Epic'staff , so i'm stuck with it right now . but maybe if they saw that a lot of us have the same issue they will respond...

avatar image Josemcasasp Jul 20 '16 at 09:12 AM

Hi Vinzant, well i have the same issue. I put on the level blueprint the screen percentage with the command console, also the post process quality, and still having the same problem.

I try all the AA options that ue4 provide us and all my builds are blurry i hope epic fix this soon.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Try the following:

  • Create a new empty level (lets name it dummy_level)

  • in the project settings, set dummy_level as your game start map

  • In the level Blueprint, on Event BeginPlay add a console command "Open Level" with your actual first level

Then it should be ok. For some reason the resolution resets to the correct values as soon as a level change is initiated.

Cheers, Indy

more ▼

answered Aug 10 '16 at 09:27 AM

avatar image

indygoof
830 26 15 41

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question