x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Cook Fails Due to Incombatible or Missing Module

The game builds fine in the editor if I do File>Package Game>Win64.

However if I run from the command line (or from Unreal Front End):

 RunUAT.bat BuildCookRun -project="{project path.uproject}" -nop4 -platform=Win64 -clientconfig=Development -cook -allmaps -build -stage -pak -archive -archivedirectory="{build directory}"

I get the following errors:

 LogInit:Warning: Incompatible or missing module: UE4Editor-BikerGangManager.dll
 LogInit:Warning: Incompatible or missing module: UE4Editor-VictoryBPLibrary.dll

This is the log from that build: Failed Build Log

However, if I run with the following flag:

 -UseDebugParamForEditorExe

Then the build proceeds as expected. This produces this log: Successful Build Log

It is a weird flag that I can't find documented anywhere which makes me nervous. Why do I need this flag? What is it doing?

Edit: Attached Build Logs

Edit 2: More Information

I have tried running the command on the build machine (which hasn't launched the editor) and with or without the UseDebugParamForEditorExe flag I get the same error (about incompatible/missing modules).

Product Version: UE 4.11
Tags:
more ▼

asked Jun 17 '16 at 04:39 PM in Packaging & Deployment

avatar image

thk123
641 44 57 89

avatar image Sean L ♦♦ STAFF Jun 17 '16 at 06:29 PM

Hello,

Could you please provide your logs from your project's Saved->Logs folder after the packaging process fails?

As far as what the -UseDebugParamForEditorExe flag does, I am investigating this now and will let you know once I have information.

avatar image Sean L ♦♦ STAFF Jun 17 '16 at 06:33 PM

Rather quick turnaround, but it appears that the -UseDebugParamForEditorExe flag adds the -debug flag to the cook on the fly server, which makes it use the debug ddls.

avatar image thk123 Jun 20 '16 at 10:20 AM

@Sean I've attached both the successful and failed logs from the build process - but there doesn't seem to be much useful information in the failed one... Thanks for the info on the flag, clearly don't want to be using debug DLLs.

avatar image Sean L ♦♦ STAFF Jun 20 '16 at 05:53 PM

Thanks for updating the post with the logs, I'm looking into this further now.

Are you using any external plugins?

avatar image thk123 Jun 21 '16 at 08:16 AM
avatar image Sean L ♦♦ STAFF Jun 21 '16 at 01:24 PM

Have you tried packaging without that plugin to see if it makes a difference? It's possible that it can cause a conflict.

avatar image thk123 Jun 23 '16 at 04:03 PM

This isn't very practical advice - this would involve going into various blueprints to find any nodes that come from that plugin and rewrite that blueprint to not depend on it. Let's assume that does fix it, what would be our next step given that we want to use that plugin?

avatar image Sean L ♦♦ STAFF Jun 23 '16 at 04:55 PM

I'm asking because if the plugin being removed resolves the issue, then you can start to narrow down exactly what the cause is. If that does fix it then you'll need to communicate with Rama to try and figure out why the plugin would be conflicting with your setup (again, may not be the case, but I've seen it occur quite a few times so it's worth testing).

Another suggestion if you are using C++ would be to regenerate your project files and build the solution again.

avatar image Ubuntourist Jul 25 '18 at 04:57 PM

Communicating with Rama just means another page added to a 149-page forum and him suggesting that the answer is somewhere in the previous 149 pages...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

For anyone who's just now running into this, here's what could be happening.

  • You haven't built the Editor yet. This can happen if you deleted Intermediate and you only have the binaries necessary to make the game run.

  • You've built a debug version of the Editor. Unless you rebuild with a Development or Shipping configuration, you'll need to add -UseDebugParamForEditorExe to your cooks so it understands to use the debug binaries.

more ▼

answered Jun 25 '18 at 03:27 PM

avatar image

toxicg0d
34 3 4 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hello,

I am marking this topic as resolved for tracking purposes, as we have not heard from you in a few days. If this issue persists, feel free to respond to this thread. For any new issues, please create a new Answerhub topic.

Have a great day

more ▼

answered Jun 28 '16 at 02:32 PM

avatar image

Sean L ♦♦ STAFF
43.7k 485 152 440

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question