x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaging Problem with Controlls

Yesterday i wanted to package my newest Project. In Editor everything works fine but as i exported it my second character movement doesent seem to work. I testet some things wich i thought where the problem, like the possessing. I set the character as default pawn but that didnt helped out. I dont know if it has to do something with the hierachy i has setup. I have a main class and 2 Childs wich divides it into 2 groups. One is AI and the other one is AI to possess into. EDIT: I tried to launch the game in editor in the launch section. There it is the same. It does not work like in Editor

LogSpecified for Warnings:

CompleteLog:

Product Version: UE 4.12
Tags:
logspecified.txt (4.8 kB)
log.txt (12.5 kB)
more ▼

asked Jun 17 '16 at 05:59 PM in Packaging & Deployment

avatar image

Thorwin99
33 2 3 5

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I found the problem Myself. It is now solved

more ▼

answered Jun 18 '16 at 11:33 AM

avatar image

Thorwin99
33 2 3 5

avatar image Sean L ♦♦ STAFF Jun 20 '16 at 02:25 PM

Hey Thorwin99,

Could you please provide the solution that you discovered for your issue to help other users out who may be experiencing the same issue in the future?

Thank you

avatar image Thorwin99 Jun 20 '16 at 04:25 PM

Sure. So i made a mistake with casting. In the begin play event i searched for the ai i want to possess into and set it as a reference variable. In my possess function i castet to him and did the work for possessing. The problem was the casting. I replaced it with the search actors from class node and git the first index. It was the same as the function where i set the variable. So i didnt saved the reference inside the variable, i now always search for the actor and then cast it to its parent class.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question