x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Cannot upload to App Store - url scheme invalid

Compiles successfully, but when I try to upload with Application Loader I get this error:

ERROR ITMS-90158: "The following URL schemes found in your app are not in the correct format : {}. URL schemes need to begin with an alphabetic character, and be comprised of alphanumeric characters, the period, the hyphen or the plus sign only. Please see RFC1738 for more detail."

Product Version: UE 4.12
Tags:
more ▼

asked Jun 18 '16 at 10:36 PM in Packaging & Deployment

avatar image

Spectral Ink
219 10 13 23

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Hi Spectral Ink:

I could not find much on this specific error, however, I did come across an Asian forum discussing the exact same error...

While it was not clear what the solution was, they did show a string of numbers defined as the Apple Collaborator ID that is not present in your post above where you have posted "{}."

Please review the steps on the App Distribution Guide and make sure your Apple ID is added correctly in XCode.

-Steve H.

more ▼

answered Jun 21 '16 at 01:50 PM

avatar image Spectral Ink Jun 21 '16 at 04:27 PM

In the actual error in between the {} was the name of my project. I had typed that in when posting the error, red acting the name of my project for privacy reasons, but when it posted it just displayed blank.

So again, I have what Unreal engine says is a successful build, but when I upload it fails to validate.

avatar image Spectral Ink Jun 22 '16 at 04:23 AM

I figured it out. The URL scheme is taken form the project name. My project name had an underscore in it, which Apple doesn't like. I changed it to a hyphen, but then unreal called it an unknown symbol on packaging. So I took it out completely and made it on alphanumeric name and Apple accepted that.

Now that we know this is an issue, maybe Unreal can fail to build when it encounters illegal characters in an ios build, or autocorrect them?

avatar image Steve Hardister ♦♦ STAFF Jun 22 '16 at 03:10 PM

Glad you were able to piece together the solution... As far as failing a build due to this particular error...

"ERROR ITMS-90158" refers to a problem submitting to the App store in general, not a problem with Unreal Engine that should fail a package. Looking up this issue on Apple's developer forums leads to this solution:

ERROR ITMS-900158 while submitting application on itunes : "URL schemes need to begin with an alphabetic character, and be comprised of alphanumeric characters, the period, the hyphen or the plus sign only."

Again this could be from any application, not just one generated from UE4.

avatar image Spectral Ink Jun 22 '16 at 04:10 PM

Yes, this is a general Apple issue. Your right, any app could have this error in it, not just one made by Unreal. But since I'm only making apps in Unreal, it's the only one I care about. Unreal didn't do anything wrong - hell, I named the project, so it was ultimately my fault - but Unreal did create the ipa with an invalid URL Scheme name, which it took from the project name, which again was created by me. I was merely suggesting that a simple check by the compiler for invalid characters would help avoid confusion in the future, now that we are aware of it. Unreal could auto-correct, or simply pop up a warning. Just making a note of it in the help docs would be a big help for those of us stumbling over the issue for the first time.

avatar image Steve Hardister ♦♦ STAFF Jun 22 '16 at 07:36 PM

I've added the following Feature Request: UE-32388. Should this be implemented into the Engine we will notify you with an update to this post.

Thanks for the feedback.

avatar image JonathanADaley Jun 29 '17 at 12:49 AM

I just ran into this in UE 4.16.1. I just wasted over an hour of build time to get a bad build, and then another hour to make a new one. This really should be fixed.

My suggestion is: when creating the URL scheme for an iOS app, remove the characters that cause the problem.

Or, display a warning when creating a project, that certain characters in a project name will cause issues for certain platforms. Then it's the user's option to use those characters in a project title (if they aren't targeting an affected platform), or be warned not to so they could save some headaches and wasted time.

avatar image JonathanADaley Nov 07 '17 at 07:38 PM

This issue is still happening in version 4.18. The URL scheme generation code should remove non-alphanumeric characters.

(comments are locked)
10|2000 characters needed characters left

I have the same error message, and it seems the problem is the project name. Not simply the bundle name mind you, but the actual file name of the project! Problem is … there’s no way to change that now?! I’ve tried to rename the whole project manually, but from googling a bit that seems to only work on Blueprint-only projects. In our project, there’s a bit of C++ code. Yesterday I spent hours trying to rename everything and going into all .CS files, but all of that just led to the project not even opening anymore. Is there any way I can tell Unreal to change the project name (remove the underscore) when compiling/packaging?

more ▼

answered May 21 '18 at 02:21 PM

avatar image

willikampmann
1 1 2

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question