x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Camera displacement with top down view

I'm creating a maze game for mobile devices using the 3rd person character template. I want to make a top down game, but want to use the controls that come with the 3rd person template. I found it easier to achieve the results I wanted simply be changing the camera position, rather than creating a top down game and trying to change the control mechanism.
Everything works fine, except I get a very distracting camera displacement when my pawn moves too close to a wall or the edge of the map. When the pawn moves too close to the edge of the map it shifts away from the middle of the screen. I figure I can remedy this issue by creating a map that encloses a smaller play area (I am yet to try this, but am confident it will work). My main concern is how the visuals shift when the pawn moves too close to certain walls. I need to have the camera keep itself in place at all times and have the pawn not move from the centre of the screen. I've added a video to show the behavior I am attempting to explain.

link text

Product Version: UE 4.11
Tags:
more ▼

asked Jun 20 '16 at 12:07 PM in Using UE4

avatar image

Ermahgerd_Lulz
87 10 13 14

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

you need to disable the do collision test of the springArm

more ▼

answered Jun 20 '16 at 12:14 PM

avatar image

saeedc
2.4k 73 43 108

avatar image saeedc Jun 20 '16 at 12:16 PM

open character BP > select springarm> in details panel find do collision test and disable it

avatar image Ermahgerd_Lulz Jun 20 '16 at 12:59 PM

You legend! Thanks for that. =)

alt text

solved.png (455.3 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question