x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Viewport flickering

Unreal Engine 4.12.3

Editor viewport flickers like mad. It's super distracting in makes it impossible to concentrate while using.

alt text

Blender used to have this issue and the solution was to specify the draw method in the settings.

alt text

Any ideas on how to fix?

Environment:

  • OS X El Capitan 10.11.5

  • MacBook Pro (Retina, 13-inch, Mid 2014)

  1. GHz Intel Core i5

  • 8 Gb 1600 MHz DDR3

  • Intel Iris 1536 MB

Product Version: UE 4.12
Tags:
more ▼

asked Jun 20 '16 at 11:20 PM in Bug Reports

avatar image

rojuinex
11 2 3 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi rojuinex,

I have not been able to reproduce this on our hardware with earlier specs, albeit 16GB of RAM. However, there are adjustments you can make that may resolve this for you:

Under "Settings," you can adjust the following two:

Settings_01

Settings_02

-And in the Viewport, click on the dropdown arrow to show these settings, including a link to the editor settings a the bottom?

Settings_03

Please try adjusting these and respond if they do not help. If not, let us know if this did not occur in previous versions Engine.

Thanks,

Steve H.

settings_01.png (16.0 kB)
settings_02.png (123.2 kB)
setting_03.png (123.5 kB)
more ▼

answered Jun 21 '16 at 07:18 PM

avatar image rojuinex Jun 23 '16 at 04:36 PM

Thanks for the suggestions, even doing everything you suggested here does not fix the issue. The flickering isn't constant now that realtime is turned off but as you can still see the meshes still get overlaid randomly with this dark checker pattern.

alt text

alt text

avatar image Steve Hardister ♦♦ STAFF Jun 23 '16 at 08:27 PM

That black checker pattern indicates there is something (a plane) between the object and camera... In the following example the widget is below the ground plane with the Z arrow just piercing it:

plane 1

... as opposed to the camera being positioned just below the plane. Now the X and Y arrows are not obscured by the plane while most of the Z arrow is:

plane 2

If there is no plane present, your GPU may be experiencing an issue or drivers may need to be updated.

Additionally, removing the "SphereReflectionCapture" widget will help:

reflector

plane1.png (165.4 kB)
plane2.png (143.5 kB)
reflectorcube.png (172.2 kB)
avatar image rojuinex Jan 26 '18 at 06:08 AM

Huh that's interesting. I know it's been a while but the scene was just a default scene and it didn't matter where the camera was everything had that pattern overlaid. I wonder if it was a z-indexing issue with the ui components.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question