x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

CPU Particles collision (Mesh Data)

It seems like the module doesn't work. I spawn single particle that I want to kill on collision with world geometry and skeletal meshes. But particle just pass trough all objects. Is there some special setup needed, or it just doesn't yet ?

Product Version: Not Selected
Tags:
more ▼

asked Mar 11 '14 at 01:48 AM in Bug Reports

avatar image

ue4-archive ♦♦ STAFF
49.9k 3662 1989 9113

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 01:48 AM

is your static mesh have collision primitive?

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 01:48 AM +

Yes, I have been testing with the meshes that are on default level.

show all comments (comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hi Lukasz and everyone,

Apologies for the delayed response. I have reproduced and reported this issue. Thank you for providing the information.

Cheers

more ▼

answered Mar 11 '14 at 01:48 AM

avatar image

ue4-archive ♦♦ STAFF
49.9k 3662 1989 9113

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Dear Lukasz,

To assist debugging, could you try using GPU particles in the same context / your spawn code, with a test particle system, and see if you can get them to collide?

If the GPU do collide, then it is your CPU setup

if the GPU dont collide, then it is the setup of the surrounding environment

Is the collision with a landscape?

Rama

more ▼

answered Mar 11 '14 at 01:48 AM

avatar image

ue4-archive ♦♦ STAFF
49.9k 3662 1989 9113

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Lukasz,

On the Collision module, there is a property called Max Collision Distance. This value defaults to 1000, and once the player camera is further away than that the collision will no longer occur. Try setting this to a higher value to see if that fixes the problem for you.

Cheers

more ▼

answered Mar 11 '14 at 01:48 AM

avatar image

ue4-archive ♦♦ STAFF
49.9k 3662 1989 9113

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 01:48 AM

I have set it to 10000, and tried some values in between, but it seems it doesn't solve my problem. Particle still pass trough all geometry in level, until it dies from reaching it's emitter duration lifetime.

Should I upload my particle along with some code that spawn it ?

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 01:48 AM

You are welcome to upload just the .uasset and I will take a look a look at it to determine if it is a simple content issue.

Thanks

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 01:48 AM

There it is. I thought at second that issue might be lack of collision bounds for particle mesh, but it turned out everything is in place.

link text

fx_trail.uasset (30.1 kB)
avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 01:48 AM

Hi Lukasz,

I have determined that collision actually is working on this particle. However I had to give the particle an Initial Velocity so I could test this. While moving, the particle stops when it collides with a StaticMesh with collision.

How exactly are you setting things up to test collision? Your particle does not move, so what are you moving for the test?

Thanks

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 01:48 AM

That would explain things I think. Because particle on it's own doesn't have any velocity. As you might have notice from my setup init velocity is parameter and I set this parameter via blueprint, which is in turn passed to code, where I spawn particle.

     if(TrailFX)
     {
         UParticleSystemComponent* TrailPSC = UGameplayStatics::SpawnEmitterAtLocation(Instigator, TrailFX, Origin);
         if(TrailPSC)
         {
             FVector ParticleSpeed = AdjustedDir * TrailSpeed;
             TrailPSC->SetVectorParameter(TrailSpeedParam, ParticleSpeed);
         }
     }

It's very simple code.

It might be that collision doesn't work while speed is setup via paramter on spawn ?

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 01:48 AM

I also have a particle system with CPU collision, that is spawned from code. And it too doesn't collides.

But if I add the particle system to the level, then collision works.

It could be a bug.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question