x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Any working multiplayer steam example?

Thanks for giving my question your time

i tried integrating steam (SHIFT + TAB works) and make it multiplayer but i am having issues.. editor crashes when i join a server.

i tried playing in viewport with 2 players, editor filled my RAM and crashed i also treid opening new window editor but whenever i clicked join server, editor hanged and did not respond

i thought i had done something wrong so i downloaded multiplayer shootout , it also crashes whenever i try joining a hosted server. (i am using PIE)

https://www.youtube.com/watch?v=6RlYegIkN0Y so i installed his project and editor crashed after hanging for 10 minutes filling my whole RAM and showed this error:

MachineId:34253C9D4F769135833497B2271F478F EpicAccountId:b4dbaefe748a46a3b70076cd4dfa170b

Access violation - code c0000005 (first/second chance not available)

""

UE4Editor_Engine!UWorld::RepairWorldSettings() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\engine\private\world.cpp:823] UE4Editor_Engine!UWorld::PostLoad() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\engine\private\world.cpp:591] UE4Editor_CoreUObject!UObject::ConditionalPostLoad() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\coreuobject\private\uobject\obj.cpp:723] UE4Editor_CoreUObject!StaticDuplicateObjectEx() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:1693] UE4Editor_CoreUObject!StaticDuplicateObject() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:1553] UE4Editor_UnrealEd!UEditorEngine::CreatePIEWorldByDuplication() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\editor\unrealed\private\playlevel.cpp:3455] UE4Editor_Engine!UEngine::LoadMap() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\engine\private\unrealengine.cpp:9457] UE4Editor_Engine!UEngine::TickWorldTravel() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\engine\private\unrealengine.cpp:8896] UE4Editor_UnrealEd!UEditorEngine::Tick() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\editor\unrealed\private\editorengine.cpp:1285] UE4Editor_UnrealEd!UUnrealEdEngine::Tick() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\editor\unrealed\private\unrealedengine.cpp:361] UE4Editor!FEngineLoop::Tick() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\launch\private\launchengineloop.cpp:2427] UE4Editor!GuardedMain() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\launch\private\launch.cpp:142] UE4Editor!GuardedMainWrapper() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\launch\private\windows\launchwindows.cpp:126] UE4Editor!WinMain() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.10\engine\source\runtime\launch\private\windows\launchwindows.cpp:200] UE4Editor!__scrt_common_main_seh() [f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:264] kernel32 ntdll

i am working on only one PC ,i don't own two. is there any working steam example there i can download? (i have given up on making one)

any help is appreciated.

Product Version: UE 4.10
Tags:
more ▼

asked Jun 23 '16 at 01:38 PM in Blueprint Scripting

avatar image

Prithvi Singh
560 16 9 14

avatar image chrismcr Jun 26 '16 at 12:48 PM

If you try to use the steam API in two processes simultaneously, the second one will fail to load it (won't show the steam overlay, with errors in the log). So you can't run host and client on the same machine. Also, steam doesn't work PIE, you have to run it Standalone. That said I don't think I've seen it crash in those situations, just not work.

Does the unmodified (non-steam) shootout example crash for you? If so, can you post the logs for server and client?

avatar image Prithvi Singh Jun 26 '16 at 02:33 PM

thanks for the reply,

it does not crash but makes my PC hang(makes it slow and ue4 stops responding as long as its open) so i have to force close it. (my PC is only 4GB RAM, but no project except open world demo , and if kept too much foliage have crashed till now) i will keep that open to see if crashes/runs afterwards (kept it open for 20 minutes before), i can open shootout example in PIE right? or i need standalone for that too? should i involve a laptop in this process?(i am clueless on multiplayer stuff whether its steam or LAN).

thanks in advance!

avatar image chrismcr Jun 26 '16 at 02:57 PM

Yeah shootout should be fine in PIE. Hang makes me think it's running out of memory - is there a lot of disk activity? Epic recommend 8GB for UE4 apparently (and 24 for the kite demo in editor!).

Are you running two instances of shootout PIE (i.e. setting number of players to 2 in the dropdown)? Can you run it PIE with players set to 1? If that runs okay you could try running the other player on another computer on your LAN and see if the reduced memory load helps.

avatar image Prithvi Singh Jun 26 '16 at 03:02 PM

is there any documentation/video for LAN you would recommend (setting up connection and all)?

about disk activity: it stays above 80% when running properly with nothing else open. it filled up when joining server (99%). i always have task manager open to keep an eye for RAM and stay optimized.

avatar image chrismcr Jun 26 '16 at 03:25 PM

I don't know a single source for UE4 network info, I had to read up and experiment a lot. In principle though LAN is really simple, especially since you can do it all in blueprints - on the server you just want to use the Create Session node then Open Level with the 'listen' option. On the client use Find Sessions and Join Session.

avatar image Prithvi Singh Jun 26 '16 at 03:28 PM

Thanks for clearing this out and giving time to this question :)

avatar image Prithvi Singh Jun 26 '16 at 03:09 PM

run fine with one even with 2 players in game but menu level with 2 player have issues.the main level(with game) runs fine with 2 players (in menu i am able to host session , find session , but unable to join, this happens with the one's log posted above as well)

avatar image chrismcr Jun 26 '16 at 03:33 PM

That is really strange. If the unmodified example crashes I am tempted to blame it on running out of RAM, though I'm not certain.

avatar image Prithvi Singh Jun 26 '16 at 03:45 PM

it crashed (shootout) but answerhub isn't letting me post it as a comment (showing - characters left)

my RAM reportalt text

levelsetup.jpg (730.8 kB)
avatar image Prithvi Singh Jun 26 '16 at 03:47 PM

the error report alt text

proof.jpg (246.0 kB)
avatar image Prithvi Singh Jun 26 '16 at 02:54 PM

if i cannot test it on one PC , how will i know if it will work on multiplayer mode on PC's , is there a way i can test if it works on PC?(multiplayer steam) please type in answer to mark as resolved i guess nothing else can be done.

Thanks for giving this question your time.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

The only thing I can suggest is you're running out of RAM. Sorry I couldn't be more helpful!

more ▼

answered Jun 26 '16 at 04:12 PM

avatar image

chrismcr
161 4 4 11

avatar image Prithvi Singh Jun 26 '16 at 04:13 PM

still very helpful to me for making things clear

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I have the same problem but I have 8 gb of ram....Imediatly after I host a game and from the second opened pannel in ue4 I join a sessions the Engine crushes. What shuld I do?

after I open back the engine, this is the log:

LogPlatformFile: Not using cached read wrapper

LogInit:Display: RandInit(1280953693) SRandInit(1280953694).

LogTaskGraph: Started task graph with 4 named threads and 5 total threads.

LogStats: Stats thread started at 0.052309

LogInit: Version: 4.10.4-2872498+++depot+UE4-Releases+4.10

LogInit: API Version: 2758231 LogInit: Compiled (64-bit): Feb 18 2016 15:47:04 LogInit: Compiled with Visual C++: 19.00.23026.00 LogInit: Build Configuration: Development LogInit: Branch Name: ++depot+UE4-Releases+4.10 LogInit: Command line:
LogInit: Base directory: F:/Aplicatii/UNREAL_ENGINE_4.10/UE_4.10/Engine/Binaries/Win64/ LogInit: Rocket: 1 LogInit: Using libcurl 7.41.0 LogInit: - built for x86_64-pc-win32 LogInit: - supports SSL with WinSSL LogInit: - other features: LogInit: CURL_VERSION_SSL LogInit: CURL_VERSION_IPV6 LogInit: CURL_VERSION_ASYNCHDNS LogInit: CURL_VERSION_LARGEFILE LogInit: CURL_VERSION_IDN

LogInit: CurlRequestOptions (configurable via config and command line):

LogInit: - bVerifyPeer = true - Libcurl will verify peer certificate

LogInit: - bUseHttpProxy = false - Libcurl will NOT use HTTP proxy

LogInit: - bDontReuseConnections = false - Libcurl will reuse connections

LogInit: - CertBundlePath = nullptr - Libcurl will use whatever was configured at build time.

LogOnline:Display: STEAM: Loading Steam SDK 1.32

LogOnline:Warning: STEAM: Steam API disabled!

LogOnline:Display: STEAM: OnlineSubsystemSteam::Shutdown()

LogInit: WinSock: version 1.1 (2.2), MaxSocks=32767, MaxUdp=65467

LogVoice:Warning: Failed to initialize voice interface

LogInit: Presizing for 0 objects not considered by GC, pre-allocating 0 bytes.

LogInit: Object subsystem initialized

LogInit: Selected Device Profile: [Windows]

LogInit: Applying CVar settings loaded from the selected device profile: [Windows]

LogInit: Computer: DESKTOP-DM6155E

LogInit: User: dragu

LogInit: CPU Page size=4096, Cores=2

LogInit: High frequency timer resolution =3.612235 MHz

LogMemory: Memory total: Physical=7.9GB (8GB approx)

LogMemory: Platform Memory Stats for Windows

LogMemory: Process Physical Memory: 58.27 MB used, 58.27 MB peak

LogMemory: Process Virtual Memory: 55.72 MB used, 55.72 MB peak

LogMemory: Physical Memory: 3492.24 MB used, 8134.27 MB total

LogMemory: Virtual Memory: 370.38 MB used, 134217728.00 MB total

LogTextLocalizationManager: No translations for ('ro-RO') exist, falling back to 'en' for localization and internationalization data.

LogD3D11RHI: Found D3D11 adapter 0: NVIDIA GeForce GTX 750 Ti (Feature Level 11_0)

LogD3D11RHI: Adapter has 2017MB of dedicated video memory, 0MB of dedicated system memory, and 4067MB of shared system memory, 1 output[s]

LogD3D11RHI: Found D3D11 adapter 1: Microsoft Basic Render Driver (Feature Level 11_0)

LogD3D11RHI: Adapter has 0MB of dedicated video memory, 0MB of dedicated system memory, and 4067MB of shared system memory, 0 output[s]

LogD3D11RHI: Chosen D3D11 Adapter Id = 0

LogD3D11RHI: !Direct3DDevice

LogRHI: Texture pool is 1361 MB (70% of 1945 MB)

LogD3D11RHI: Async texture creation enabled

LogShaderCompilers: Guid format shader working directory is -24 characters bigger than the processId version (C:/Users/dragu/OneDrive/Documente/Unreal Projects/Eliberate_the_fortun/Intermediate/Shaders/WorkingDirectory/4508/).

LogShaderCompilers: Cleaned the shader compiler working directory 'C:/Users/dragu/AppData/Local/Temp/UnrealShaderWorkingDir/A43CD225422595E4C568769840C5DE92/'. LogShaderCompilers:Display: Using Local Shader Compiler.

LogTemp:Display: Loaded TP AllDesktopTargetPlatform

LogTemp:Display: Loaded TP WindowsClientTargetPlatform

LogTemp:Display: Loaded TP WindowsNoEditorTargetPlatform

LogTemp:Display: Loaded TP WindowsServerTargetPlatform

LogTemp:Display: Loaded TP WindowsTargetPlatform

LogTemp:Display: Loaded TP AndroidTargetPlatform

LogTemp:Display: Loaded TP Android_ASTCTargetPlatform

LogTemp:Display: Loaded TP Android_ATCTargetPlatform

LogTemp:Display: Loaded TP Android_DXTTargetPlatform

LogTemp:Display: Loaded TP Android_ETC1TargetPlatform

LogTemp:Display: Loaded TP Android_ETC2TargetPlatform

LogTemp:Display: Loaded TP Android_MultiTargetPlatform

LogTemp:Display: Loaded TP Android_PVRTCTargetPlatform

LogTemp:Display: Loaded TP HTML5TargetPlatform

LogTemp:Display: Loaded TP IOSTargetPlatform

LogTemp:Display: Loaded TP LinuxNoEditorTargetPlatform

LogTemp:Display: Loaded TP LinuxServerTargetPlatform

LogTemp:Display: Loaded TP LinuxTargetPlatform

LogTargetPlatformManager:Display: Building Assets For Windows

LogDerivedDataCache:Display: Max Cache Size: 512 MB

LogDerivedDataCache: Loaded boot cache 0.05s 41MB C:/Users/dragu/AppData/Local/UnrealEngine/4.10/DerivedDataCache/Boot.ddc.

LogDerivedDataCache:Display: Loaded Boot cache: C:/Users/dragu/AppData/Local/UnrealEngine/4.10/DerivedDataCache/Boot.ddc

LogDerivedDataCache: FDerivedDataBackendGraph: Pak pak cache file C:/Users/dragu/OneDrive/Documente/Unreal Projects/Eliberate_the_fortun/DerivedDataCache/DDC.ddp not found, will not use a pak cache.

LogDerivedDataCache: Unable to find inner node Pak for hierarchical cache Hierarchy.

LogDerivedDataCache: FDerivedDataBackendGraph: CompressedPak pak cache file C:/Users/dragu/OneDrive/Documente/Unreal Projects/Eliberate_the_fortun/DerivedDataCache/Compressed.ddp not found, will not use a pak cache.

LogDerivedDataCache: Unable to find inner node CompressedPak for hierarchical cache Hierarchy.

LogDerivedDataCache:Display: Pak cache opened for reading ../../../Engine/DerivedDataCache/Compressed.ddp.

LogDerivedDataCache: Using Local data cache path C:/Users/dragu/AppData/Local/UnrealEngine/Common/DerivedDataCache: Writable

LogInit: Selected Device Profile: [Windows]

LogContentStreaming: Texture pool size is 0.000000MB

LogMeshUtilities: No automatic mesh reduction module available

LogMeshUtilities: No automatic mesh merging module available

UdpMessaging: Initializing bridge on interface 0.0.0.0:0 to multicast group 230.0.0.1:6666.

LogAssetRegistry: FAssetRegistry took 0.0109 seconds to start up

SourceControl: Info Source control is disabled

SourceControl: Info Source control is disabled

SourceControl: Info Source control is disabled

SourceControl: Info Source control is disabled

LogObj: 29059 objects as part of root set at end of initial load.

LogUObjectAllocator: 6386160 out of 0 bytes used by permanent object pool.

LogEngine: Initializing Engine...

LogHMD: Can't find Oculus library dev build: is proper Runtime installed? Version: 0.8.0.0

LogHMD: SteamVR failed to initialize. Err: 110

LogAIModule: Creating AISystem for world NewWorld

LogInit: XAudio2 using 'Speakers (Realtek High Definition Audio)' : 2 channels at 48 kHz using 32 bits per sample (channel mask 0x3)

LogInit: FAudioDevice initialized.

LogDerivedDataCache: Saved boot cache 0.03s 41MB C:/Users/dragu/AppData/Local/UnrealEngine/4.10/DerivedDataCache/Boot.ddc.

LogInit: Texture streaming: Enabled

LogAnalytics: Creating configured Analytics provider AnalyticsET LogAnalytics: [UEEditor.Rocket.Release] APIServer = http://et2.epicgames.com/ET2/. AppVersion = 4.10.4-2872498+++depot+UE4-Releases+4.10

LogAnalytics: [UEEditor.Rocket.Release] SetUserId f3b5004041ba251d0908518043e48842|d03edc60d034465eb06c1f60028be858|f26918a0-ae89-4a18-9bb6-7f527e5d6e99

LogAnalytics: [UEEditor.Rocket.Release] AnalyticsET::StartSession

LogInit: Transaction tracking system initialized

BlueprintLog: New page: Editor Load

LocalizationService: Info Localization service is disabled

LogCook:Display: Done creating registry. It took 0.00s.

LogFileCache: Scanning file cache for directory 'C:/Users/dragu/OneDrive/Documente/Unreal Projects/Eliberate_the_fortun/Content/' took 0.10s

SourceControl: Info Source control is disabled

Cmd: MAP LOAD FILE="C:/Users/dragu/OneDrive/Documente/Unreal Projects/Eliberate_the_fortun/Content/GAME/LEVELS/MainMenu.umap" TEMPLATE=0 SHOWPROGRESS=1 FEATURELEVEL=3

LightingResults: New page: Lighting Build

MapCheck: New page: Map Check

LightingResults: New page: Lighting Build

LogParticles: Destroying 0 GPU particle simulations for FXSystem 0x000002359ED8E160

LogAIModule: Creating AISystem for world MainMenu

LogEditorServer: Finished looking for orphan Actors (0.000 secs)

Cmd: MAP CHECKDEP NOCLEARLOG

MapCheck: Info Map check complete: 0 Error(s), 0 Warning(s), took 101.864ms to complete.

LogFileHelpers: Loading map 'MainMenu' took 0.755

LogCollectionManager: Loaded 0 collections in 0.001981 seconds

LogFileCache: Scanning file cache for directory 'C:/Users/dragu/OneDrive/Documente/Unreal Projects/Eliberate_the_fortun/Saved/Collections/' took 0.01s

LogFileCache: Scanning file cache for directory 'C:/Users/dragu/OneDrive/Documente/Unreal Projects/Eliberate_the_fortun/Content/Developers/dragu/Collections/' took 0.01s

LogFileCache: Scanning file cache for directory 'C:/Users/dragu/OneDrive/Documente/Unreal Projects/Eliberate_the_fortun/Content/Collections/' took 0.01s

LogCollectionManager: Rebuilt the GUID cache for 0 collections in 0.000002 seconds

LogContentBrowser: Native class hierarchy populated in 0.0059 seconds. Added 1913 classes and 346 folders.

LogContentBrowser: Native class hierarchy updated for 'WidgetCarousel' in 0.0007 seconds. Added 0 classes and 0 folders.

LogContentBrowser: Native class hierarchy updated for 'AddContentDialog' in 0.0011 seconds. Added 0 classes and 0 folders.

LogContentBrowser: Native class hierarchy updated for 'SceneOutliner' in 0.0006 seconds. Added 1 classes and 2 folders.

LogCrashTracker: Crashtracker disabled due to settings.

LogUObjectGlobals:Warning: Failed to find object 'Class None.'

LogLoad: Full Startup: 9.29 seconds (BP compile: 0.19 seconds)

LogSteamController: SteamController is not available

LogOcInput: Can't find Oculus library dev build: is proper Runtime installed? Version: 0.8.0.0

LogContentStreaming: Texture pool size now 1000 MB

LogRenderer: Reallocating scene render targets to support 1208x572 (Frame:2).

LogAssetRegistry: Asset discovery search completed in 5.2437 seconds

LogCollectionManager: Rebuilt the object cache for 0 collections in 0.000001 seconds (found 0 objects)

LogCollectionManager: Fixed up redirectors for 0 collections in 0.000025 seconds (updated 0 objects)

LogEditorViewport: Clicking on Actor (LMB): BP_Sky_Sphere_C (Sky Sphere)

LogSavePackage: Save=61.220821ms

LogSavePackage: Moving 'C:/Users/dragu/OneDrive/Documente/Unreal Projects/Eliberate_the_fortun/Saved/MainMenuC100900841CCBA10E88BB79046B1F4F3.tmp' to 'C:/Users/dragu/OneDrive/Documente/Unreal Projects/Eliberate_the_fortun/Content/GAME/LEVELS/MainMenu.umap'

LogSavePackage: Total save time: 96.581481ms

LogSavePackage:Display: Finished SavePackage C:/Users/dragu/OneDrive/Documente/Unreal Projects/Eliberate_the_fortun/Content/GAME/LEVELS/MainMenu.umap

more ▼

answered Oct 12 '17 at 03:32 PM

avatar image

TheAnimator2
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question