x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to disable auto-SteamVR launch on UE4 launch?

Whenever I launch an Unreal Engine 4 project, regardless of whether that project is a VR project or not, it launches SteamVR on my behalf. How can I disable this?

Product Version: UE 4.12
Tags:
more ▼

asked Jun 24 '16 at 05:26 AM in Using UE4

avatar image

kingkeoua
201 25 25 201

avatar image TorQueMoD Nov 03 '17 at 07:30 AM

Could you maybe accept the better answer (the one from Philippe23 that's been upvoted 20+ times) as your answer is a setting in Steam, not a way to fix the problem for a specific UE4 project. The easy solution is to disable the Steam VR plugin (if you're not using it).

avatar image dryware Jun 05 '18 at 10:48 AM

check the other answers too, it doesn't fix it for everyone.

avatar image ZNsolo101 Jan 27 '18 at 03:55 PM

Don't forget the apple ARkit Augmented reality its running to :P

(comments are locked)
10|2000 characters needed characters left

5 answers: sort voted first

Well, it took 5 minutes of poking around in settings... SteamVR has a Developer tab with 'Start SteamVR when an application starts'.

more ▼

answered Jun 24 '16 at 05:27 AM

avatar image

kingkeoua
201 25 25 201

avatar image Jarrastafari Sep 20 '16 at 09:59 AM

Thank you. My graphics card screeches at me while SteamVR is active, so this helped a lot. :-)

avatar image SergeOvD Jan 19 '17 at 10:47 AM

Thx for info

avatar image Zeiser Mar 11 '17 at 09:36 PM

That is unticked, unreal engine still insists on starting steam vr. So annoying, I just want to do some logic unrelated to any vr input, but that thing keeps starting up. Also changes my audio device at times, even though the setting says to do nothing when started and stopped.

avatar image TheFoyer Apr 07 '17 at 05:10 PM

Same, even with the setting unchecked some unreal games do launch SteamVR in steamVR plugin is enabled. If I disable the plugin in my own projects it seems to fix the problem. There is also a way to enable VR through the command line with -vr so I wonder if there is a way to disable it too.. hmm. It's really annoying for me because my son like to play an alpha version of a game that has SteamVR enabled when the game doesn't even support VR in the first place. So I have to make sure the headset is unplugged before I can fire up the game.

avatar image nic-hartley Jul 10 '17 at 07:20 PM

Did this. SteamVR still starts. This answer is wrong. It might have been correct at some point, but it no longer is.

avatar image Philippe23 Jul 10 '17 at 07:26 PM

@nic-hartley see the most upvoted answer below (not the accepted one) and see if it helps you.

avatar image nic-hartley Jul 12 '17 at 01:16 PM

Already did; it doesn't work either. I just gave up on telling people their solutions are wrong after trying every solution I could find and none of them working.

avatar image Jake1337 May 23 '18 at 11:05 AM

Just what I was looking for - TY :)

(comments are locked)
10|2000 characters needed characters left

Disable the SteamVR plugin from within the Editor in the Plugin configuration pane. (You may wish to also disable other VR systems you're not supporting.) The Editor will need to be restarted.

more ▼

answered Dec 22 '16 at 04:18 PM

avatar image

Philippe23
400 1 24 24

avatar image FOVE_Scott Feb 02 '17 at 09:08 AM

This is the one I wanted. Thanks. :)

avatar image ferdbold Feb 21 '17 at 12:51 PM

This is what worked for me, disabling "Start SteamVR when an application starts" in SteamVR did nothing on my end

avatar image mr_pinc Feb 23 '17 at 07:19 PM

This is the correct answer. The above answer will disable Steam VR from launching for all VR apps. If you want to just disable it for Unreal you need to disable the plugin.

avatar image Amirulradzi Mar 31 '17 at 09:41 PM

how to test if vr is launched or not ? one of my customer complained that his vr was launched when he started my game and i don't know what is he talking about because I don't have vr and the game run find . Perhaps i can just disable all vr plugin and make a small updates . any information ?

avatar image nic-hartley Jul 12 '17 at 01:16 PM

This doesn't work either. Before I can even select a project to open -- i.e. when I open Unreal from the Epic Games Launcher, or even if I start it independently -- SteamVR starts. Just to make absolutely sure, I've removed the VR plugin on all of my projects. It still doesn't work.

avatar image dlam26 Aug 23 '17 at 04:41 AM

same, on 4.16.2 disabling the occulus and steamvr plugins dosen't prevent the two sfrom starting when Unreal Engine starts

avatar image travisneids Oct 03 '17 at 12:47 PM

As of 4.17.2 this solution worked for me. This should now be the accepted answer. @nic-hartley Id reinstall man. You are the 2%er

avatar image Theman2k Jan 06 '18 at 12:03 PM

It didn't work the first time I tried turning it off in the pkugins menu. But then I tried it again and saw it was still on, so I turned it off again and restarted.

Now it worked. Thanks.

(comments are locked)
10|2000 characters needed characters left

The way I've stopped SteamVR from auto-launching with different applications is by:

  1. Move the SteamVR folder away from inside "../Steam/steamapps/common", since applications can't launch what they can't find.

  2. Whenever you want to use VR, start it preemptively, using "../SteamVR/bin/win64/vrstartup.exe" (or whichever OS you have), I also recommend creating a shortcut.

more ▼

answered Jul 30 '17 at 08:54 AM

avatar image

fluf0
6 1

(comments are locked)
10|2000 characters needed characters left

I only tested this on the editor from source. You can edit the file: $PATH_TO_UNREAL_SOURCE%\Engine\Plugins\Runtime\Steam\SteamVR\SteamVR.uplugin

See that the following line is set to false:

"EnabledByDefault" : false,

more ▼

answered Feb 12 '19 at 04:28 AM

avatar image

cgonzoo
6

(comments are locked)
10|2000 characters needed characters left

'SteamVR has a Developer tab with 'Start SteamVR when an application starts'. Thanks, That did it, saved me a lot more than five minutes!

more ▼

answered Feb 19 '17 at 02:25 PM

avatar image

Ian_Tetrault
0 2 3 5

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question