x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Event Begin Play is being fired too early on Android

If I use "Open Level" node or console command "open levelname", Begin Play event is being fired too early(before new level has seen), on slow Android phones. But if I use console command "RestartLevel", it is being fired in time, because it loads the same level faster while restarting.

It causes some problems, for example, I can't connect to the internet if it is being fired early. There are online events in the begin play node but they fail because of this bug.

There isn't any problem on editor.

Product Version: UE 4.12
Tags:
more ▼

asked Jun 24 '16 at 07:29 AM in Bug Reports

avatar image

SalihBalkan
429 16 28 58

avatar image Rudy Q ♦♦ STAFF Jun 24 '16 at 07:03 PM

Hello SalihBalkan,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?

  3. Could you provide screen shots of any blueprints that may be involved with this issue?

  4. What is the exact device that is being used?

  5. What is the current OS that is being run on the device?

  6. Could you try placing a delay node between the begin play node and the open level node and let me know if this helps?

avatar image SalihBalkan Jun 27 '16 at 04:12 PM
  1. Yes, I was able to reproduce with default car template too.

  2. Use the blueprint below and see what happens when you've just seen the game rendering. You will probably see multiple "Hi"s when the game actually started. Please note that the device that I tested loads the game in more than 5 seconds. If you are using a faster device, make timer loop time a smaller value than 1.0 second.

  3. alt text

  4. Zenfone A501CG, which has a slow RAM.

  5. Android 5.0 (Since I am a developer, of course it is rooted.)

  6. Yes, putting a delay node solved the internet connection problem. Also, increasing the TCP handshake time solved the problem too.

untitled.jpg (69.4 kB)
avatar image Rudy Q ♦♦ STAFF Jun 27 '16 at 09:00 PM

With the given setup shown above I was able to have the print string show up as expected. Could you provide a sample project that reproduces the issue that you are seeing?

avatar image SalihBalkan Jun 27 '16 at 10:45 PM

Here is the project: https://www.dropbox.com/s/gsq3229lkbiamln/BeginPlayTest.zip?dl=0

And a video: https://www.dropbox.com/s/gyf376j4cnxx7ym/BeginPlayTest_Video.mp4?dl=0 (Download to watch in higher quality.)

I changed the blueprint a little bit. Look at the printed time just when you see the game completely opened. It starts with 0.7 second instead of 0.

avatar image Rudy Q ♦♦ STAFF Jun 29 '16 at 08:41 PM

I ran a couple of tests using the project that was provided. However, I did not see the issue that you mentioned with it skipping print strings. I made a couple of changes for the test to see everything. Could you try the changes below and let me know if you still have this issue?

alt text

beginplayissue.png (117.2 kB)
avatar image SalihBalkan Jun 29 '16 at 10:57 PM

I tried with the changes in your blueprint. It doesn't stuck at the black screen but result is still unexpected. Expected result is only one print.

When the game really begins, early printed texts are being rendered at the same time. alt text

New video: https://www.dropbox.com/s/qxlun5n28vncmy7/BeginPlay_Video_2.mp4?dl=0

alt text

untitled.jpg (71.3 kB)
untitled.jpg (100.8 kB)
avatar image Rudy Q ♦♦ STAFF Jul 06 '16 at 05:42 PM

Hello SalihBalkan,

I am not seeing the results reported on my end. Are you packaging out or are you launching on? Does either of these make a difference?

avatar image SalihBalkan Jul 06 '16 at 07:07 PM

I am packing out. This problem doesn't occur with "Launch" button and on fast android devices. It only occurs with Asus A501CG which has a slow memory(or sd card) access.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello SalihBalkan,

After taking a look at the specs on the device you mentioned above, I do not currently have access to a comparable device. This appears to be a limitation of the device.

more ▼

answered Jul 12 '16 at 06:37 PM

avatar image

Rudy Q ♦♦ STAFF
47.4k 545 132 523

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question