x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Vive preview in Direct Mode stuck at 60fps

I saw another post about this issue but it seemed to relate more to not using direct mode and changing the location of your secondary screen. In direct mode I have had it run perfectly fine once, and I haven't a clue what I did differently then as compared to all other times where it is locked at 60fps. What am I doing wrong here?

Edit: I created a new blank project and I get 60fps still with the jittery view

Product Version: UE 4.12
Tags:
more ▼

asked Jun 26 '16 at 12:28 AM in VR

avatar image

McPhearson
49 4 7 12

avatar image Krxtopher Jun 26 '16 at 03:55 PM

When you say "blank project", can you tell us what initial options you're choosing? Desktop vs. Mobile. Max Quality vs. Scalable 3D/2D. Starter content vs. no starter content.

avatar image McPhearson Jun 26 '16 at 07:10 PM

Thanks for the response, I took a snapshot of how I have been making my blank project:

alt text

img.jpg (62.1 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

I'm typing on my phone so I'll make this brief, what ended up fixing it for me was to go into the settings in the nvidia control panel and change vsync from adaptive to off

more ▼

answered Jul 18 '16 at 07:12 PM

avatar image

McPhearson
49 4 7 12

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

With those settings your project basically has everything "turned up to 11". :) In particular, it includes post processing effects like bloom and others that can really bog down VR. Try setting up a new project using the VR best practices documented here and report back on whether it improves things...

https://docs.unrealengine.com/latest/INT/Platforms/VR/ContentSetup/

more ▼

answered Jun 26 '16 at 08:07 PM

avatar image

Krxtopher
825 27 15 57

avatar image McPhearson Jul 12 '16 at 01:51 AM

Sorry for the delay, I have been trying to follow the link in my free time. I am not entirely sure if I am doing everything correctly. If I am though it is still not working, but while I was using the Vive example template (seen here: https://forums.unrealengine.com/showthread.php?106609-Steam-VR-Template ) one day the framerate magically was working great then the next day it started being jittery again even though I made no changes to the project.

To follow that link you posted though I made a new project, so far I suspect I am doing the "VR .INI Settings" portion incorrectly. I opened the DefaultEngine.INI and just pasted the whole example they have there. Is that how it is supposed to be done?

I was also confused with the post process volume, but I think I figured out how to get it into the level and started doing as it said setting values on and setting them to 0, I don't have much of a clue as to what I am turning off but I pretty much turned any 1.0 to 0 unless it was some sort of color values. This is been really frustrating especially when I see it working just fine randomly on its own. Could steam VR be the issue?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I have a similiar strange problem with the 60 fps lock since 4.12. When I start my game initially over Steam I am getting always 60 fps and if I start it from the Desktop I have nice 90 fps. After a first start from the Desktop, the second start over Steam is also at 90 fps.

more ▼

answered Jul 13 '16 at 03:54 PM

avatar image

Cyxx
26 1 2 3

avatar image McPhearson Jul 18 '16 at 07:28 PM

what ended up fixing it for me was to go into the settings in the nvidia control panel and change vsync from adaptive to off. Hope this helps!

avatar image Cyxx Dec 22 '16 at 09:32 PM

The 60 fps problem is now also solved for me, after publishing my game on Steam and marking it as a VR application, the issue got fixed and the game starts now nicely with 90 fps.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question