x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Collision stays after using in game "Set Max Draw Distance" of LOD of Rendering propery of ISM

It is not normal to be able to automatic hide ISM but its collision to be present!?!?

Product Version: UE 4.11
Tags:
more ▼

asked Jun 26 '16 at 03:18 PM in Bug Reports

avatar image

Angel Tsvetkov
277 26 37 53

avatar image Adam Davis STAFF Jun 27 '16 at 08:06 PM

Hi Angel,

Are you hiding or unchecking visibility? What steps can I take to reproduce this on my end?

avatar image Angel Tsvetkov Jun 28 '16 at 09:21 AM

Hello,

I am not either hiding or unchecking visibility. Here is what I do:

  1. I create one blueprint actor (BA) containing one ISMC under Scene Component.
    I have only two modified properties in this ISMC:
    a)Static Mesh is "1M_Cube" (from template, startercontent,etc.); b) "Collision Presets"->"BlockAll";

  2. In game mode (runtime mode, procedural generating content) I create many BA and set "Set Max Draw Distance" (in LOD) to some value.

  3. When Pawn is moving and respective BA actors hides, their collision is staying and I can't walk through them even they doesn't show.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

This is expected behavior. Max Draw Distance affects the rendering of an actor, not the collision. To affect collision, you will need to change it via blueprints or c++.

more ▼

answered Jun 28 '16 at 03:03 PM

avatar image Angel Tsvetkov Jun 28 '16 at 03:26 PM

Its mean that I need to check on each Pawn move which BA actors are above this "Max Draw Distance " number? It is ridiculous. If I have 1m BA all my performance will go to that check!

avatar image Adam Davis STAFF Jun 28 '16 at 03:34 PM

Not necessarily. You can, by contrast, do a sphere collision around your player character that disables collision on end overlap with any actors that you wish, ignoring those that require persistent collision (if any). Then, when they overlap the player's sphere again, return collision. This will allow you to control which actors have collision without having to depend on framerates to be able to do so.

Alternatively, you can, on a timer send out a sphere trace around the player to a specified distance and turn off any actors not within that sphere. If the sphere is large enough there is never a chance that an actor will not be caught within the sphere's collision trace and as a timer it shouldn't have a dramatic impact on performance because it is still not framerate dependent. Relying on tick is the least desirable option of several because it would not be optimized, so in the long term won't be nearly as viable or performant as other options that would be less intensive.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question