x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Strange Lighting Artifacts

Hi all, I've been having these lighting bugs for a while now. For some reason I get these orange blotches all over the place. alt text

All meshes have perfect lightmap-uvs (custom made on a 2nd UV-set, and in engine lightmap-index set to correct index (1). The lightmap resolution is also fine. alt text

I only use static lighting, and use the lightmass settings shown on image below. I have noticed that it gets less, when I use a Indirect Lighting Quality. alt text

Things I have tried: - Changing Materials - Change Light intensity - Change color of lights - Increase Light building quality

Thanks!

Product Version: UE 4.11
Tags:
lighting01.png (2.7 MB)
lighting02.png (2.2 MB)
lighting03.png (55.3 kB)
more ▼

asked Jun 26 '16 at 06:27 PM in Rendering

avatar image

Ambrosiussen
1 1 2 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

That value for "Static Lighting Level Scale" looks suspiciously low. In most situations you'll want that value pretty close to 1. Unless the scale of your models is significantly different from Unreal Engine's default (1 world unit = 1 cm) then you shouldn't have to change this value significantly. If you change it to 1 what sort of change do you see with the blotchiness?

Also, just to debug, try turning off "Compress Lightmaps." This will at least eliminate compression artifacts which can sometimes get in the way of seeing the true effect of what changes to the other values do.

more ▼

answered Jun 26 '16 at 08:36 PM

avatar image

Krxtopher
825 27 15 57

avatar image Ambrosiussen Jun 26 '16 at 09:01 PM

Hi Krxtopher, thanks for your reply.

I set the Static Lighting Level Scale to 0.15 just to see if it would fix the issue. (As I saw many Archvis Lighting setups have such a low number) Usually I always leave it to 1. I noticed however that setting the "Static Lighting Level Scale" to 0.15 increased the fequency of the orange spots on the meshes.

Turning "Compress Lightmaps" off, increased the amount of artifacts, and their size. The orange now covers the entire mesh.

The only real solution so far, is to set the "Indirect Lighting Quality" to 10+, but thats not really a long term solution.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I assume your baking on max quality? Look like it's from the light bake rays where you just aren't getting enough rays in this area. You can increase the quality which should increase the number of rays used. You can probably also adjust some of the ray number settings in the config files (as was the case in UE3)

With light calculations like this when your main light is several bounces away you can get this kind of degradation easily. One less cpu intensive solution is to place some of your own soft lights to simulate some bounce light yourself just having these extra subtle lights can help.

One thing to keep in mind is that once you have textures etc. (assuming you will) on these object the splotches will be less noticeable as well.

more ▼

answered Jun 26 '16 at 09:48 PM

avatar image

BarrettMeeker
59 3 7 12

avatar image Ambrosiussen Jun 27 '16 at 12:33 PM

Hi BarrettMeeker,

Like my post stated; when baking on high quality, the bugs dissapear. This however is very troublesome when a fast iteration speed is required.

I also dont think its because of the light degradation, because then the places that have a high level of occlusion would not have the same amount of errors. The scene however is already textured, and it's very noticeable. (looks like its emitting light).

I also found that when baking multiple levels at once in a persistent level, the error doesnt show up.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Ambrosiussen, I missed the part about you not baking at High or Production quality! I think you may have to temper your expectations about being able to get fast bake times and perfect quality. Fast bake times (for quick iterations) require quality tradeoffs.

If you want to speed up bake times for High or Production bakes, I'd recommend setting up other computers on your network to act as Swarm clients. This will allow the processing to be distributed to multiple computers and thus speed up your lighting builds. You'll find information about how to set up Swarm here: https://answers.unrealengine.com/questions/27550/swarm-what-is-it-and-how-to-use-it.html

more ▼

answered Jun 27 '16 at 02:26 PM

avatar image

Krxtopher
825 27 15 57

avatar image Ambrosiussen Jun 27 '16 at 04:23 PM

Hi,

I understand that Quality vs Iteration Speed is a tradeoff which is always present. The strange thing however is that this bug only appears in one out the total 7 Maps. All of which dont have this problem when building on the lowest quality possible. (The bug however doesnt appear when I build the lighting in a persistent level holding this particular scene).

Regarding Swarm.. I am aware of its capabilities, but have not yet had the chance to test it with multiple computers :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

One other idea, are you making sure your using a lightmass importance volume when baking? Your note about how when you build with all the levels together it looks fine makes me think maybe when your building with just that level you don't have a lightmass importance volume set up or maybe it's not encompassing the full area needed? Just another thing to check.

more ▼

answered Jun 28 '16 at 02:42 AM

avatar image

BarrettMeeker
59 3 7 12

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question