x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Limiting FPS causes stuttering + 'Smooth Frame Rate' problem

'Smooth Frame Rate' (under 'General Settings') causes single stutter every ~0.5s. It can be fixed by limiting FPS (to e.g. 60) by 'Fixed Frame Rate' parameter or via 't.maxfps 60' console command - but this, on the other hand, causes stuttering every ~20 seconds for around ~3 seconds!

I'm testing it on Epic Top Down Template project, running around and seeing single stutter every ~0.5s (when 'Smooth Frame Rate' is on) OR seeing ~3 second long stuttering every ~20 seconds (when FPS is limited to 60)

Is this a bug or maybe it's happening only on my end? I can't test it on other PCs... Here is my DXDIAG: DXDIAG

How can I fix this? Any ideas?

Update: I've tested it on 4.11 and it also happens there...

Product Version: UE 4.12
Tags:
dxdiag.txt (88.1 kB)
more ▼

asked Jun 26 '16 at 08:48 PM in Rendering

avatar image

Slavq
2k 157 153 210

avatar image Tim Hobson ♦♦ STAFF Jun 27 '16 at 06:04 PM

Hey Slavq,

This posted answer here by Eric can help you understand how VSync and Smooth Frame Rate work together.

https://answers.unrealengine.com/questions/90743/what-exactly-does-smooth-frame-rate-do.html

-Tim

avatar image Slavq Jun 27 '16 at 06:52 PM

Thanks, I've read this before and now again, but I still don't understand why it stutters like this (~3s-long stuttering every ~20 seconds when FPS is locked at 60 FPS seems... Weird) and what I can do to fix it?

'V-Sync Stutters When Frame Rates Drop' - but my FPS is consistent and never drops (at least that's what 'stat FPS' command tells me) - I've tested it on a simple Top Down Template project and Rolling Ball template - so there it even doesn't have any reason to suddenly drop FPS.

So this is something wrong on my end, maybe with graphics card? But I don't have any stuttering problems e.g. when playing different games locked at 60 FPS, so this confuses me...

I've also tried setting these propetries to different FPS values, but it only changes stutter frequency.

avatar image Tim Hobson ♦♦ STAFF Jun 27 '16 at 08:12 PM

It's not something that I can reproduce on my machine here. I'll try this tonight when I get home and see if I see what you're seeing on my home machine. It's a closer match to your specs than my machine here at the office. Shouldn't take me but a few minutes to see and if I see the same results maybe I can offer some tips to improve on your end, but not sure yet.

In the the meantime make sure that you're on the latest drivers for your graphics card. I see you're on the 364 drivers. The latest is currently up to 368.22.

avatar image Slavq Jun 27 '16 at 09:58 PM

Thank you, I've just installed new 368 drivers, but sadly it didn't change anything.

Additional interesting behavior:

  • When I set 'Smoothed Frame Rate Range' min to 59.5 and max to 60.5, the stutter occurs every ~1s.

  • With min == 59.75 and max == 60.25, it stutters every ~2s.

  • With min == 59.875 and max == 60.125, it stutters every ~3s...

The stutter is best visible when smoothly moving (e.g. running through Top Down Level) and observing other objects passing by, e.g. the cubes or other level geometry.

avatar image Slavq Jun 28 '16 at 12:20 PM

Update: I've suddenly fixed it by typing 'r.VSync 1' in console! It fixed both stutter cases (stuter every ~20s. when locked at 60 FPS and every ~0.5s. when frame smoothing on)

... Is it normal that V-Sync is turned off in UE by default? How can I set it ON by default, without need to type 'r.vsync 1' every time to fix the stuttering?

avatar image Tim Hobson ♦♦ STAFF Jun 28 '16 at 08:16 PM

Something came up and I couldn't test at home last night, but regardless of that, thanks for posting your update.

Vsync is always off by default. I must have misread up above because I mistakenly had thought you had enabled it already.

You don't have to enter it every time. You can add r.Vsync=1 to the DefaultEngine.ini under the System Settings section and relaunch the editor.

You can check it by going to the Output Log window and typing in "r.vsync ?" (without the quotation marks) to see what the default value is now set to.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question