x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

[Gear VR] Dynamic lighting doesn't work at all

I figured it would be nice trying to have one directional light, non-shadow-casting, to bring out normal maps on movable actors.

Turned out that dynamic lights don't work at all on Gear VR (I suspect they don't work on Android, period)

Product Version: UE 4.12
Tags:
more ▼

asked Jun 27 '16 at 01:27 PM in VR

avatar image

motorsep
378 39 48 66

avatar image motorsep Jun 30 '16 at 01:30 PM

Did more testing and dynamic directional lights do not work on Gear VR (or perhaps on mobile in general).

Stationary lights do work in 4.12.4, but require distance field shadows for static lighting, which is a performance drainer compare to lightmaps.

avatar image Rudy Q ♦♦ STAFF Jul 05 '16 at 07:22 PM

Hello motorsep,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?

  3. Could you provide screen shots of any blueprints/settings that may be involved?

  4. Could you tell us what device it is that you are using?

  5. Could you also provide the exact OS that is currently running on the device?

avatar image motorsep Jul 06 '16 at 03:38 AM

Hi Rudy,

I am gonna have to try creating new project and testing it.

Steps are simple - create BP FPS template, place static meshes (set them to cast dynamic shadows), make them Static, set directional light to be Stationary (affect world, cast dynamic shadows; play with distance settings, etc.), build, play in PIE - shadows are there. Then deploy to S6 (is what I use) and observe no shadows.

I am using T-Mobile's Galaxy S6 64Gb, Android 6.0.1

avatar image Rudy Q ♦♦ STAFF Jul 12 '16 at 06:45 PM

Hello motorsep,

Were you able to reproduce this issue in a clean project?

avatar image motorsep Jul 12 '16 at 06:56 PM

Sorry, not quite yet. Been dealing with my launcher connectivity report, Gear VR performance and Oculus FMOD issues with UE4.

I'll get to this one pretty soon!

avatar image motorsep Jul 13 '16 at 04:52 AM

alt text

FPS Template, UE 4.12.5, everything is default, directional light is Stationary with static and dynamic shadows.

White boxes are movable, gray - static.

As you can see - no shadows from movable objects on the device. There are shadows in PIE, even in ES2 mode, but not on the device.

In my other project (the one I PM'ed you) I don't get even static shadows with Stationary directional light.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

After further testing with the project provided I believe the following information may help.

Information:

  1. You need to enable "Receive combined static and CSM shadows" when using stationary light. This needs to be enabled on ALL static meshes you want to receive both shadow types.

  2. In your directional light source you will need to disable "Inset Shadows for Movable Objects".

  3. If you would like to use a fully dynamic light (no baking), you will need to set the light to Movable, and adjust the Shadow Distance. However, dynamic lighting will largely be dependent on the device and it's specs

more ▼

answered Aug 03 '16 at 07:18 PM

avatar image

Rudy Q ♦♦ STAFF
47.4k 545 132 523

avatar image motorsep Aug 03 '16 at 07:25 PM

Thanks Rudy, I will do some tests using your suggestions!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi motorsep, I can only get dynamic objects to cast a shadow on mobile if I set the directional light source to also be moveable. Not stationary. If I add a cube to the level, set it to simulate physics and set the light source to moveable, I get dynamic shadows on mobile. Also remember to build your lighting.

Cheers,

TeamKingdom

more ▼

answered Jul 13 '16 at 05:40 AM

avatar image

TeamKingdom
87 9 10 15

avatar image motorsep Jul 13 '16 at 12:25 PM

I did build lighting and someone from Epic advised on using Stationary light and not fully dynamic. When using directional moving light performance is atrocious.

avatar image Rudy Q ♦♦ STAFF Jul 13 '16 at 06:23 PM

Hello motorsep,

As a quick test could you try enabling Cast Modulated Shadows and let me know if this makes any difference on the device?

avatar image motorsep Jul 13 '16 at 11:59 PM

Hi Rudy,

Nope, no dynamic shadows from movable actors on the device with modulated shadows on.

avatar image motorsep Jul 14 '16 at 12:04 AM

Btw, I think there are bigger issues with Stationary lights - I was messing with settings of the light in ES2 mode, turned off dynamic shadows, turn them back on and shadows were gone :/

Then I closed project, reopened it (with SM5 preview by default) and shadows were still gone :/

So now I don't have dynamic shadows at all, not in PIE, not on the device.

avatar image Rudy Q ♦♦ STAFF Jul 18 '16 at 03:42 PM

Just wanted to double check, but did you have your Light source set to Stationary? Modulated shows requires the light to be Stationary.

avatar image motorsep Jul 18 '16 at 03:48 PM

Yep, I did set it to Stationary. Initially, when I just set the project up, I did have static shadows from Stationary light, but no dynamic shadows. When I ticked Modulated shadows, I got some nasty "shadows" in PIE, so I turned that off.

Then I played with various settings, and ended up without any dynamic shadows in PIE (not even modulated).

avatar image motorsep Jul 18 '16 at 03:50 PM

I'll see about uploading that project. It's not that big in size.

avatar image Rudy Q ♦♦ STAFF Jul 22 '16 at 07:55 PM

Hello motorsep,

I wanted to check in on the progress for the project that you mentioned above. I was wondering if you had an example project that reproduces the issue mentioned here?

avatar image motorsep Jul 24 '16 at 02:58 AM

Yep, ready.

Here is the video of what I see in ES2 PIE:

https://www.youtube.com/watch?v=PJMI9fXf6q4

and here is the project:

https://drive.google.com/open?id=0BwE6dxM0O2Psblhpemh5LTViZ00

Also worth noting that the project I sent you via PM on the forums has no shadows at all, with the same setup I got going in this project I linked above.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question