x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Material not loading fast enough

I have hundreds of static mesh actors and hundreds of materials. I'm using the Set Material blueprint node to assign the material to the meshes.

When I run my project, I notice that all my meshes appear grey! alt text

I know that my material is definitely being set (because the original material was the white Default material), and it looks like the material simply hasn't loaded.

Is there a way to work around this?

(The material actually shows up on some of my meshes, but it doesn't show up for the majority of them)

Product Version: UE 4.12
Tags:
grey.png (943.1 kB)
more ▼

asked Jun 27 '16 at 08:32 AM in Rendering

avatar image

zephyrite
1 1 2

avatar image tedshrop Jun 28 '16 at 02:53 PM

The problem could be that your VRAM isn't keeping up with the project. Are the objects really high-poly? It would help if you post a photo of the blueprint of your material, as well as the scene it's in. Let me know the specs on your computer and I can probably figure out if that's what's keeping you down.

avatar image zephyrite Jun 29 '16 at 02:38 AM

Each mesh has about 33,000 triangles, and there are a few hundred of them in my scene, although they're already placed before run time. I'm simply assigning material at run time.

Here's a photo of the material BP (I didn't do anything to it). alt text

There's literally no scene. It's just my mesh/texture in the middle of the default plane. Here's a picture anyway. alt text

Computer specs: Edition: Windows 10 Pro Version: 1511 OS Build: 10586.420 Processor: Intel(R) Core(TM) i5-6600 CPU @ 3.30GHz 3.30 GHz Installed RAM: 32.0 GB System type: 64-bit operating system, x64-based processor

Thanks tedshrop~!

mat bp.png (114.3 kB)
scene.png (803.8 kB)
avatar image tedshrop Jun 29 '16 at 08:32 PM

Does it work when you assign the texture before runtime? Or does it still not work. It's a good thing to check because it will eliminate the possibility of it being a problem with the texture or mesh.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question