x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Failed to cook dedicated server

I develop a multi-player game. I will hosting the game server on a dedicated server, so I need the dedicated and standalone server

I follow this tutorial, but, at step 8, I can't cook content... The message log is : "game module target is not found" Any idea? Thanks

Product Version: UE 4.12
Tags:
more ▼

asked Jun 28 '16 at 07:01 AM in Packaging & Deployment

avatar image

Vana29
31 3 6 7

avatar image Vana29 Jun 28 '16 at 07:01 AM
avatar image Samantha Sutton ♦♦ STAFF Jun 29 '16 at 08:24 PM

Vana29,

In order to better assist you, I will need the full output logs uploaded as a .txt file.

Thank you!

avatar image Vana29 Jun 30 '16 at 03:40 PM

Sorry, there is the log link text

avatar image Samantha Sutton ♦♦ STAFF Jun 30 '16 at 08:59 PM

Vana,

It looks as though your issue can be resolved by reviewing this post. Please let me know if you're still having trouble after going through the steps.

Thanks! :)

avatar image Vana29 Jul 04 '16 at 08:24 AM

I think I have not package the project. So, after launch the uproject with the build engine, I launch the package build but I have some errors. link text

log.txt (16.0 kB)
avatar image Samantha Sutton ♦♦ STAFF Jul 05 '16 at 06:08 PM

Your error is as follows: MainFrameActions: Packaging (Windows (64-bit)): UnrealBuildTool: ERROR: Couldn't find target rules file for target '-Project=C:\Users\Ludovic\Documents\Unreal Projects\test\test.uproject' in rules assembly 'UE4Rules, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'.

Please make sure you've built your project correctly in Visual Studio for the target platform. Check through the steps in this AnswerHub post and see if any of them help get you further along in packaging. Please also try to create a new project that's similar to the one you're working with and try to package it.

Please upload the new logs once you've attempted these.

Thanks!

avatar image Ludea35 Jul 05 '16 at 07:50 PM

I delete my project, recreate a new c++ project, build it with VS alt text

I delete the build and intermediate/build folder but I have always the same error ... I can't packagelink text

log.txt (88.7 kB)
avatar image Ludea35 Jul 05 '16 at 08:01 PM

(I create my project with my build of unreal engine )

avatar image Vana29 Jul 05 '16 at 08:47 PM

We are on the same project, and we have the same error

avatar image Vana29 Jul 06 '16 at 10:42 AM

I will update VS to update 3 and retry

avatar image Samantha Sutton ♦♦ STAFF Jul 06 '16 at 02:20 PM

Have you both updated? Visual Studio update 3 is going to more than likely cause trouble for you with 4.12.4.

Is this happening on a newly created project? If you can provide me with exact, full repro steps, I will gladly try to reproduce what you all are doing here.

Thanks!

avatar image Vana29 Jul 06 '16 at 09:12 PM

there is a fix for Update 3 :

Hi everyone,

I just wanted to pop in here real quick to let you know that we do not yet officially support Update 3 for Visual >Studio. Our goal is to have support for new VS updates by the time they are officially released (Release Candidate >versions are not official final release versions). Sometimes we are able to get that support into the Engine early, but >as of right now it is not in place.

I brought this up with the individual who will be responsible for making sure support for Update 3 is added to the >Engine. He has not done any testing on this yet, but he believes it should be possible to correct this issue by >opening the WindowsPlatformCompilerSetup.h file in source code (this won't correct it for the binary version of the >Engine, unfortunately), and remove 4599 from the table of warnings at the top. Then add #pragma warning(disable : >4599) below the list. It is possible that this may not work since the warning is coming from command line arguments >instead of source, but it's the first thing he is going to try when he starts working on support for Update 3. He also >said that he does not believe this edit will have any adverse affect on your game code generation, but stressed >again that he has not done any testing yet.

For now we recommend sticking with Visual Studio 2015 Update 2.

Tim

I have not test yet with it.

For step, I just open the last Unreal version (4.12.4) with the launcher( or from source, it's the same error), create a c++ project. I try to open the uproject file, but it says the dll is misiing and rebuild from source. I open the sln project, build with VS and reopen the uproject. I try to package and I have the error message

avatar image Samantha Sutton ♦♦ STAFF Jul 07 '16 at 02:14 PM

Thanks for sharing the workaround. :)

So I created a C++ project on the binary version of the engine. I closed Visual Studio and the project and proceeded to open the .uproject. It loaded without any dll errors.

Please update me once you have tested with the update.

Thanks!

avatar image Vana29 Jul 07 '16 at 08:35 PM

I up to 4.12.5 and VS update 3, and try to create a c++ project There still the same error message ....

The project could not be compiled. Would you like to open it in Visual Studio?

Running D:/Programmes/Epic Games/4.12/Engine/Binaries/DotNET/UnrealBuildTool.exe test Development Win64 ->project="C:/Users/Ludovic/Documents/Unreal Projects/test/test.uproject" -editorrecompile -progress -noubtmakefiles >-NoHotReloadFromIDE ERROR: Couldn't find target rules file for target '-project=C:/Users/Ludovic/Documents/Unreal >Projects/test/test.uproject' in rules assembly 'UE4Rules, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'. Location: D:\Programmes\Epic Games\4.12\Engine\Intermediate\Build\BuildRules\UE4Rules.dll Target rules found: UE4Editor - D:\Programmes\Epic Games\4.12\Engine\Source\UE4Editor.Target.cs UE4Game - D:\Programmes\Epic Games\4.12\Engine\Source\UE4Game.Target.cs UnrealHeaderTool - D:\Programmes\Epic >Games\4.12\Engine\Source\Programs\UnrealHeaderTool\UnrealHeaderTool.Target.cs

avatar image Vana29 Jul 07 '16 at 09:16 PM

I try this fix : link text but when I create a project, I have a new error message ...

An error occurred while trying to generate project files.

Running D:/Programmes/Epic Games/4.12/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -progress UnrealBuildTool Exception: ERROR: A game project path was not specified, which is required when generating >project files using an installed build or passing -game on the command line

I don't understand, I add the path ...

avatar image Samantha Sutton ♦♦ STAFF Jul 08 '16 at 01:45 PM

Vana29,

We believe that you're missing your Project.Target.cs file. In order to get this file back, you'll have to recreate it yourself.

avatar image Vana29 Jul 08 '16 at 02:36 PM

the files already exist in folder alt text

source :

 // Copyright 1998-2016 Epic Games, Inc. All Rights Reserved.
 
 using UnrealBuildTool;
 using System.Collections.Generic;
 
 public class testTarget : TargetRules
 {
     public testTarget(TargetInfo Target)
     {
         Type = TargetType.Game;
     }
 
     //
     // TargetRules interface.
     //
 
     public override void SetupBinaries(
         TargetInfo Target,
         ref List<UEBuildBinaryConfiguration> OutBuildBinaryConfigurations,
         ref List<string> OutExtraModuleNames
         )
     {
         OutExtraModuleNames.Add("test");
     }
 }
target.png (4.9 kB)
avatar image Samantha Sutton ♦♦ STAFF Jul 08 '16 at 05:37 PM

Thank you for verifying that you have that file. Do you have your Server.Target.cs file? If not, that will also throw this error out.

Also, in the Intermediate folder, there is a "PCH.ProjectName.h.cpp" file. There should be a path to your projects header file. Check if the path is correct.

Update me when you can, thanks!

avatar image Vana29 Jul 09 '16 at 09:50 AM

I have not this files, so I create it and add some code with link text

I retry to cook, but fail ...(same error)

I found the "PCH.ProjectName.cpp"; The path of my project header file is ok.

avatar image Vana29 Jul 11 '16 at 09:45 AM

I launch the verification test, and there is no error message

avatar image Samantha Sutton ♦♦ STAFF Jul 11 '16 at 03:16 PM

Were you able to resolve your issue since no error messages were shown?

avatar image Vana29 Jul 11 '16 at 03:29 PM

No, this issue is still here...

avatar image Samantha Sutton ♦♦ STAFF Jul 11 '16 at 04:52 PM

When you say you launched a verification test, does that mean you created a new project to see if you're having this issue elsewhere? I am a tad bit confused with the wording.

Please make sure that you have UE 4.12.5 installed, Visual Studio 2015 with update 3 installed as well as the Windows SDK (build tools) installed as well.

You can make sure that the tools are updated by following these steps:

  • Open Control Panel

  • Click on Programs and Features

  • Locate and click on Microsoft Visual Studio 2015

  • Click update if it's available to you

  • If not, click on modify and make sure the SDK is added.

Make sure you restart after you've gone through all these steps.

Looking forward to hearing back from you, thanks!

avatar image Vana29 Jul 11 '16 at 07:35 PM

verification test : alt text

and the sdk : alt text

All the tools are updated, update 3 , sdk with outils is installed, (sorry for french)

verify.png (26.2 kB)
sdk w10.png (15.8 kB)
avatar image Samantha Sutton ♦♦ STAFF Jul 11 '16 at 08:03 PM

I have SDK Windows 10 (10.0.10240) ticked. Could you try that, please?

Thank you!

avatar image Vana29 Jul 12 '16 at 06:20 PM

I install the SDK Windows 10 (10.0.10240), reboot, but I have the same issue ...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I format and reinstall ue4. . Create new projet, build and cook dedicated server work !! Thanks for help :)

more ▼

answered Aug 24 '16 at 08:46 PM

avatar image

Vana29
31 3 6 7

avatar image Samantha Sutton ♦♦ STAFF Aug 29 '16 at 02:40 PM

You're welcome, so glad you were able to get through this issue.

Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Vana,

Please review step 5 in the dedicated server guide: https://wiki.unrealengine.com/Dedicated_Server_Guide_(Windows_%26_Linux)#5._Create_.3CMyGame.3EServer.Target.cs

And since you're building a Development Server in VS, you'll need to get the GitHub version of our engine as it can't be built in Binary unfortunately.

UE4 GitHub

Thank you!

more ▼

answered Jul 12 '16 at 07:19 PM

avatar image Vana29 Jul 13 '16 at 06:29 PM

I'm blocked at step one.... I can't create a c++ project And when I build and launch the engine from github, it is the same thing.... I can't compil any new c++ project

avatar image Samantha Sutton ♦♦ STAFF Jul 15 '16 at 04:05 PM

Are you using any sort of anti-virus that would cause a problem? Can you send me the new logs from when you're trying to compile a new c++ project from the Github built version of the engine?

avatar image Vana29 Jul 17 '16 at 08:30 PM

I desactivate my anti-virus and try to create some c+ project. Same issue...

I launch the build engine, but when the project is created, the engine crash, and VS open. I try to open by double-click on the uproject, but I have the message I must rebuild the project sources. I rebuild but I have the message :" project could not be compiled. Try rebuilding from source manually."

avatar image Samantha Sutton ♦♦ STAFF Jul 18 '16 at 09:12 PM

Can you upload the saved logs for me from your saved folder in the project? And also screenshot any error message that may pop up during the crash process?

Looking forward to hearing back from you! :)

avatar image Vana29 Jul 21 '16 at 05:30 PM

There are the logslink text

I have no windows or message during the crash :s

avatar image Samantha Sutton ♦♦ STAFF Jul 22 '16 at 05:09 PM

Open up the Epic Games Launcher, click on 'Installed Plugins' and make sure that there aren't any plugins enabled when you launch your project, and then try again.

Let me know what happens.

avatar image Vana29 Jul 26 '16 at 08:43 PM

I have not installed plugins alt text

plugin.png (9.1 kB)
avatar image Vana29 Jul 26 '16 at 08:44 PM

I thinks I will try in virtual machine for testing this issue

avatar image Samantha Sutton ♦♦ STAFF Jul 28 '16 at 09:30 PM

Let me know what you've found out from testing. Thanks.

avatar image Vana29 Jul 30 '16 at 07:40 AM

Even the virtual machine (Windows 10) I have the same issues and can't compil a new c++ third person project...

The project could not be compiled. Would you like to open it in Visual Studio? Running C:/Program Files (x86)/Epic >Games/4.12/Engine/Binaries/DotNET/UnrealBuildTool.exe test Development >Win64 -project="C:/Users/Ludovic/Documents/Unreal >Projects/test/test.uproject" -editorrecompile -progress -noubtmakefiles ->NoHotReloadFromIDE ERROR: Couldn't find target rules file for target '->project=C:/Users/Ludovic/Documents/Unreal Projects/test/test.uproject' in >rules assembly 'UE4Rules, Version=0.0.0.0, Culture=neutral, >PublicKeyToken=null'. Location: C:\Program Files (x86)\Epic >Games\4.12\Engine\Intermediate\Build\BuildRules\UE4Rules.dll Target rules found: UE4Editor - C:\Program Files (x86)\Epic >Games\4.12\Engine\Source\UE4Editor.Target.cs UE4Game - C:\Program Files (x86)\Epic >Games\4.12\Engine\Source\UE4Game.Target.cs UnrealHeaderTool - C:\Program Files (x86)\Epic >Games\4.12\Engine\Source\Programs\UnrealHeaderTool\UnrealHeaderTool.Tar>get.cs

avatar image Samantha Sutton ♦♦ STAFF Aug 01 '16 at 09:17 PM

Do you have the Substance plugin turned on? If so, disable it and try again.

avatar image Vana29 Aug 05 '16 at 09:20 PM

No, I have not this plugin.

avatar image Samantha Sutton ♦♦ STAFF Aug 13 '16 at 07:50 PM

Is your project a C++ project? If so, try to regenerate your project files and build the solution again.

Thank you!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question