x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to rebuild UnreaBuildTool on Mac?

Hello everyone!

I'm using Mac and I'm going to generate CMakeLists.txt for CLion.

Here is fresh CMakefileGenerator.cs file on Github: https://github.com/Nihlus/UnrealEngine/blob/3d0f469b3a356bf83add2f6dc9f50ed36d76c78e/Engine/Source/Programs/UnrealBuildTool/System/CMakefileGenerator.cs one user reported that all works on his Mac fine with CLion.

But I can't figure out how to patch UBT. I've been scoping internet for hours but I didn't find reasonable answer.

Sorry for newbie question here, but how can I cook this new file CMakefileGenerator.cs ?

Do I need to use Mono(Xamarin Studio) ? Do I need to build UnrealBuildTool from Mono?

I've found this solution: https://letstryunreal.wordpress.com/2015/05/06/setting-up-cmake-environment/ I've build UnrealEngine from source code and the UnrealEditor runs from Xcode Production->Run

but I simply can not 'rebuild' UBT in Xamarin cause of the error:

 The type or namespace name ‘App’ could not be found. Are you missing an assembly reference?

I'm really struggling for a half of a day already.

And one more question: I've generated CMakeLists.txt file with command:

 cd /path/to/UE4/Engine/Build/BatchFiles/Mac
 ./GenerateProjectFiles.sh -cmakefile -game -project “/path/to/Game.uproject"


And I opened it with CLion and even intellisece worked fine BUT it underlined some errors which are unseen in Xcode. Particularly it underlines with red some errors in .h header files. Will it be the same after patch?

Thank you so much for help in advance!

UPDATE:

So I've tried rebuild UBT with Xamarin Studio and Project Rider from JetBrains but it all seems doesn't work! Still I've got errors in all header files. The same thing in Qt Creator. Is that even possible to use CLion with unreal?

Product Version: UE 4.12
Tags:
more ▼

asked Jun 29 '16 at 12:44 PM in Installation & Setup

avatar image

hexenskull
6 1 3 4

avatar image Matthew J Jul 01 '16 at 07:13 PM

Hello hexenskull,

I don't believe that we officially support CLion for use with UE4 at this time. I'll be asking around to confirm my belief about if we support this or not, and if we do I'll look into how it should be done. I'll be sure to get back to you as soon as possible.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello hexenskull,

After asking around to be sure, I can confirm that we currently don't officially support CLion. I would suggest taking a look at the discussion about this on the forums as there are multiple users who are implementing their own support for the software.

Have a nice day!

more ▼

answered Jul 12 '16 at 04:44 PM

avatar image hexenskull Jul 16 '16 at 02:13 AM

Thank you!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question