x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Movie Texture doesn't work after package

Hello!

As stated, the Movie Texture doesn't play after I package the project. Everything works fine on the PIE. After package, there's only black screens where the movies should be playing.

I have tried blueprint controls, relative url, playback rate and can't seem to find a solution.

Product Version: UE 4.12
Tags:
more ▼

asked Jul 01 '16 at 09:25 AM in Packaging & Deployment

avatar image

13lumes
1 2 2

avatar image Samantha Sutton ♦♦ STAFF Jul 01 '16 at 06:12 PM

13lumes,

Could you please provide additional details about your movie texture? What type of file are you using? Does this happen with various types of movie files? Are you using the binary or source version of the engine?

Looking forward to hearing back from you, thanks!

avatar image 13lumes Jul 02 '16 at 09:53 AM

Hello Samantha!

Well, it's a 3MB .wmv, I've tried .avi and .mp4, all to no avail. The movie plays fine on the PIE but not on the package (except .mp4 that doesn't play at all).

I believe I'm using the binary version. Is there any way for me to confirm?

avatar image AndrewHurley Jul 05 '16 at 08:37 PM

Have you taken a read over our documentation to make sure you are setting up your media player asset correctly?

Media Framework

You need to place it in the Content/Movies folder within your folder directory so it packages and plays correctly in your project.

Let me know if you have further questions or need additional assistance.

Cheers,

Andrew Hurley

avatar image 13lumes Jul 06 '16 at 12:44 PM

Hello Andrew,

I have and ther movie is on the Content/Movies folder.. I made a blueprint with set texture parameter and simulated the video (it was a karaoke kind of thing) but I never found a sollution for the problem.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

It could be how you are calling the actual media player asset to play within the blueprint. Could you provide me with some screenshots or some simple steps to reproduce the issue on my end?

I wrote a simple tutorial which might help you resolve your issue. It goes through the process I use when calling the media player asset to playback in your project within a blueprint.

Media Player Asset Tutorial

Let me know if you have further questions or need additional assistance.

Cheers,

Andrew Hurley

more ▼

answered Jul 06 '16 at 03:15 PM

avatar image 13lumes Jul 06 '16 at 05:05 PM

I do believe I have followed your tutorial. I no longer have the blueprint but I'm curious aswell so I'll do it again as I did it and cross check with your tutorial and I will be back to you :)

Thank you

avatar image BigaCubensis Mar 02 '18 at 09:56 AM

Its still an issue in 4.18. Movie placed in Content/Movies folder, it works in PIE and Standalone, but doesnt in packaged version. Only black material shows.

avatar image ryan bechtel May 06 '18 at 07:08 PM

Did you ever get this resolved? Im having the same issue.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question