x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

3D UMG widget looks washed out

I created a 3D widget and placed it on the level. I disabled all the post processing in the editor. Yet the 3D widget's color looks washed out compared to adding the same widget directly to viewport.

This is how it looks if i add it to viewport directly. alt text

And this is how it looks if I add it as 3D widget into the world alt text Not just the color, 3D widget doesnt look as crispy as the viewport menu looks.

How to make the 3D widget looks exactly like how its look when I add it to viewport? Crispy and colors not washed out.

EDIT: After i disabled postprocessing nothing happened, but when i detach from controller in editor its crispy and not washed out. But when I posses controller in editor post processing is happening again. I added PostProcessVolume and disabled everything and checked everything and there is no difference at all! I unchecked everything still no difference. Its same washed out look. Does postprocess volume effect 3D widget at all??

Product Version: UE 4.11
Tags:
3d widget.jpg (45.2 kB)
more ▼

asked Jul 01 '16 at 10:16 AM in Using UE4

avatar image

plato.manchi
82 11 11 22

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Your 3D widget could be affected by the auto exposure settings in either your camera or any post process effects you have placed in the world: https://answers.unrealengine.com/questions/223267/3d-widget-glowing-in-a-dark-map.html "Eye adaptation is a feature in the engine that mimics the way your eyes adjust in real life depending on how bright or dark your surroundings are."

more ▼

answered Jul 15 '16 at 09:53 AM

avatar image

haruna
307 9 16 92

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

This is the top search result in Google, but the answer I found to solve the issue is here

more ▼

answered Feb 19 '19 at 10:41 AM

avatar image

Dover8
1 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question