x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

How to corectly rig/export skeletal mesh from Blender to UE4

I'm trying to make a ragdoll in UE4. I created and rigged a character in Blender and exported it as an FBX file.

First off, UE4 failed to create physics asset, because some bones were to small, even though all the bones are farely big (bigger than the character from premade projects). So when I manualy created the physics asset, all the bones just bunched up together and it was going all over the place, even when I turned off collision between bones.

Then I tryed to delete all the bone collision boxes except lower body and upper body. And when I started the simulations, the upper body flew about 100m up in the air an it stayed there, rigidly attached to the lower body.

Also I noticed, that when I view the skeleton in Persona and try to rotate individual bones, it takes multiple whole turns to rotate bones even a little bit. I don't know if that has to do anything with the problem, but it probably does.

Do I have to do some extra steps in Blender? Also, I don't know what exactly it is I have to avoid in Blender (like maybe bones that are attached but not connected).

Thank you for any help :)

Product Version: UE 4.10
Tags:
more ▼

asked Jul 01 '16 at 08:25 PM in Everything Else

avatar image

TimberTuc
13 3 5 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I finaly got it!

I Blender, under the scene settings, there is a scale option in the Units section. For the skeleton to work properly, you have to set scale to 0.01.

I knew you should do that before, but I thought it's not necesery and I just kina worked around it. It still worked fine with static meshes.

Anyway, this resolved all my issues. There is no more "bone size too small" error, the bones rotate just fine in Persona and ragddoll works much better now (still had to change it a bit).

I hope you'll find this useful if you have similar problem.

more ▼

answered Jul 04 '16 at 11:12 AM

avatar image

TimberTuc
13 3 5 7

avatar image Dartanlla Oct 21 '16 at 01:07 AM

This fixed my error, so I just want to give some specifics for others who are looking for a solution. I am using Blender 2.77 with the 7.4 FBX binary export and when I exported my skeletal mesh to UE4 it was huge (6000 units tall) and moving the bones in Persona did not move the mesh. As soon as I went back into the FBX export options in Blender and set the Scale from 1.0 to 0.01 it imported into UE4 perfectly and now the mesh moves with the bones. This is a strange error, but my guess is UE4 has some kind of size constraint. I also tried export to UE4 from Blender 2.68 and it did NOT need the scale set to 0.01 to work.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question