x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Instant crash opening 4.12.4

Hello all, I'm having a very bad time with 4.12. I have never been able to actually load it. I'm hoping someone at EPIC can help.

I get an instant crash when opening 4.12 by itself. I'm not even trying to load a project or anything. I'm just pushing the "launch" button under the engine version from the launchers library tab. I've tried all versions including 4.12.4.

At our company we really need to update to 4.12 for the new network improvements. Can someone help out?

4.11 and earlier versions launch with no issues. I'm running both Vive and Oculus apps/games with no issues.

Here's a zip of the ue4 crash report directory: link text

Heres a zip of my machines msinfo32.nfo system information: link text

Here's DxDiag log: link text

Let me know if you need any more information, or would like me to run any tests.

Product Version: UE 4.12
Tags:
dxdiag.txt (82.1 kB)
crash.report.zip (40.8 kB)
msinfo32.zip (120.1 kB)
more ▼

asked Jul 02 '16 at 04:53 AM in Bug Reports

avatar image

MagicBots
13 3 9 8

avatar image Goolog Jul 02 '16 at 06:20 AM

I am having this problem as well. The only thing I know about it so far is that this seems to happen with projects that have been converted from earlier versions of UE4. One of my projects won't open because of this. I proved it by making a fresh new project with blank code and no starter content pack. That project seems to open just fine. Not sure what's causing this issue yet though :( Hopefully we'll find out soon.

avatar image MagicBots Jul 03 '16 at 04:24 AM

My problem is different than that. UE 4.12 will not open at all. Not even launching the editor without a project.

avatar image MagicBots Jul 03 '16 at 05:04 AM

I noticed that the traceback mentioned it couldn't display all the info the crash because debug symbols were not included in my build. I added them in under options and now my traceback looks like this on crash:

UE4Editor_Core!FDebug::AssertFailed() [d:\build++ue4+release-4.12+compile\sync\engine\source\runtime\core\private\misc\outputdevice.cpp:440] UE4Editor_D3D11RHI!FD3D11DynamicRHIModule::FindAdapter() [d:\build++ue4+release-4.12+compile\sync\engine\source\runtime\windows\d3d11rhi\private\windows\windowsd3d11device.cpp:367] UE4Editor_D3D11RHI!FD3D11DynamicRHIModule::IsSupported() [d:\build++ue4+release-4.12+compile\sync\engine\source\runtime\windows\d3d11rhi\private\windows\windowsd3d11device.cpp:187] UE4Editor_RHI!PlatformCreateDynamicRHI() [d:\build++ue4+release-4.12+compile\sync\engine\source\runtime\rhi\private\windows\windowsdynamicrhi.cpp:81] UE4Editor_RHI!RHIInit() [d:\build++ue4+release-4.12+compile\sync\engine\source\runtime\rhi\private\dynamicrhi.cpp:172] UE4Editor!FEngineLoop::PreInit() [d:\build++ue4+release-4.12+compile\sync\engine\source\runtime\launch\private\launchengineloop.cpp:1456] UE4Editor!GuardedMain() [d:\build++ue4+release-4.12+compile\sync\engine\source\runtime\launch\private\launch.cpp:114] UE4Editor!GuardedMainWrapper() [d:\build++ue4+release-4.12+compile\sync\engine\source\runtime\launch\private\windows\launchwindows.cpp:126] UE4Editor!WinMain() [d:\build++ue4+release-4.12+compile\sync\engine\source\runtime\launch\private\windows\launchwindows.cpp:200] UE4Editor!__scrt_common_main_seh() [f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:264] kernel32 ntdll

avatar image MagicBots Jul 03 '16 at 05:04 AM

The crash appears to be happening when UE4Editor_D3D11RHI!FD3D11DynamicRHIModule is trying to find supporting adaptor(s). A quick search around tells me that RHI is the ue4 hardware rendering interface.

https://answers.unrealengine.com/questions/37056/what-is-rhi.html

In case it helps, I have a SLI setup with my machine, however, this crash happens even when I have SLI disabled in the NVIDIA control panel.

avatar image MagicBots Jul 03 '16 at 06:31 AM

Found this thread which was the same issue, and it appears the issue is between oculus launcher service / oculus server service and ue4.12. There is a workaround mentioned there of getting ue4.12 to launch by killing all of the oculus services in the windows task manager. This does fix the problem of ue4 crashing, but unfortunately I'm developing for the CV1 headset so this isn't really a solution or a workaround for me. As it stands I can't use CV1 with 4.12.

Here's that thread: https://answers.unrealengine.com/questions/429087/same-crash-on-412-preview-5-and-the-official-relea.html

avatar image wileyknight Jul 03 '16 at 02:14 PM

I am having the same issues and I am also running some Oculus development software as well as Leap Motion.

It was mentioned that this could be an issue with SLI (dual graphics cards) but I am not using that configuration. My graphics card is a Nvidia GeForce GT 750M in an ASUS notebook.

Possibly an Oculus SDK related issue. I'm going to remove my SDK and see if maybe the oculus for UE 4 Integration fixes it. Seems like if that were the case there would be a lot more complaints on this same topic but it's worth a try.

Here is my thread on the issue. https://answers.unrealengine.com/questions/445232/instant-crash-opening-4124.html

avatar image MagicBots Jul 05 '16 at 03:52 AM

Good suggestion. Thanks for that. I downloaded oculus' build of ue 4.12 and ran that. It works, but it's not up to date with latest in 4.12.4. It's on version 4.12.3 of the engine.

https://github.com/Oculus-VR/UnrealEngine/tree/4.12

I had tried earlier versions of 4.12 from Epic main builds and they had crashed the same way. Looks like there's work needed by EPIC or Oculus to get the released branch working with Oculus. Unfortunately I'm getting visual popping in the rendering in HMD with Oculus' build that I wasn't getting before, but at least I can work with it until they can get the release branch of 4.12 working.

I see there are quite a few differences between the two still: This branch is 7947 commits ahead, 43 commits behind EpicGames:4.12.

Maybe I was just wrong in assuming the released branches should always work out of the box with the headsets.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I can personally vouch that a rebuild of the source code for 4.12.5 with the update to change:

ChosenDescription = AdapterDescription[ChosenAdapter.AdapterIndex];

to

ChosenDescription = AdapterDescription[0];

and rebuild the editor will fix the problem.

more ▼

answered Jul 08 '16 at 01:03 AM

avatar image

wileyknight
41 2 3 4

avatar image MagicBots Jul 08 '16 at 01:26 AM

Will give it a try today. Thanks!

avatar image lucastakejame Aug 11 '16 at 09:37 PM

Did it work?

avatar image MagicBots Aug 11 '16 at 11:56 PM

I didn't actually get around to trying it because I needed to unSLI my machine to make it into 2 machines for network testing anyway. It seems like it works according to wileyknight. Give it a try?

avatar image wileyknight Aug 12 '16 at 03:03 AM

Yes, this works. I have applied the update to the source from git and compiled it into a functional editor.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question