x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Packaged game fails to load on my android devices

I recently packaged my game for development on Android devices. The game packages successfully, yet when I install it on any of my devices, it opens the splash screen for about ten seconds then returns to the home screen. I have tested this on a Samsung S5 phone and a Dell Venus tablet. Both have the same results. Is this a known issue, or is it something I am doing wrong?

Also, when I do a launch to device, it goes to the splash screen, and never goes any further (never loads my game).

Product Version: UE 4.12
Tags:
more ▼

asked Jul 04 '16 at 09:46 PM in Packaging & Deployment

avatar image

TrayJ
13 1 2 5

avatar image saeedc Jul 05 '16 at 10:29 AM

did you package your game for android Multi or All?

there is a bug for multi format android projects which contain sound files(ambient sounds).

try to package your project for a single texture format(ETC1, ETC2 or......).

avatar image TrayJ Jul 05 '16 at 04:15 PM

It packages fine. I tried Android All and ETC1. Both package successfully. It is opening the app on the device that is the issue. Packages and installs fine, but when I open it, it loads the splash screen, and then closes a few seconds later.

avatar image Samantha Sutton ♦♦ STAFF Jul 08 '16 at 06:04 PM

TrayJ,

In order to better assist you, I'm going to need for you to provide me the logs from your mobile device.

  • Attach your phone to the computer

  • Go here: C:\NVPACK\android-sdk-windows\tools

  • Open up Monitor.bat

  • Launch the program and save the logs

Make sure that you highlight all of the logs, because they do not save unless they're highlighted.

avatar image TrayJ Jul 11 '16 at 08:38 PM

I tried to do this, but it doesn't appear to be outputting any logs?

avatar image Samantha Sutton ♦♦ STAFF Jul 12 '16 at 03:49 PM

You need to click on your device and then the logs should start popping up once you've plugged your device to your computer and opened the game.

avatar image TrayJ Jul 12 '16 at 04:27 AM

Actually, I semi-solved the issue. Is there an issue with nativizing blueprints for android? When I unchecked that option, and repackaged, the file opened properly.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

So, I searched over Jira and I found a bug already entered in. It's a priority 2 - major bug in our system that's on our to do list. UE-31600 states that projects fail to package for Android with nativized blueprint assets enabled.

So this issue has been reported. If you notice anything else wonky, please let me know and I'll investigate further for you.

Thanks!

more ▼

answered Jul 12 '16 at 04:06 PM

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question