x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Bug] Character Appears under map when 'Run with dedicated Server'

Testing Criteria - Brand New project, C++ with BP. Nothing added. Only change to the Project is that I added two clients, set dedicated server, and play in new editor window. EVERYTHING else remains the same.

C++ project has Gamemode and Character C++ by default and a character BP by default.

Below are the versions in which the character spawns correctly and when they spawn under the map.

.4.8 - Works

.4.9 - Works

4.10 - Works

4.11 - Not Working - Client one always spawns under the map, client 2 spawns normally

4.12 - Not Working - Client one always spawns under the map, client 2 spawns normally

If anyone knows a work around to prevent this in the later versions, I would love to know it...

Product Version: UE 4.12
Tags:
more ▼

asked Jul 05 '16 at 10:11 PM in Bug Reports

avatar image

DrakeWalker
96 30 30 32

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey DrakeWalker-

I was able to reproduce the behavior and have entered the bug UE-32855 for investigation.

Cheers

Doug Wilson

more ▼

answered Jul 06 '16 at 05:51 PM

avatar image DrakeWalker Jul 08 '16 at 11:39 PM

Do you know if there is a work around?

avatar image Doug E ♦♦ STAFF Jul 11 '16 at 05:51 PM

You can uncheck the dedicated server checkbox to test non-dedicated server multiplayer however there is not a way to work around this with the checkbox marked in 4.12.

avatar image DrakeWalker Sep 20 '16 at 11:45 PM

I went to the Bug tracker for this bug to check the progress, but it looks like its not made public. Do you have any update on this?

avatar image Doug E ♦♦ STAFF Sep 21 '16 at 02:17 PM

Hey DrakeWalker-

This issue was fixed for 4.13 and should be included in the final version release. I have made the report public and you can find it here:

https://issues.unrealengine.com/issue/UE-32855

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question