x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can you limit physical materials to certain meshes?

What i want to do: I want to place an office chair on a floor, but have the wheels on the bottom of the mesh have a slight negative "friction value". So when the chair is standing up, it will slide more easily when collided with. I haven't found any workaround yet and an answer would be much appreciated. My initial thoughts where to apply a physical material to just the wheels or apply it to the floor and have all other objects ignore the physical material, but i haven't had any succes. Maybe someone knows how to get either one of theese solutions working or they have one of their own. Sorry for bad english.

Product Version: Not Selected
Tags:
more ▼

asked May 16 '14 at 10:47 PM in Using UE4

avatar image

fluzzywuzzy
5 1 3 6

avatar image Ben Halliday STAFF May 16 '14 at 10:59 PM

Hey fluzzy,

Applying a physical material with a negative Friction value onto the wheels ought to work. What isn't working specifically? Does your chair move at all when pushed? Do you have Simulate Physics enabled on your chair mesh? Is its collision set to PhysicsActor?

avatar image fluzzywuzzy May 16 '14 at 11:12 PM

Yes, the chair moves, but when i apply the Physical material to the floor, I get the desired result, but it applies to all of my objects on that surface. When i add it to the wheels (the wheels are not a seperate mesh but they have a seperate material) it doesn't seem to affect it at all. Do i need to have the wheels as a seperate mesh and then combine it with the chair mesh in unreal?

avatar image Ben Halliday STAFF May 16 '14 at 11:32 PM

That shouldn't make a difference. I just tested it on a simple box and it worked fine. It may seem silly, but try saving the physical material, the material, and the level, and then try. It's possible the Friction setting just hasn't taken effect yet.

avatar image fluzzywuzzy May 16 '14 at 11:39 PM

:/ I applied the same phys material to a box mesh just now aswell and that worked fine, maybe unreal cant identify where the material is applied since the collision is powered by the (in my case) auto generated collision mesh? Just a thought, I did exactly the same thing with the box as with the chair and tried them both at the same time. Box works, chair doesn't.

avatar image Ben Halliday STAFF May 16 '14 at 11:50 PM

Hm, no, the collision shouldn't be causing this. It might have something to do with how your Material sits on your mesh. Would you mind attaching your chair .uasset? I'd like to take a look at it and see if I can't figure out what's going on. Thanks!

avatar image fluzzywuzzy May 17 '14 at 12:06 AM

The forum said I couldn't send the file here, invalid file format or something. So a dropbox link will have to do. It's a prototype so i might have messed up somewhere but I honestly don't know where. https://www.dropbox.com/s/8tlhmgl9ca3kg0h/Chair.uasset

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey fluzzy,

I took a look at your mesh and I'm seeing the same thing. It looks like the only way to have a physical material affect the way the mesh interacts with other actors is to have it in Element 0, which affects the entirety of the mesh instead of just the material in that position.

I'm checking with the developers to see if this is intended and if there are any workarounds. In the meantime, your best option (assuming you don't want the entire chair to look like it's rolling around rather than just when it's upright) is going to be separating the wheels from the rest of the chair as a second mesh and attaching it to the chair body in the Scene Outliner, as you suggested earlier.

Sorry for the inconvenience. I will let you know as soon as I find something out.

Ben Halliday

more ▼

answered May 19 '14 at 03:31 PM

avatar image fluzzywuzzy May 19 '14 at 05:59 PM

Splitting the meshes and using a Physics Constraint Actor works perfectly, I will probably stick with this solution as it enables the top part of the now remodeled chair to rotate like it would in real life. I would however be incredibly grateful if you could update me on the original question if you come across a workaround as I (and others) might run in to the same problem but in other scenarios. And if it matters, I would just like to say that this is probably the best company/client interaction I have ever witnessed! Big ups to you and Epic!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question