x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Problem when importing Smooth Shaded object from blender

I have a problem when I import a .fbx mesh from blender into UE4. I get these dark shading artifacts. alt text However, when I change it from smooth shading to flat shading, these dark spots go away. alt text In both cases, when I export I have smoothing applied to face (as opposed to edge or normals only).

Product Version: UE 4.11
Tags:
more ▼

asked Jul 07 '16 at 07:29 PM in Using UE4

avatar image

zhegames
15 2 6 7

avatar image Battz Aug 24 '16 at 08:54 PM

This is a skeletal mesh you are importing right?

There are some options in blender to check on export:

alt text

The on Unreal import try these:

alt text

Hope this helps, this solved shading problems for me because it made sure I was able to import my smoothing groups.

export.png (12.5 kB)
import.png (4.4 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question