x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Cast Modulated Shadows Grayed Out

I was following the unreal documentation for Mobile Lighting, specifically with Dynamic Cascaded Shadow Maps. Before I was using Modulated Shadowing, but now it is blurred out. I disabled Dynamic Cascaded Shadow Maps and reenabled it but still no changealt text

Product Version: UE 4.12
Tags:
more ▼

asked Jul 07 '16 at 07:38 PM in Rendering

avatar image

Zack_McN
60 9 14 14

avatar image Pasta007 Jul 29 '16 at 11:33 PM

I had the "Cast Modulated Shadow" box become greyed out spontaneously as well. I had checked it a short while before, then unchecked it, and did some testing the dynamic lighting. When I went to check the "Cast Modulated Shadows" again, it was grayed out.

I got around this by creating another directional light. With the new light I had just created, I could check the "Cast Modulated Shadows" box as it was not greyed out.

avatar image Zack_McN Jul 31 '16 at 05:58 PM

thanks, never thought of that such a simple fix

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Zach,

I'm not able to see this happening on my end in any reproducible way. You didn't mention this in your post but the tags you used mention the Mobile Preview. I the default mobile preview and still did not see this issue.

I have a few questions for you:

  • Since you mention Mobile Preview Discrepancies, this would seem to imply that you see it not grayed out when not in mobile preview, right?

  • Is this only happening in this project in this level, or can you create a new level and it work as intended?

  • If not in this particular project, do it work correctly for you in other projects?

  • Is it safe to assume you're working on a Windows machine, or another OS?

  • If you have any additional steps to reproduce this can you post them here in detail?

Thank you!

Tim

more ▼

answered Jul 08 '16 at 01:09 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 887 101 878

avatar image Zack_McN Jul 08 '16 at 09:47 PM

Thank you for responding, I will answer them in order.

  • I created my project with mobile mode checked on, starter content and high quality checked off.

  • it works correctly in other levels.

  • It works correctly in other projects set to mobile

  • Windows

  • basically I was following the mobile lightening documentation, dont really know what I was specifically doing but I was testing out different lighten for a mobile game.

I dont believe this is a problem anymore since I found cascaded dynamic shadows works well. I am having one problem and that is the shadows are pure black? Also Im wondering if there are analt texty specific causes to graying out Cast Modulated Shadows?

avatar image Tim Hobson ♦♦ STAFF Jul 13 '16 at 07:16 PM

Unfortunately, I'm not able to reproduce it so it's either a fluke or there is a very specific way to get it to cause this issue that just isn't known.

As for the shadows casting black, if you're using a dynamic only light this will happen because there is no dynamic bounce light or Global Illumination. If you use a Stationary or static light you get the bounce light from static lighting, or you can simply add a Sky Light actor to soften the shadowing. Modulated Shadowing being disabled will not have an effect on this. Modulated shadowing allows you to set a color for the shadow which can be softer than the black that is from dynamic direct lighting.

avatar image Waves Mar 23 '17 at 07:47 PM

I have the same problem in UE 4.15 ... I was using Cast Modulated Shadows on the stationary directional light in my mobile project. I turned on Cascaded Shadow Maps by setting Dynamic Shadow Distance StationaryLight to 2000 with 1 cascade and no inset for moveable objects.

Now I can not turn it off. If I set the Distance back to zero, The Cascaded Shadow Map Options grey out. But 'Cast Modulated Shadows' is also greyed out and I can not interact with it.

avatar image Carrion Rabbit Jun 28 '17 at 06:58 PM

These simple repro steps work for me in 4.16:

  1. Add a directional light

  2. Set 'Dynamic Shadow Distance Stationary Light' to a non-zero value

  3. Check 'Inset Shadows For Movable Objects'

  4. Reset 'Dynamic Shadow Distance Stationary Light' to the default (0)

  5. Now 'Cast Modulated Shadows' is grayed out.

Simple workaround: temporarily set 'Dynamic Shadow Distance Stationary Light' to a non-zero value, reset offending customizations, then reset shadow distance back.

avatar image virtualHC Oct 25 '17 at 06:04 PM

I have the same issue. The proposed workaround seems to work, although I'm able to turn on/off the Cast Modulated Shadows but I see no difference in the shadow.

avatar image Zack_McN Dec 27 '17 at 07:32 PM

Pasta007 fix works. Also Carrion Rabbit's fix also works for me so I am marking this as resolved

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question