x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

テクスチャと同じ色で描画されない

Unlitのマテリアルにテクスチャを設定してCubeへ貼り付けているのですが明らかにテクスチャと同じ色でレンダリングされません。

インポートされたテクスチャについてはUE上ではほぼ同一のRGB値(誤差1程度)なのですがどうなっているのでしょうか...?(そもそもここで完全に同一でないのもおかしいですが...)

カメラのポストプロセスもカメラの設定でオフにしています。

どうすれば正常にレンダリングされますでしょうか?

よろしくお願いいたします。


こちらがインポートしたテクスチャになります。

alt text

描画されたもののスクリーンショットとの比較。

alt text

Product Version: UE 4.12
Tags:
red.png (391 B)
red2.png (17.4 kB)
more ▼

asked Jul 10 '16 at 07:22 AM in Japanese

avatar image

YUTARO NIWA
1 1 2 3

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

ライティングなどの影響を受けていない状態でそれであるのなら、ガンマ補正による問題の可能性があります。

テクスチャーエディターからsRGBのチェックを外してみるなりを試してみてください。

またガンマ補正については次にもまとまっています。→ http://togetter.com/li/827106

more ▼

answered Jul 11 '16 at 02:16 PM

avatar image

alwei STAFF
3k 125 19 53

avatar image YUTARO NIWA Jul 12 '16 at 03:19 AM

ありがとうございます。

そのページについては調査中既に見たことがあったのですが、内容が難解で結局どう設定すれば良いのか理解できませんでした。

ですのでsRGBのチェックの有無やpower2.2など一通り試しましたが、やはりテクスチャ通りの色にはなりませんでした。

すみませんが具体的な設定など教えていただくことはできますでしょうか?

avatar image alwei STAFF Jul 12 '16 at 03:43 AM

色表現についてはツールによっても違いが生まれますし、またUE4でどのようにレンダリングしているのかでも違います。

まずはどのようなツールで作成した、どのようなテクスチャー(ビット情報やテクスチャーの圧縮形式など)なのかという情報と、違っていると仰られているレンダリングはどのような手段で実行されたものなのかの詳細がないと、こちらからもアドバイスが難しいところです。

avatar image yuu Jul 12 '16 at 03:56 AM

トーンマップの影響で、レンダリングした結果の画面は色が変わります。 モデルはHDRバッファに書き込まれ、そのあとトーンマップを通じて最終レンダリング画像がLDRに変換されるので、その過程で色が変わったと思われます。 なので見た目としてはそれで正しいと思われます。

補足: PostProcessVolumeを外してもトーンマップ自体は行われます。 ToneMapperを入れ替えて、全部LDRで処理するようにしないとおそらく解決しません。

ただ、その場合、HDRの画面に明るい領域があった場合は白にクランプされるので、あまり推奨はされないと思われます。

avatar image YUTARO NIWA Jul 12 '16 at 02:04 PM

なるほど!ではテクスチャと同一の色にならないのはUE4的には仕様通りということですね。ありがとうございます。

ToneMapperの入れ替えについてあまり推奨されない件、了解しました。 もう少し調査した上でこれ以外解決法が見つからなかった場合、デザイナと相談してどうするか決めることにします。

avatar image motayoshi.san Jul 12 '16 at 06:01 AM

トーンマッパの置き換えはこちらを参考にすると良いと思います。

link text

avatar image YUTARO NIWA Jul 12 '16 at 02:05 PM

ありがとうございます!参考にさせていただきます!

avatar image YUTARO NIWA Jul 12 '16 at 01:56 PM

テクスチャについてはWindows10のペイントにて作成したものになります。フォーマットは32bitのPNGです。

レンダリングにつきましてはポストプロセス設定項目が多いので一旦検証中のプロジェクトをお渡しいたします。トーンマップの件もありますので、そもそもうまくできるか怪しいですが...

すみませんが、よろしくお願いいたします。 link text

myproject2.zip (100.0 kB)
avatar image alwei STAFF Jul 12 '16 at 02:41 PM

こちらのプロジェクト上のものを私の環境のUE4からPIEでプレイしたものと、テクスチャーをエクスポートして、Irfan Viewで表示させたものを横に並べて、スポイトツールを使ってRGB値を比較してみましたが、多少誤差はあってもほぼ一致しておりました。

alt text

またマテリアルを利用せず、ポストエフェクトも一切かからないUMG上でも実験しましたが結果は同じです。特殊な設定をしたわけでもありませんし、当然トーンマッパーを弄るようなことはやっていません。

おそらくUE4側の問題ではなく、何かしらのビュー環境の違いがある気がします。

avatar image YUTARO NIWA Jul 12 '16 at 03:25 PM

ほんとだ...!確かにほぼ一致していますね。 alwai様の環境についてお聞かせいただいてもよろしいでしょうか?

avatar image alwei STAFF Jul 12 '16 at 11:32 PM

特に特殊な環境ではないです。UE4.12.5でオープンし、上記でも言ったようにUE4からテクスチャーをエクスポートし、それをIrfanViewというビューワーで表示させてUE4上でプレイしたものと横に並べているのみです。

alt text

他のPCやツールで行っても症状は発生するのでしょうか?まずはそこから疑った方がいいかもしれません。

キャプチャ.png (537.5 kB)
avatar image YUTARO NIWA Jul 13 '16 at 12:34 PM

ちょっと他の環境でやってみて気づいた点があります。「設定 > エンジンの拡張機能設定 >ポストプロセス」が中以下になっていると正常に描画されるみたいです。

alwei様の環境ではどういった状態になっておりますでしょうか?

avatar image alwei STAFF Jul 13 '16 at 02:12 PM

確かに設定のエンジンの拡張機能設定でポストプロセスを落とすと、若干ながら色が変化するように見えます。(誤差程度ですが)

これの原因はデフォルトでUE4のポストプロセスが何も設定しなくても効いているためだと思います。これはプロジェクト設定からRendering→Default Postprocessing Settingsで切ることが可能です。

私の環境ではポストプロセスを切ってもほとんど変化がありませんが、もしかするとそちらの環境では効果があるかもしれません。特にBloomやAuto Exposureあたりが怪しいです。

avatar image YUTARO NIWA Jul 13 '16 at 02:42 PM

うーん...こちらではすべてチェックを外しても変化はありませんでした。 やはりToneMapperの入れ替えをするしかないのかもしれませんね。

avatar image alwei STAFF Jul 13 '16 at 03:36 PM

環境によって色合いが違うのであれば、トーンマッパーを置き換えても結局差がでてしまうと思います。そちらでは別環境でも全て色が暗くなってしまうのでしょうか?

試しに私の方でも別PCを使って確認をしましたが、やはり特に差は見受けられなかったです。例えばモニター側の色深度の設定によっても変わる可能性があります。

参考までに私の環境でのビデオカード上での色深度の設定だとこんな感じです。 alt text

モニターに対するビデオカード上の設定なども見ていった方がいいかもしれません。特にUE4はビデオカードの影響を受けやすいので。

キャプチャ.png (137.0 kB)
avatar image YUTARO NIWA Jul 14 '16 at 03:02 PM

こちらでもディスプレイの設定を見てみましたが、解像度以外は一致しています。 alt text

こちらの別の環境でも全て色が暗くなってしまっております。

で、試しにトーンマップの置き換えをやってみました。

こちらの環境では正常に表示されるようになりましたので、 alwei様の環境でどのように描画されるか見ていただいてよろしいでしょうか?

よろしくお願いいたします。 link text

myproject2.zip (261.8 kB)
pc_display.png (145.3 kB)
avatar image alwei STAFF Jul 14 '16 at 03:53 PM

なるほど。ビデオカードの違いなのかも微妙なところですね…

トーンマップの置き換えたものも確認しました。こちらではどうやら特に変化なさそうです。トーンマップ置き換え前と特に違いはみられませんでした。

根本的な原因はわかりませんが、他の環境でも問題がなさそうであれば解決済みと言えるかもしれません。

avatar image YUTARO NIWA Jul 15 '16 at 02:32 PM

確認ありがとうございます!

この件については一旦これで相談することにします。

色々と見ていただきありがとうございましたm( )m

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question