x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Unable to package/launch project - "Unknown error"

Hi,

I am really frustrated with this issue as I have found no working solutions online while searching everywhere for a whole week. I desperately need this fixed as my project is due very soon for a school assignment. This issue occurs both when I attempt to launch or package the project, or even the default/blank projects and I can't seem to narrow the issue down in the output log. I've attempted to upgrade my engine from 4.11 to 4.12 in hopes of fixing it, to no avail. I would really appreciate a solution, or any assistance at all.

The project is purely in blueprints with no C++ of my own, however I have purchased and included two asset packages from the Unreal Marketplace.

This is the output log when I try to package the project:

 MainFrameActions: Packaging (Windows (64-bit)): Running AutomationTool...
 MainFrameActions: Packaging (Windows (64-bit)): Automation.ParseCommandLine: Parsing command line: -ScriptsForProject=D:/Unreal Projects/Elementalists/Elementalists.uproject BuildCookRun -nocompile -nocompileeditor -installed -nop4 -project=D:/Unreal Projects/Elementalists/Elementalists.uproject -cook -stage -archive -archivedirectory=C:/Users/Myste/Desktop/
 Elementalists SDD Submission -package -clientconfig=Shipping -ue4exe=UE4Editor-Cmd.exe -clean -pak -prereqs -nodebuginfo -targetplatform=Win64 -build -CrashReporter -utf8output
 MainFrameActions: Packaging (Windows (64-bit)): Automation.Process: Setting up command environment.
 MainFrameActions: Packaging (Windows (64-bit)): BuildCookRun.SetupParams: Setting up ProjectParams for D:\Unreal Projects\Elementalists\Elementalists.uproject
 MainFrameActions: Packaging (Windows (64-bit)): Project.Build: ********** BUILD COMMAND STARTED **********
 MainFrameActions: Packaging (Windows (64-bit)): CommandUtils.Run: Run: C:\Program Files (x86)\Epic Games\4.12\Engine\Binaries\DotNET\UnrealBuildTool.exe Elementalists Win64 Shipping -Project="D:\Unreal Projects\Elementalists\Elementalists.uproject" -clean "D:\Unreal Projects\Elementalists\Elementalists.
 MainFrameActions: Packaging (Windows (64-bit)): uproject"  -remoteini="D:\Unreal Projects\Elementalists" -nobuilduht -NoHotReloadFromIDE
 MainFrameActions: Packaging (Windows (64-bit)): UnrealBuildTool: Performing full C++ include scan (building a new target)
 MainFrameActions: Packaging (Windows (64-bit)): UnrealBuildTool: ERROR: Unable to determine module type for D:\Unreal Projects\Elementalists\Source\Elementalists\Elementalists.Build.cs
 MainFrameActions: Packaging (Windows (64-bit)): CommandUtils.Run: Run: Took 0.912715s to run UnrealBuildTool.exe, ExitCode=5
 MainFrameActions: Packaging (Windows (64-bit)): Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.AutomationException: Command failed (Result:5): C:\Program Files (x86)\Epic Games\4.12\Engine\Binaries\DotNET\UnrealBuildTool.exe Elementalists Win64 Shipping -Project="D:\Unreal
 MainFrameActions: Packaging (Windows (64-bit)):  Projects\Elementalists\Elementalists.uproject" -clean "D:\Unreal Projects\Elementalists\Elementalists.uproject"  -remoteini="D:\Unreal Projects\Elementalists" -nobuilduht -NoHotReloadFromIDE. See logfile for details: 'UnrealBuildTool-2016.07.10-18.09.55.txt' 
 MainFrameActions: Packaging (Windows (64-bit)):    at AutomationTool.CommandUtils.RunAndLog(String App, String CommandLine, String Logfile, Int32 MaxSuccessCode, String Input, ERunOptions Options, Dictionary`2 EnvVars)
 MainFrameActions: Packaging (Windows (64-bit)):    at AutomationTool.CommandUtils.RunUBT(CommandEnvironment Env, String UBTExecutable, String CommandLine, String LogName, Dictionary`2 EnvVars)
 MainFrameActions: Packaging (Windows (64-bit)):    at AutomationTool.UE4Build.CleanWithUBT(String TargetName, UnrealTargetPlatform Platform, String Config, FileReference UprojectPath, Boolean ForceMonolithic, Boolean ForceNonUnity, Boolean ForceDebugInfo, String InAddArgs, Boolean ForceUnity, Dictionary`2 EnvVars)
 MainFrameActions: Packaging (Windows (64-bit)):    at AutomationTool.UE4Build.Build(BuildAgenda Agenda, Nullable`1 InDeleteBuildProducts, Boolean InUpdateVersionFiles, Boolean InForceNoXGE, Boolean InUseParallelExecutor, Boolean InForceNonUnity, Boolean InForceUnity, Boolean InShowProgress, Dictionary`2 PlatformEnvVars, Nullable`1 InChangelistNumberOverride,
  Dictionary`2 InTargetToManifest)
 MainFrameActions: Packaging (Windows (64-bit)):    at Project.Build(BuildCommand Command, ProjectParams Params, Int32 WorkingCL, ProjectBuildTargets TargetMask)
 MainFrameActions: Packaging (Windows (64-bit)):    at BuildCookRun.DoBuildCookRun(ProjectParams Params)
 MainFrameActions: Packaging (Windows (64-bit)):    at AutomationTool.BuildCommand.Execute()
 MainFrameActions: Packaging (Windows (64-bit)):    at AutomationTool.Automation.Execute(List`1 CommandsToExecute, CaselessDictionary`1 Commands)
 MainFrameActions: Packaging (Windows (64-bit)):    at AutomationTool.Automation.Process(String[] CommandLine)
 MainFrameActions: Packaging (Windows (64-bit)):    at AutomationTool.Program.MainProc(Object Param)
 MainFrameActions: Packaging (Windows (64-bit)):    at AutomationTool.InternalUtils.RunSingleInstance(Func`2 Main, Object Param)
 MainFrameActions: Packaging (Windows (64-bit)):    at AutomationTool.Program.Main()
 MainFrameActions: Packaging (Windows (64-bit)): Program.Main: AutomationTool exiting with ExitCode=5 (5)
 MainFrameActions: Packaging (Windows (64-bit)): Domain_ProcessExit
 MainFrameActions: Packaging (Windows (64-bit)): copying UAT log files...
 MainFrameActions: Packaging (Windows (64-bit)): BUILD FAILED
 PackagingResults:Error: Error Unknown Error
Product Version: UE 4.12
Tags:
more ▼

asked Jul 10 '16 at 08:21 AM in Packaging & Deployment

avatar image

Mysterise
21 1 3 5

avatar image Rudy Q ♦♦ STAFF Jul 11 '16 at 03:22 PM

Hello Mysterise,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you provide your entire log?

  2. Does this build error happen without the marketplace assets?

  3. What platform are you trying to package for?

avatar image Mysterise Jul 13 '16 at 02:35 PM

Thank you so much for responding.

  1. link text

  2. How do I remove the marketplace assets from my project? Do I simply delete the asset folders from my project?

  3. Windows 64-bit

Also if it helps, I have tried the "Cook Content for Windows" option that, after a relatively long time (compared to the packaging which was almost instant before the error), I have received the "Missing UE4Game Binary" message.

Additionally, I could not generate a Visual Studio project file where the error along the lines of "unable to determine module type for..." came up.

Thank you so much for responding, I really need this fixed ASAP as my school marks heavily depend on submitting and completing this project.

avatar image Rudy Q ♦♦ STAFF Jul 13 '16 at 03:14 PM

Hello Mysterise,

To clarify what I meant about the market place assets, I was asking if you could reproduce this issue in a clean project. Also, what version of 4.12 are you currently using? Are you using 4.12.5?

avatar image Mysterise Jul 14 '16 at 01:15 PM

I am using 4.12.5.

It seems that the packaging is successful when I attempt to package a clean project (I used the Side Scroller template which my project was based on).

This is the log for this instance of successful packaging: link text

I then tried to "port" my project over to this dummy project to see if packaging will work (I did this by copying the entire "contents" folder where all my assets & bps etc were stored), and surprisingly packaging worked. However I would still like this issue to be resolved as it would be much better to be able to continue the project on the original project file just to make sure nothing is left behind/changed during the porting.

avatar image Rudy Q ♦♦ STAFF Jul 14 '16 at 03:47 PM

Could you try adding an empty C++ class to your project and let me know if this changes anything? Could you also go through your project settings and look for differences between the clean project and the one that is failing to build?

avatar image Rudy Q ♦♦ STAFF Jul 18 '16 at 05:21 PM

Hello Mysterise,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.

Thanks,

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi, after I had initially resolved this issue by porting the project over to a new template, and after some further work and additions to the project, I've encountered a new error when packaging "PackagingResults:Error: Error Unknown Cook Failure".

I've made a thread here containing the full output logs.

more ▼

answered Jul 19 '16 at 01:08 AM

avatar image

Mysterise
21 1 3 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question