x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why does the plugin I created keep defaulting back to disabled?

Hello,

so I wrote my own plugin in C++ following the plugin tutorials from the unreal wiki. The plugin compiles and appears in my plugins list in the editor.

The problem is when I try to enable my plugin, it will switch back to disabled after I restart my editor.

The same happens with any built in plugin I try to enable/disable.

Is there something I am missing ? Some save option or some file I need to modify/checkout ?

Even if I toggle a plugin on/off and just switch to see another plugin from the list, the one I modified immediately toggles to its previous value.

So it is not really an issue with my plugin I think, but more a global issue I have with plugins not saving their enable/disabled status.

any idea ?

Chrys

Product Version: Not Selected
Tags:
more ▼

asked May 17 '14 at 03:20 PM in Using UE4

avatar image

Chrys
306 21 29 44

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

okay so It seems that I have fixed it, but I am not 100% sure how.

here is 2 things I did , one of them or both did the trick.

1) I made sure all intermediate and binary folders as well as the saved folder are not read only 2) I didn't press the "Restart Editor" button, but instead I went to manually hit File->Exit

now my plugin window shows up and seems to work fine.

If someone knows more please add a comment here, I will mark this as resolved now.

more ▼

answered May 17 '14 at 03:55 PM

avatar image

Chrys
306 21 29 44

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question