x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Blueprints that create instanced static meshes don't always get baked lighting

This is a pretty frustrating bug, as it is quite temperamental.

Basically if you create a blueprint in your scene that adds an instanced static mesh component, then add a bunch of instances to that and bake the lighting, the instances don't get lighting baked to them.

A temporary work around for this is to click Force No Precomputed Lighting, bake the lighting, then untick that again, then rebuild the lighting again.

Secondly, sometimes after a successful light build, closing and reopening UE4 causes the instances to lose their baked lighting as well.

Unfortunately this makes using blueprints and instances to layout scenes quite buggy.

Any help in this regard would be great. :) Richard

Product Version: UE 4.12
Tags:
more ▼

asked Jul 11 '16 at 09:08 AM in Bug Reports

avatar image

richst42
41 1 3 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hi Richard,

Do you have any repro steps that can cause this to happen consistently and a setup for your BP instances?

When I test this with a BP that has 9 instances setup, with their mobility set to Static I'm not seeing any issue at all on my end. I've reloaded the level, I have multiple copies of the BP in the level with multiple stationary lights and I'm not seeing any issue.

You may need to include more information and steps for me to reproduce on my end.

Thank you!

Tim

more ▼

answered Jul 13 '16 at 03:18 PM

avatar image

Tim Hobson ♦♦ STAFF
48.7k 888 103 880

avatar image richst42 Jul 13 '16 at 04:22 PM

Hi Tim,

Unfortunately It seems quite random... I can show you examples in my scene where just after building the lighting, only the blueprints responsible for placing instances in the scene didn't bake.

Here's the link to a project containing the blueprints I'm using. Nothing fancy though, the root + the instance static mesh node set to static.

[Removed Project Link]

I hope this helps resolve the issue. I have another example at home that I can also send if that helps. The next time it happens I'll post the output log as well.

Thanks for the response, Richard

avatar image richst42 Jul 13 '16 at 04:23 PM

alt text

avatar image richst42 Jul 13 '16 at 04:25 PM

alt text

avatar image Tim Hobson ♦♦ STAFF Jul 13 '16 at 04:50 PM

I'll mess around with the project and see if I can get it to happen. When you run the output log use the command DumpUnbuiltLightInteractions. I see that you've got the Lighting Needs to be Rebuilt warning in corner. If this BP is causing the issue that will be called out by this command.

avatar image richst42 Jul 14 '16 at 12:11 PM

Hi Tim, So I baked the lighting in my scene again, same result with the instances not baking correctly. Here's the output log if it helps

link text

outputlog.txt (8.7 kB)
avatar image Tim Hobson ♦♦ STAFF Jul 21 '16 at 05:58 PM

Hey Richard,

It looks like this may already be fixed in our internal 4.13 version that should be released late next month.

I was able to get a consistent repro of it dumping the baked lighting in 4.12.5 by just building lighting, loading another map, and then re-opening the one with the splines. It would always show like the spline light bake never took.

Testing with 4.13 I've tried this several times and in different ways than I did with 4.12.5 and it seems to stick this time. Once the previews for 4.13 start in the next couple of weeks you'll be able to test this out if you'd like. If it's still an issue please let me know and I'll investigate some more.

avatar image richst42 Jul 22 '16 at 08:40 AM

Thanks for the feedback Tim, much appreciated! Really looking forward to testing this out. Will give feedback once I've tried it with some of my levels. Cheers!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I been having the same issue that instanced static meshes are not baked in 4.12.5. Pressing "Build Lighting Only" has been a work-around for me. Pressing "Build" will reintroduce the issue.

Haven't tested in 4.13 yet.

more ▼

answered Sep 06 '16 at 06:35 AM

avatar image

Jaatuli
35 1 4 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I have a blueprint that constructs a "Add Static Mesh Component" with mobility set to Static. When going into Lightmap Density view, the mesh was appearing the tan color which I believe means no lightmap or moveable. Well my blueprint has a "Scene Component" as the root. When I set the mobility to to "Static" on the "Scene Component", the static mesh the gets constructed is now showing as a lightmap color with the checker. So if you have a scene component as the root, try changing the mobility to static. This worked for me, the lights bake correctly on the mesh. (Note: I'm using 4.13.1 release from source)

more ▼

answered Oct 02 '16 at 10:46 PM

avatar image

Sarlack
83 2 10

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question