x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

importing skeletal mesh ...and the geometry with eye material are not visible.

So i have my character bound to a skeleton and i noticed the eyes are not importing. The material and the joints are there for them, but the eyes geometry are not there..... why would this be? Its a pretty standard smooth bind with selected joints...

As a static mesh this imported fine.

Product Version: UE 4.12
Tags:
more ▼

asked Jul 11 '16 at 07:37 PM in Bug Reports

avatar image

kurylo3d
464 46 82 108

avatar image Matt.Williams Jul 11 '16 at 08:11 PM

Hey kurylo3D,

I don't know what modeling software you're using, but could your open up your exported FBX in that software and tell me if anything looks off? This is usually my starting point when diagnosing possible FBX issues.

Can you check what the "Normal Input Method" is set to with and without "Import as Skeletal" enabled? I believe skeletal has "compute normals" set as the default and static has "import normals". Depending on how the eyes are modeled, the engine may be recomputing your normals incorrectly.

-Matt W.

avatar image kurylo3d Jul 11 '16 at 08:17 PM

fbx imports fine back into maya.. no problems.

Also read my latest comment i ran a few more tests its driving me nuts..

avatar image kurylo3d Jul 11 '16 at 08:16 PM

As a static mesh this imported fine.

Even when i create 1 single joint nad bind all geometry to that... the eyes are not rendered... when in engine... makes no sense... yet on static mesh its fine......

I have literally tried exporting the eyes alone to obj... then importing that back in to bind to the skeleton.... and that didnt work either...

If i checkbox on the "use t0As Ref Pose" ... the eyes appear correctly, but the arm joints magically make the arms super tiny and as though the arms are non existnat.. its weird as hell.. wtf is happening???? i wasted 8 hours today on thsi nonsense.

avatar image kurylo3d Jul 11 '16 at 10:00 PM

Question, what version of fbx exporter/importer is recommended for unreal engine ... latest version 4.12.5 or whatever?

Because when i export/import from home.. i can see the eyes in my skeletal mesh fine. But from my work computer it does not give me the eye geometry. whats up with that?

avatar image kurylo3d Jul 12 '16 at 04:35 PM

More info.. at home... my export seems to go through fine... may be an older fbx... at work its not working fine.

BUT...

at work if i import at scale 100.0 (normal for this scene) it has no eyes... but if i export at scale of 1.0 and scale it to 100 manually... then it has the eyes and looks fine.. wtf!?

avatar image kurylo3d Jul 12 '16 at 04:42 PM

Anotehr thing i noticed... at scale of 100... the eyes are actually there, just really tiny as though they were somehow exported at scale of 1 while the rest of hte model was scale of 100... wtf?

Speaking of scales.. whatever measurement settings i have it set as in maya... meters or cm.. it still exports same size... its not working right... on my work comp at least.

avatar image Matt.Williams Jul 14 '16 at 08:43 PM

I can't really pinpoint one cause of this from these disparate test cases. The fact that T0As Ref Pose works indicates to me that the bind pose for the eye mesh is not correct. The combination of all your scale issues makes me think that the eyes were bound to the skeleton at a different scale than the rest of the character mesh.

Could you try selecting your skeleton and eye meshes and Exporting Selection (excluding the body)? Import this into the editor and see if you can find the eye meshes (something tells me they will be very small).

Another thing to try is to unbind the skin (you can copy the skin weights if you don't want to re-paint the weights), then scale everything to the correct size and zero your transforms. Then re-skin your mesh (you can probably get away with copying skin weights from the old skinning too)

We highly recommend modeling at full scale where 1cm in Maya=1 unreal unit in the engine. One of the main issues we get from users on Blender(And I know you're not in Blender) is that their bones are at Scale 100 when exported to fbx because the default settings in Blender make this happen. We have to get people to switch from mm to cm before modeling everything.

If none of this helps, could you send me your .mb/.ma file in a PM on the forums?

-Matt W.

PS - We have supported FBX 2016 since 4.11.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I actually found the problem. To make it work correctly I kept the model scale in Meters, but i switched the units to cm in maya. Then i exported teh fbx as cm or auto.... Then in unreal i imported as scale of 1.0... and it worked fine.

I have no idea why messing with unit measurements would make the eye geometry come in at a different scale then the rest of the body in the same import on the same rig.... but whatever... it works now with this way...

That being said.. 1cm is not 1 unit in my maya scene... 1 meter is 1 unit... its a crap load of cm .. though switching the unit to cm and exporting it as such works... and even is the correct scale in unreal with unit of 1.0 import.... so who the hell knows why.

more ▼

answered Jul 14 '16 at 09:42 PM

avatar image

kurylo3d
464 46 82 108

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question