x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why does my terrain have collision issues?

Hi,

I'm facing issues when I have meshes colliding with the terrain. The object apparently ignores the terrain and just goes through it. I've tried with many different mesh settings (both in the mesh editor and the physics/collision section of the actor) and it doesn't change anything. I'm not sure if I should file this under "bug reports" or in "using UE4" since I'm probably messing up the settings somewhere. Just in case, I would appreciate it if you would tell me what settings would need to be applied to the terrain / mesh in order to make the mesh bounce off the object.

http://i.imgflip.com/8vaeo.gif

Thanks in advance.

Product Version: Not Selected
Tags:
more ▼

asked May 17 '14 at 08:17 PM in Using UE4

avatar image

jfaztk
326 45 62 72

avatar image Hyperloop May 17 '14 at 11:07 PM

What collision settings do you have applied to the cube?

avatar image jfaztk May 17 '14 at 11:17 PM
avatar image TJ V ♦♦ STAFF May 19 '14 at 01:55 PM

And is your Landscape's collision set to BlockAll?

avatar image jfaztk May 19 '14 at 07:52 PM

Yes, it is

avatar image TJ V ♦♦ STAFF May 19 '14 at 09:02 PM

It's hard to tell in your gif because its a bit dark. The wall that the cube goes through, that is just a raised part of the landscape you are walking on correct? Or is it a separate mesh or another landscape intersecting?

avatar image jfaztk May 19 '14 at 09:03 PM

It's a raised part of the landscape that I am walking on. And sorry about that, I was in a bit of a hurry when I recorded it :P

avatar image TJ V ♦♦ STAFF May 19 '14 at 09:18 PM

Its no problem. I set everything to your settings but still haven't been able to reproduce it. I do remember seeing something a while back about collision sometimes acting weird on steep landscape inclines. I'll keep looking into it. In the meantime could you try reproducing it in a new level and a new project? Just to see if it is confined to that single level.

avatar image jfaztk May 19 '14 at 09:22 PM

Eh... This is a bit embarrassing, but it works when I create a new level. It still does not work on the previous one though. I can't seem to figure out why :S

avatar image Virgil Tuser Sep 17 '14 at 09:42 PM

paragonx9 - this is most definitely not your fault - remaking the map is actualyl the only fix that I know of so far. I am having the same problem as well.. Using version 4.4 and it clearly isn't fixed - I read about this issue in many places and it seems like a serious problem in UE4. Surely there has to be some official fix coming this way for it. I really don't want to remake my landscape, please.. I have applied a lot of props, vegetation and tons of manual vertex paint :( please help!! CCD doesn't help at all with this situation. Only pawn collision works which is rather rarely used.

EDIT: I meant to say version 4.4.2, sorry, it was late >.<

avatar image neighborlee Oct 07 '14 at 11:54 PM

I have the problem too. Ill try creating a new project . Atm, I exported a terrain from unity via 16bit raw format windows, and imported into ue4. I never used to have this problem, so I was indeed wondering what the deal was. I made a new project and it doesn't do this . Sigh , I must be able to import that terrain as it would take far too much work to recreate it in UE4. I guess I could try importing raw into PS and exporting a PNG.

Hope this gets resolved as im stuck at this point.

cheers nl

avatar image TJ V ♦♦ STAFF Oct 09 '14 at 01:49 PM

Hi neighborlee,

Which version of the editor are you currently using?

avatar image neighborlee Oct 10 '14 at 10:55 PM

Figured out on forums..I had to go into quicksettings and set ,quickserttings > engine scalability > EPIC,and voila..instant fix.

Ty anyway tj ;)

avatar image seantriana Dec 04 '14 at 04:36 AM

Oh! This one works for me! But now I'm worried about the framerate...

avatar image Guy Paddock Mar 02 '15 at 03:45 PM

This is not an actual fix, just a workaround in the editor. At run-time, depending upon the engine settings, collision still fails to work properly.

avatar image Guy Paddock Mar 02 '15 at 03:50 PM

Still seeing this issue in UE 4.7.1. We were able to work around it when previewing in the editor by deleting all terrain and undoing, but this doesn't seem to work for the packaged version of the map. The collision map is completely wrong for the geometry -- our pawn seems to encounter invisible barriers where there is no geometry, and encounters slopes that fall through the terrain.

It does not happen when previewing through the editor after deleting the terrain and undoing. It happens consistently when playing as a "standalone game" or in the packaged version. If we set the LOD to Epic, it still happens, but portions of the collision mesh seem to be accurate. If we set the LOD to Low, Pawns just fall through the terrain without collision.

The collision on the terrain is "BlockAll". We've tried every setting that would still apply to the Pawn without success. Our pawn is a round ball (based on the rolling starter).

avatar image Achilleon Mar 03 '15 at 01:24 PM

I am not sure if that would help you, but I got a solution which worked for me.

Chose Scuplt tool from Landscape editor. And make the Brush size 50000000. Max you can do. Size doesn't matter but just speeds things up.

Then lower Tool Strenght to 0.00000001. You will not see no change but this will force the landscape to rebuilt everything. Be warned that it will ask you to build lightning even nothing changed.

This is really a big problem. Surprising to see that there is no check or rebuild for landscape collision, but this worked for me at least. Hope this helps to you too. :)

PS: This happens ALOT when you add extra landscape components to an exsisting one.

avatar image neighborlee May 28 '18 at 07:16 PM

DOesn't help here, darn ;0-0,nothing works, a few areas only but thats a few too many.Not workable. OLD thread I know but there aren't many that address this--bad math ?

(comments are locked)
10|2000 characters needed characters left

5 answers: sort voted first

I created a new terrain on that same map and it works now for some reason. I'll just recreate that terrain. Thank you, and sorry about wasting your time XD

more ▼

answered May 19 '14 at 09:23 PM

avatar image

jfaztk
326 45 62 72

avatar image TJ V ♦♦ STAFF May 19 '14 at 09:26 PM

Its not a problem at all. I'm glad you found a work around. If it happens again please post back here and we will dig into it further.

Have a good day, TJ

avatar image MarcelBlanck Sep 17 '14 at 09:51 PM

I had that issue quite a lot when using terrain. Suddelny collision is gone. And the only way to have terrain collision again is to create a new terrain. I have seen quite a lot posts about this issue.

I also had that problem again with 4.3 after the fix, that might have fixed something, but not this problem.

Just search for "landscape collision" here and you will find people still having problem.

avatar image Virgil Tuser Sep 17 '14 at 10:11 PM

I have just opened a new ticket for this problem. It needs a lot more attention that it has been given so far, apparently. The problem floats around for a long time now and I'm sure it happens to many, even though only a few actually report it here.

avatar image dimitrov Oct 15 '14 at 10:42 PM

Another report from me: I created a terrain in 4.4. Then converted it to 4.5 preview. Now I opened it with 4.5 and added a pawn for the first time. It successfully stands on the terrain, but when I drive over a particular flat area (that I did not elevate), the buggy drops in the space below. I decided to raise the terrain in that area to see what happens. Now there is a new problem - the buggy collides in invisible objects and cannot even go over that area any more. I have no problems with other areas of the terrain, not even with other flat areas. I tried building the project. I also tried to find a way to visualize the collision shape of the terrain, but there doesn't seem to be a way to do it. The things that the buggy collides into don't feel like simply invisible objects - the way it reacts is really strange.

avatar image Chariots Dec 04 '14 at 11:37 AM

I have the same issue. We started with 4.3, now working on 4.5, there's a collision issue with 1 landscape out of 100, can't delete and reimport it because it is part of world composition.

It has the same collision settings, same everything with all other landscapes, but the collision just doesn't work when dragging dropping new meshes on it. Very frustrating.

(comments are locked)
10|2000 characters needed characters left

I had this problem with 4.13 and may have fixed it

my terrain map was suddenly full of small invisible colliders so i decided to remove the last few fbx mesh imports and the problem seems to have now gone away

not sure if the importing causes the problem but it has saved my terrain map from having to be restarted so worth a try maybe

more ▼

answered Jan 05 '17 at 08:42 AM

avatar image

damianStanley
11 1 1

avatar image FatBalloon Sep 28 '17 at 12:59 PM

This literally saved my life. Thank you for posting this. I had a problem where my terrain suddenly was going nuts with collision thus I deleted the latest imported meshes and it solved the issue! Apparently, there's a mesh with a huge horrible collision that was really throwing off my map. Thank you.

avatar image FatBalloon Sep 28 '17 at 02:04 PM

Here's my mesh. Notice the horrible collision going way outside the map. alt text

(comments are locked)
10|2000 characters needed characters left

I found the best solution for me yet - Delete certain components from the landscape and Add new components in their place. (The engine tries to construct the new components so that they fit nicely in the terrain.)

I am not sure what the exact behavior is, but I have a feeling that when I did this, some other components that were not working before, got fixed as well (without deleting and adding them).

I tried this approach because in my case the problem was only in a small part of my terrain - the pawn was dropping into the void below, as if there was no collider. The rest of the terrain worked fine.

And of course, I think that this needs a proper fix...

more ▼

answered Oct 15 '14 at 10:54 PM

avatar image

dimitrov
88 10 13 16

(comments are locked)
10|2000 characters needed characters left

I'm using 4.7.2 and I'm getting this problem with my terrain, its quite frustrating if I really had to re create the terrains. Has anybody found new solution? I've tried all methods mentioned above, except recreate it...

more ▼

answered Mar 05 '15 at 04:36 PM

avatar image

L_A_L_I_90
1

avatar image Hyperloop Mar 05 '15 at 07:06 PM

Agreed. Rebuilding art assets isn't really a sustainable solution to the problem.

(comments are locked)
10|2000 characters needed characters left

The issue is still here, and I'm about to jumpship to Lumberyard- they have 32bit terrain anyway,whichis MUCH smoother--

more ▼

answered May 28 '18 at 07:51 PM

avatar image

neighborlee
31 1 9 10

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question