x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Add Controller Input not working in packaged game

Hi, I have quite an odd problem on my hands. I use axes LookUp and Turn, bound to mouse Y and X respectively, to control my character's looking movement. Both of these axes work fine in editor, but when I package the game, only the vertical axis works properly, however I can still see the horizontal axis' value. It's just the input event that doesn't seem to work, although both events are structured the exact same way. As per other threads, I both restarted the editor multiple times and made sure I wasn't turning mouse control to UI only and never turning it back to the game.

Here's my script.

Product Version: UE 4.12
Tags:
more ▼

asked Jul 12 '16 at 08:49 PM in Blueprint Scripting

avatar image

LethalClips
21 2 6

avatar image Matthew J Jul 15 '16 at 05:01 PM

Hello LethalClips,

This is quite odd as I don't see anything particularly wrong with that blueprint. Just as something to try, have you tried removing everything between Input Axis Turn and Add Controller Yaw Input and see if it works correctly then? If it does, it at least gives us an idea of where the issue is. If it doesn't, then we know that the issue is likely elsewhere.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Matthew! I ended up posting on /r/unrealengine about this issue, and found another person with the same issue, who told me to turn off "Nativize Blueprint Assets", which I was using in my project. This actually fixed my problem. I was going to submit a bug report on this, but I couldn't figure out any way to reproduce it. Creating a clean project didn't give the same result, but at the time I posted this, there wasn't much of anything in my project besides a few other C++ classes. This script is in a Player Controller which is a child of a Player Controller C++ class with only one method as of now (a fire method for a weapon).

more ▼

answered Jul 15 '16 at 05:07 PM

avatar image

LethalClips
21 2 6

avatar image Matthew J Jul 15 '16 at 05:18 PM

Glad to hear that it's fixed on your end. Nativize Blueprint Assets is still an experimental feature at this time so some odd behavior is expected but I'll attempt to try to reproduce it locally. If you find any more information, please let me know but at the moment I'll be marking this as resolved.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question